summaryrefslogtreecommitdiff
path: root/ui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ui/CMakeLists.txt')
-rw-r--r--ui/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/ui/CMakeLists.txt b/ui/CMakeLists.txt
new file mode 100644
index 0000000..597de26
--- /dev/null
+++ b/ui/CMakeLists.txt
@@ -0,0 +1,8 @@
+find_package(Qt5 COMPONENTS Widgets)
+
+IF(Qt5_FOUND)
+ option(BUILD_QT "Build the Qt 5 user interface" ON)
+ IF(BUILD_QT)
+ add_subdirectory(qt5)
+ ENDIF(BUILD_QT)
+ENDIF(Qt5_FOUND)