summaryrefslogtreecommitdiff
path: root/ui/qt5/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ui/qt5/CMakeLists.txt')
-rw-r--r--ui/qt5/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/ui/qt5/CMakeLists.txt b/ui/qt5/CMakeLists.txt
new file mode 100644
index 0000000..5620cf7
--- /dev/null
+++ b/ui/qt5/CMakeLists.txt
@@ -0,0 +1,19 @@
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+
+set(UI_SOURCES
+ horizonwizard.cc
+ horizonwizardpage.cc
+ horizonhelpwindow.cc
+ main.cc
+
+ intropage.cc
+ networkingpage.cc
+
+ horizon.qrc)
+add_executable(horizon-qt5 ${UI_SOURCES})
+target_link_libraries(horizon-qt5 Qt5::Widgets)
+
+IF(INSTALL)
+ # add_executable(horizon-run-qt5 ${RUN_QT_SOURCES})
+ENDIF(INSTALL)