summaryrefslogtreecommitdiff
path: root/ui/qt5/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ui/qt5/CMakeLists.txt')
-rw-r--r--ui/qt5/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/ui/qt5/CMakeLists.txt b/ui/qt5/CMakeLists.txt
index 87f4d64..a138f07 100644
--- a/ui/qt5/CMakeLists.txt
+++ b/ui/qt5/CMakeLists.txt
@@ -78,6 +78,11 @@ IF(INSTALL)
pkg_check_modules(XKBFile REQUIRED xkbfile)
pkg_check_modules(LIBX11 REQUIRED x11)
pkg_check_modules(LibCap REQUIRED libcap)
+ find_library(SKARNET NAMES skarnet)
+ find_library(BCNM NAMES wpactrl PATH_SUFFIXES bcnm)
+ if(BCNM STREQUAL "BCNM-NOTFOUND")
+ message(FATAL_ERROR "BCNM is required for the Installation Environment.")
+ endif()
target_link_libraries(horizon-qt5 ${BCNM} ${SKARNET} ${LIBUDEV_LIBRARIES} ${LibCap_LIBRARIES} ${LIBX11_LIBRARIES} ${XKBFile_LIBRARIES} diskman)
add_executable(horizon-run-qt5 ${RUN_QT_SOURCES})
target_link_libraries(horizon-run-qt5 Qt5::Widgets)