summaryrefslogtreecommitdiff
path: root/ui/qt5/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ui/qt5/CMakeLists.txt')
-rw-r--r--ui/qt5/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/ui/qt5/CMakeLists.txt b/ui/qt5/CMakeLists.txt
index 9ac6372..7fd1ebf 100644
--- a/ui/qt5/CMakeLists.txt
+++ b/ui/qt5/CMakeLists.txt
@@ -31,7 +31,11 @@ ENDIF(UNSUPPORTED_NONFREE_FIRMWARE)
include_directories(${CMAKE_SOURCE_DIR}/3rdparty)
add_executable(horizon-qt5 ${UI_SOURCES})
-target_link_libraries(horizon-qt5 Qt5::Network Qt5::Widgets)
+target_link_libraries(horizon-qt5 Qt5::Network Qt5::Widgets crypto)
+
+IF("cxx_std_17" IN_LIST CMAKE_CXX_COMPILE_FEATURES)
+ set_property(TARGET horizon-qt5 PROPERTY CXX_STANDARD 17)
+ENDIF()
install(TARGETS horizon-qt5 DESTINATION bin)