summaryrefslogtreecommitdiff
path: root/ui/qt5/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ui/qt5/CMakeLists.txt')
-rw-r--r--ui/qt5/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/ui/qt5/CMakeLists.txt b/ui/qt5/CMakeLists.txt
index cc56ed4..a8779fd 100644
--- a/ui/qt5/CMakeLists.txt
+++ b/ui/qt5/CMakeLists.txt
@@ -72,4 +72,7 @@ IF(INSTALL)
add_executable(horizon-run-qt5 ${RUN_QT_SOURCES})
target_link_libraries(horizon-run-qt5 Qt5::Widgets)
target_compile_definitions(horizon-run-qt5 PRIVATE IN_RUNNER)
+ IF("cxx_std_17" IN_LIST CMAKE_CXX_COMPILE_FEATURES)
+ set_property(TARGET horizon-run-qt5 PROPERTY CXX_STANDARD 17)
+ ENDIF()
ENDIF(INSTALL)