summaryrefslogtreecommitdiff
path: root/ui/qt5/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ui/qt5/CMakeLists.txt')
-rw-r--r--ui/qt5/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/ui/qt5/CMakeLists.txt b/ui/qt5/CMakeLists.txt
index 7fd1ebf..14d5399 100644
--- a/ui/qt5/CMakeLists.txt
+++ b/ui/qt5/CMakeLists.txt
@@ -25,6 +25,12 @@ set(UI_SOURCES
horizon.qrc)
+IF(INSTALL)
+ LIST(APPEND UI_SOURCES commitpage.cc)
+ELSE(INSTALL)
+ LIST(APPEND UI_SOURCES writeoutpage.cc)
+ENDIF(INSTALL)
+
IF(UNSUPPORTED_NONFREE_FIRMWARE)
LIST(APPEND UI_SOURCES firmwarepage.cc)
ENDIF(UNSUPPORTED_NONFREE_FIRMWARE)