summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantin <ria.freelander@gmail.com>2017-04-23 00:31:58 +0300
committerKonstantin <ria.freelander@gmail.com>2017-04-23 00:31:58 +0300
commitd4d9fe7026734523244b0fe6f873e5efb637d0ee (patch)
tree3544c01dfa1e5cc75225ee85c8d8eb25a667839d /CMakeLists.txt
parentc0a164db0e0d0ba7678e6ad4a8226efec7424cf1 (diff)
downloadmusl-locales-d4d9fe7026734523244b0fe6f873e5efb637d0ee.tar.gz
musl-locales-d4d9fe7026734523244b0fe6f873e5efb637d0ee.tar.bz2
musl-locales-d4d9fe7026734523244b0fe6f873e5efb637d0ee.tar.xz
musl-locales-d4d9fe7026734523244b0fe6f873e5efb637d0ee.zip
CMake: Search for libintl.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b188ad3..d78453c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,8 +7,12 @@ set(GETTEXT_PACKAGE "musl-locales")
set(MUSL_LOCPATH ${CMAKE_INSTALL_DATAROOTDIR}/i18n/locales/musl CACHE PATH "Locales directory" FORCE)
configure_file(config.h.in config.h)
configure_file(locale.in 00locale.sh)
+find_package(Intl)
set(LOCALE_SOURCES locale.c categories.c categories.h config.h)
add_executable(locale ${LOCALE_SOURCES})
+if(Intl_LIBRARIES)
+ target_link_libraries(locale ${Intl_LIBRARIES})
+endif()
target_compile_options(locale
PRIVATE $<$<COMPILE_LANGUAGE:C>:-std=gnu11 -Wno-pedantic>
)