summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-04-27 08:34:34 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-04-27 08:34:34 +0000
commit7708a261d5ed03cf77b82204a6558d9651da7e8b (patch)
treebd2de0d429c99e62eb01a3fb5f8699f8d1779a92
parentb736eadbbf54d2b5fc7059a601353bee863b76f9 (diff)
downloadpackages-7708a261d5ed03cf77b82204a6558d9651da7e8b.tar.gz
packages-7708a261d5ed03cf77b82204a6558d9651da7e8b.tar.bz2
packages-7708a261d5ed03cf77b82204a6558d9651da7e8b.tar.xz
packages-7708a261d5ed03cf77b82204a6558d9651da7e8b.zip
user/lksctp-tools: install header properly
-rw-r--r--user/lksctp-tools/APKBUILD9
-rw-r--r--user/lksctp-tools/header-install.patch32
2 files changed, 38 insertions, 3 deletions
diff --git a/user/lksctp-tools/APKBUILD b/user/lksctp-tools/APKBUILD
index 666515b81..c625bb4d5 100644
--- a/user/lksctp-tools/APKBUILD
+++ b/user/lksctp-tools/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=lksctp-tools
pkgver=1.0.18
-pkgrel=0
+pkgrel=1
pkgdesc="Tools for using SCTP on Linux"
url="http://lksctp.sourceforge.net/"
arch="all"
@@ -10,7 +10,9 @@ license="GPL-2.0-only AND LGPL-2.1-only"
depends=""
makedepends="autoconf automake"
subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/sctp/$pkgname/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/sctp/$pkgname/archive/v$pkgver.tar.gz
+ header-install.patch
+ "
build() {
./bootstrap
@@ -32,4 +34,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="1d7275fadc0f2270865307cff2645810e9bab6c1a97e70be6115cace737334dbdd87a072fae25b89dd9cac2e05974556542de70ea8ef70b9e4f14873c82a5055 lksctp-tools-1.0.18.tar.gz"
+sha512sums="1d7275fadc0f2270865307cff2645810e9bab6c1a97e70be6115cace737334dbdd87a072fae25b89dd9cac2e05974556542de70ea8ef70b9e4f14873c82a5055 lksctp-tools-1.0.18.tar.gz
+1047d40a961433ef072404aad31c976300e4631ef4ccc4abd505a1ae2dfbb169982079f6932eaab5d91c564f3f6949adf97c44ac155d80b4161c39931f569590 header-install.patch"
diff --git a/user/lksctp-tools/header-install.patch b/user/lksctp-tools/header-install.patch
new file mode 100644
index 000000000..1ebe6c803
--- /dev/null
+++ b/user/lksctp-tools/header-install.patch
@@ -0,0 +1,32 @@
+From 378560050a8f93786c590cc99a55461666205b61 Mon Sep 17 00:00:00 2001
+From: Xin Long <lucien.xin@gmail.com>
+Date: Fri, 24 Aug 2018 01:13:32 +0800
+Subject: [PATCH] build: fix netinet/sctp.h not to be installed
+
+After libcnetinet_HEADERS was set to sctp.h.in, netinet/sctp.h can
+no longer be installed into ${includedir}.
+
+Since "AC_CONFIG_HEADERS([src/include/netinet/sctp.h])" is already
+added into configure.ac, there's no need to generate sctp.h by
+automake.
+
+So we simply set libcnetinet_HEADERS back to sctp.h.
+
+Fixes: 9607dd85e70a ("netinet/sctp.h: dynamically build based on system setup")
+Signed-off-by: Xin Long <lucien.xin@gmail.com>
+Signed-off-by: Marcelo Ricardo Leitner <marcelo.leitner@gmail.com>
+---
+ src/include/netinet/Makefile.am | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/src/include/netinet/Makefile.am b/src/include/netinet/Makefile.am
+index ca0aac2..965db8c 100644
+--- a/src/include/netinet/Makefile.am
++++ b/src/include/netinet/Makefile.am
+@@ -11,5 +11,4 @@ libcnetinetdir = $(includedir)/netinet
+ # API.
+ include_HEADERS =
+
+-libcnetinet_HEADERS = sctp.h.in
+-BUILT_SOURCES = sctp.h
++libcnetinet_HEADERS = sctp.h