summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2018-06-03 23:38:22 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2018-06-03 23:38:22 +0000
commit824584f136206c13732db9958beed4c6918e0ce1 (patch)
tree8a93a45848c063391ad95351e3538430cdbc0155
parentc201ddecae188890079cac20a53232c7f361e393 (diff)
parentf7e0c638da74c1b7fb54bb850b36991898cb3c89 (diff)
downloadpackages-824584f136206c13732db9958beed4c6918e0ce1.tar.gz
packages-824584f136206c13732db9958beed4c6918e0ce1.tar.bz2
packages-824584f136206c13732db9958beed4c6918e0ce1.tar.xz
packages-824584f136206c13732db9958beed4c6918e0ce1.zip
Merge branch 'python-updates' into 'master'
Various python package updates See merge request !36
-rw-r--r--user/py3-olefile/APKBUILD16
-rw-r--r--user/py3-pillow/APKBUILD6
-rw-r--r--user/py3-py/APKBUILD12
-rw-r--r--user/py3-pytest/APKBUILD6
-rw-r--r--user/py3-setuptools/APKBUILD17
-rw-r--r--user/py3-setuptools/pythonpath.patch19
-rw-r--r--user/py3-tox/APKBUILD4
-rw-r--r--user/py3-virtualenv/APKBUILD6
8 files changed, 42 insertions, 44 deletions
diff --git a/user/py3-olefile/APKBUILD b/user/py3-olefile/APKBUILD
index 4709626ae..06bbd6951 100644
--- a/user/py3-olefile/APKBUILD
+++ b/user/py3-olefile/APKBUILD
@@ -2,20 +2,17 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-olefile
_pkgname=olefile
-pkgver=0.44
+pkgver=0.45.1
pkgrel=0
pkgdesc="A Python module to read/write MS OLE2 files"
-url="https://pypi.python.org/pypi/olefile"
+url="https://pypi.python.org/project/olefile"
arch="noarch"
-license="Custom"
+license="BSD-2-Clause Custom"
depends="python3"
-makedepends="py3-setuptools python3-dev"
+makedepends="py3-setuptools python3-dev unzip"
install=""
giturl="https://github.com/decalage2/olefile"
-verbase="$pkgver"
-reporev="v$pkgver"
-# The downloads from GitHub are missing the test files
-source="https://dev.sick.bike/$pkgname-$pkgver.tar.gz"
+source="$pkgname-$pkgver.zip::https://files.pythonhosted.org/packages/source/o/$_pkgname/$_pkgname-$pkgver.zip"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
@@ -31,6 +28,7 @@ check() {
package() {
cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
}
-sha512sums="bece8b040cb3572c1fa2536a21c1de4c05e560b641e1c6e4bf66772135c43d29e06c7fc47d6c07d3c351b1f741f49c63201657634c33e9124de892e9a0cc053f py3-olefile-0.44.tar.gz"
+sha512sums="31f7584553304b186aad88f1988dfa12ceb34a50d546a38181280a816cfcda8dc54ff502afb31a928d647e6106c9e4878bfac8cec31d24018fdbab65c7007e49 py3-olefile-0.45.1.zip"
diff --git a/user/py3-pillow/APKBUILD b/user/py3-pillow/APKBUILD
index c995de7f5..6f443bf5f 100644
--- a/user/py3-pillow/APKBUILD
+++ b/user/py3-pillow/APKBUILD
@@ -2,10 +2,10 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-pillow
_pkgname=Pillow
-pkgver=5.0.0
+pkgver=5.1.0
pkgrel=0
pkgdesc="A Python Imaging Library"
-url="https://pypi.python.org/pypi/Pillow/$pkgver"
+url="https://pypi.python.org/project/Pillow"
arch="all"
license="Custom"
depends="py3-olefile python3"
@@ -50,5 +50,5 @@ doc() {
install -Dm644 LICENSE "$subpkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-sha512sums="f6f1e138effe44a89897f48032a36406dab3c4ddff2a97b7d01e99c05865abad5cffa3ab0eefcacb243e422778063b49243b1a538012fe9c39a1e4329c0978f3 py3-pillow-5.0.0.tar.gz
+sha512sums="1e1d5f12054e2f3befa8dafef2551eb75dfefc06944a528638a1686ebc480b52edfc3eaa9964d687816caf003314ad1fc4891d7379cd92e41fbf4b3cbddd1cb9 py3-pillow-5.1.0.tar.gz
1a2e6dc45127b3f0b706d5be4fdc8ddeb09a9e046a182eb48239572e1bdc62d1b1f1a1f11ef1f1f23766aaac1b498556cc9a9cf11d3b943c9f2834c9b41612e0 py3-pillow-scripts-f578e2c.tar.gz"
diff --git a/user/py3-py/APKBUILD b/user/py3-py/APKBUILD
index 171ac8245..ad05e041e 100644
--- a/user/py3-py/APKBUILD
+++ b/user/py3-py/APKBUILD
@@ -2,10 +2,10 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-py
_pkgname=py
-pkgver=1.4.34
+pkgver=1.5.3
pkgrel=0
pkgdesc="A python library with cross-python path, ini-parsing, io, code, log facilities"
-url="https://pypi.python.org/py/$pkgver"
+url="https://pypi.python.org/project/py"
arch="noarch"
license="MIT"
depends="python3"
@@ -21,10 +21,10 @@ build() {
}
check() {
- # This test suite seems to be incurring the wrath of
- # https://bugs.python.org/issue28627 on 1.5.2
+ # Can't use py3-pytest > 3.0 as of py3-py==1.5.3-r0 because some tests
+ # haven't been updated yet
cd "$builddir"
- tox -e py36
+ tox -e py36-pytest30
}
package() {
@@ -32,4 +32,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="2e19c82c8315274bffe0ba2c7e20ae3af95f942c40c16121ec953af186f8ff33e8f427c070e137bb04b7cc6dcc6779e35df3911c08595fd3294b5ec9897706e1 py3-py-1.4.34.tar.gz"
+sha512sums="243c0da94c439163257c525ef00b30fd6d8add5897121ee0b1f19476b50f18823ce2b99a5ab27a9cf47598b538758d0534060123dce0820d2a65d98046548c96 py3-py-1.5.3.tar.gz"
diff --git a/user/py3-pytest/APKBUILD b/user/py3-pytest/APKBUILD
index 39b723529..b180e039d 100644
--- a/user/py3-pytest/APKBUILD
+++ b/user/py3-pytest/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-pytest
_pkgname=pytest
-pkgver=3.2.2
+pkgver=3.5.1
pkgrel=0
pkgdesc="A python test library"
url="https://pypi.python.org/pypi/pytest"
@@ -11,7 +11,7 @@ license="MIT"
depends="python3 py3-py"
makedepends="py3-setuptools python3-dev"
#checkdepends="py3-tox"
-options="!check" # Circular dependency with py3-tox. Passes on x86_64
+options="net !check" # Circular dependency with py3-tox. Passes on x86_64
source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -30,4 +30,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="6df3a50e7d1efeaf7a283920b16d1daf800798f422bc851b0aacd2bbd5cb0a88c95f9057fae49943b9dfe6527ed552cdf8d983b944ab91d0af252ee4f6eb82db py3-pytest-3.2.2.tar.gz"
+sha512sums="5f54251b197b4bebadb06536054b4f79e16c5cec2cdfd7d95fd74548b8ecfaddaafeb635eb90d085fe4d4bea1108f951fe500d0e548cc8b797b0d23e0c2693a0 py3-pytest-3.5.1.tar.gz"
diff --git a/user/py3-setuptools/APKBUILD b/user/py3-setuptools/APKBUILD
index ba5e1aebf..6bee60420 100644
--- a/user/py3-setuptools/APKBUILD
+++ b/user/py3-setuptools/APKBUILD
@@ -2,19 +2,18 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-setuptools
_pkgname=setuptools
-pkgver=38.4.0
-pkgrel=1
+pkgver=39.1.0
+pkgrel=0
pkgdesc="A collection of enhancements to the Python distutils"
-url="http://pypi.python.org/pypi/setuptools"
+url="http://pypi.python.org/project/setuptools"
arch="noarch"
license="MIT"
depends="python3"
makedepends="python3-dev"
-#checkdepends="py3-tox"
-options="!check" # Circular dependency with py3-tox. Passes on x86_64
+checkdepends="py3-tox"
+options="net" # Circular dependency with py3-tox. Passes on x86_64
subpackages="py3-easy_install:easy_install"
-# Note: PyPI download is missing tests/requirements.txt
-source="$pkgname-$pkgver.tar.gz::https://github.com/pypa/$_pkgname/archive/v$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
pythonpath.patch"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -41,5 +40,5 @@ easy_install() {
mv "$pkgdir"/usr/bin/easy_install* "$subpkgdir/usr/bin"
}
-sha512sums="81903ee7ecb19715bbafe7b4e6878d3af5f801a9ff3334e82a599a81a8e6430443c4b765180c53c3c9cdcea338b3fff0bdf26245bc9d2da7d5d41b745de73a24 py3-setuptools-38.4.0.tar.gz
-0c80433534dbb715829f48713690a72a68f6cb7e337215c9aa507df0fbb2a2a242f54d42fab848c6f03729f155dfe0ccb819a6f5d5230e2195e94e20094eec0b pythonpath.patch"
+sha512sums="9fa00930a1923782c2f6356bf992410d42b3dd81b5a673e2957eaf8941787fbea324851c5df48e37601641d004ee900c88a1cfa97ef9df374879586a36efa5c6 py3-setuptools-39.1.0.tar.gz
+ee248df4174240e90a35190e0a47bf0fa4cc5601adc64eff5fd585c8919e47c3a2bb6191b8333800016567d8a0f0f71b7c2306779ea7e4ab7c8951bdee28ef5e pythonpath.patch"
diff --git a/user/py3-setuptools/pythonpath.patch b/user/py3-setuptools/pythonpath.patch
index 371804f55..d9d78a861 100644
--- a/user/py3-setuptools/pythonpath.patch
+++ b/user/py3-setuptools/pythonpath.patch
@@ -1,10 +1,11 @@
---- setuptools-38.4.0/tox.ini 2018-01-05 13:17:02.000000000 +0000
-+++ setuptools-38.4.0/tox.ini 2018-01-11 01:50:05.810000000 +0000
-@@ -6,6 +6,6 @@
-
- [testenv]
- deps=-rtests/requirements.txt
--passenv=APPDATA USERPROFILE HOMEDRIVE HOMEPATH windir APPVEYOR
-+passenv=APPDATA USERPROFILE HOMEDRIVE HOMEPATH windir APPVEYOR PYTHONPATH
- commands=py.test {posargs}
+--- setuptools-39.1.0/tox.ini 2018-04-28 07:07:00.000000000 -0400
++++ setuptools-39.1.0/tox.ini 2018-05-22 00:25:02.969163171 -0400
+@@ -12,7 +12,7 @@
+ setenv=COVERAGE_FILE={toxworkdir}/.coverage.{envname}
+ # TODO: The passed environment variables came from copying other tox.ini files
+ # These should probably be individually annotated to explain what needs them.
+-passenv=APPDATA HOMEDRIVE HOMEPATH windir APPVEYOR APPVEYOR_* CI CODECOV_* TRAVIS TRAVIS_*
++passenv=APPDATA HOMEDRIVE HOMEPATH windir APPVEYOR APPVEYOR_* CI CODECOV_* TRAVIS TRAVIS_* PYTHONPATH
+ commands=pytest --cov-config={toxinidir}/tox.ini --cov-report= {posargs}
usedevelop=True
+
diff --git a/user/py3-tox/APKBUILD b/user/py3-tox/APKBUILD
index 9ae7e731a..68f2c2364 100644
--- a/user/py3-tox/APKBUILD
+++ b/user/py3-tox/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-tox
_pkgname=tox
-pkgver=2.9.1
+pkgver=3.0.0
pkgrel=0
pkgdesc="virtualenv management and test command line tool"
url="https://pypi.python.org/pypi/tox"
@@ -30,4 +30,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="ff19b2bb7ac963379f1cccd4973ad9eb4dabfbda976cde7caba50ad010d8fa57c1cba91d63e3e0512e44cc7d350bc9270fbd9b30db1bd55f7d9c239e7623d066 py3-tox-2.9.1.tar.gz"
+sha512sums="3bce42561a032b9d1bcc6086093ab79e2ba84ca55b4a6b646485ed3ec4a5b7349d8fc4e47758d2dd7998fc943824a99a251447e13b9ccc396b9d2d87f367f6cd py3-tox-3.0.0.tar.gz"
diff --git a/user/py3-virtualenv/APKBUILD b/user/py3-virtualenv/APKBUILD
index 0d4212635..89f7a69b8 100644
--- a/user/py3-virtualenv/APKBUILD
+++ b/user/py3-virtualenv/APKBUILD
@@ -2,10 +2,10 @@
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=py3-virtualenv
_pkgname=virtualenv
-pkgver=15.1.0
+pkgver=16.0.0
pkgrel=0
pkgdesc="Virtual Python Environment builder"
-url="https://pypi.python.org/pypi/virtualenv"
+url="https://pypi.org/project/virtualenv"
arch="noarch"
license="MIT"
depends="python3"
@@ -33,5 +33,5 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="d7e95b8c017ec076210f30b6fd4bb44be2f7dc0257492c25bb00fee597d3ade34226d03539180f1edaf2d27b361f8efdabb92d3476e13785b890878ee1295cb2 py3-virtualenv-15.1.0.tar.gz
+sha512sums="43bc37f1da1b65e9a2df5a8813a801f27f5783b7211219d441d1c2132789917df42fdc0aba1d5ec51e3d6f7583af9474d59c1f532d8880c8c325ccc96e73b3df py3-virtualenv-16.0.0.tar.gz
8e022416eb10289fd5215f3810203eefb450ce2fca7bdc581b5cd1892f41f34815beec35fc6c744991536c1f2edebd58ab934a4414c6fe2ae6387aea02787ef8 test-python3.patch"