summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2020-10-01 04:19:34 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2020-10-01 04:19:34 +0000
commite4e47732892bf914bd2684bc526d1f1751aa2446 (patch)
treee829a0ddd445f60524697d6e8226da2a5017d96b
parentc74cfa261ae990f848f79f1d00517d7cbba9395e (diff)
downloadpackages-e4e47732892bf914bd2684bc526d1f1751aa2446.tar.gz
packages-e4e47732892bf914bd2684bc526d1f1751aa2446.tar.bz2
packages-e4e47732892bf914bd2684bc526d1f1751aa2446.tar.xz
packages-e4e47732892bf914bd2684bc526d1f1751aa2446.zip
user/qt5-qtdeclarative: Fix endian
-rw-r--r--user/qt5-qtdeclarative/APKBUILD4
-rw-r--r--user/qt5-qtdeclarative/endian.patch31
2 files changed, 34 insertions, 1 deletions
diff --git a/user/qt5-qtdeclarative/APKBUILD b/user/qt5-qtdeclarative/APKBUILD
index 828732868..27f526671 100644
--- a/user/qt5-qtdeclarative/APKBUILD
+++ b/user/qt5-qtdeclarative/APKBUILD
@@ -2,7 +2,7 @@
pkgname=qt5-qtdeclarative
_pkgname=${pkgname#qt5-}-everywhere-src
pkgver=5.12.9
-pkgrel=0
+pkgrel=1
pkgdesc="Qt Declarative and Qt Quick 2"
url="https://www.qt.io/"
arch="all"
@@ -13,6 +13,7 @@ subpackages="$pkgname-dev"
source="https://download.qt.io/official_releases/qt/${pkgver%.*}/$pkgver/submodules/$_pkgname-$pkgver.tar.xz
add-execinfo.patch
disable-jit-pmmx.patch
+ endian.patch
python3.patch
"
@@ -39,4 +40,5 @@ package() {
sha512sums="5357cdc56c0835c3c5d397839faf07ac61af4ed3067765edd32122aecd204849ce4b9a3b1eb5e631efdf832994c682851f43025796fb1bd56b32061a1c048bc8 qtdeclarative-everywhere-src-5.12.9.tar.xz
065ab2440fd0a81e76fe8873b0991929fad3d4189c8938e0205e94478a6cdce81ef710e3bad19cd5ca0b5ea0f8b3cd1b366969ddede51070496d1d02ace59220 add-execinfo.patch
d21720d9d26fa323e769f5edb97f17b189e07d98ea825aad7d4d39dabd7293e49ce6a2d79a7997f4f0c825d3ac84ac148c68261d1f24629f5f4026a5cd733076 disable-jit-pmmx.patch
+4830800e2440e7a69073115e0e0d3ed42bcc99bdf04d4ea662508ff44edf30346211988171972bb49676c2b6aaa4cef684e9ab97e97091b656d517bbb790a584 endian.patch
bb39564f2d68e5635141f3de950ff7ec8174d2c972d066049153039268154de1cad7fcb82d191e325db0a0317ed90eb869431432e32494fa52584af1536f1990 python3.patch"
diff --git a/user/qt5-qtdeclarative/endian.patch b/user/qt5-qtdeclarative/endian.patch
new file mode 100644
index 000000000..313e9ca5c
--- /dev/null
+++ b/user/qt5-qtdeclarative/endian.patch
@@ -0,0 +1,31 @@
+From 15b3a8fc8635e04fa7ea1275b910772d8f2820a2 Mon Sep 17 00:00:00 2001
+From: q66 <daniel@octaforge.org>
+Date: Sun, 10 May 2020 02:44:47 +0200
+Subject: [PATCH] always default to qtquick software backend on big endian
+
+the default backend is buggy and breaks rendering of various
+components of KDE Plasma and LXQt, so just default to software
+so the user doesn't have to specify QT_QUICK_BACKEND
+---
+ qtdeclarative/src/quick/scenegraph/qsgcontextplugin.cpp | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git qtdeclarative/src/quick/scenegraph/qsgcontextplugin.cpp qtdeclarative/src/quick/scenegraph/qsgcontextplugin.cpp
+index 66add51..a0fdaa2 100644
+--- qtdeclarative/src/quick/scenegraph/qsgcontextplugin.cpp
++++ qtdeclarative/src/quick/scenegraph/qsgcontextplugin.cpp
+@@ -139,7 +139,10 @@ QSGAdaptationBackendData *contextFactory()
+ // If this platform does not support OpenGL, and no backend has been set
+ // default to the software renderer
+ if (requestedBackend.isEmpty()
+- && !QGuiApplicationPrivate::platformIntegration()->hasCapability(QPlatformIntegration::OpenGL)) {
++#if Q_BYTE_ORDER == Q_LITTLE_ENDIAN
++ && !QGuiApplicationPrivate::platformIntegration()->hasCapability(QPlatformIntegration::OpenGL)
++#endif
++ ) {
+ requestedBackend = QString::fromLocal8Bit("software");
+ }
+
+--
+2.25.1
+