summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2018-08-18 02:52:54 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2018-08-18 02:52:54 +0000
commit8ad674ec9c720a4e5c3fedd60372790990456d82 (patch)
tree7a5f311df8554f7eacec12fbd8c9a81e9fcb45aa
parent624b698e46800cd6c1aa44dbc3ae0a6f0f71095d (diff)
parentb384b8162f107febcb1a279d2836b51b1acabeda (diff)
downloadpackages-8ad674ec9c720a4e5c3fedd60372790990456d82.tar.gz
packages-8ad674ec9c720a4e5c3fedd60372790990456d82.tar.bz2
packages-8ad674ec9c720a4e5c3fedd60372790990456d82.tar.xz
packages-8ad674ec9c720a4e5c3fedd60372790990456d82.zip
Merge branch 'ncurses-fix-static-linkage' into 'master'
Fix ncurses static linkage. Use the same linker script trick as used on the .so files on the .a files to redirect to the wide version of the static libraries. Fixes an issue with `llvm-config --system-libs --link-static` pulling in curses instead of tinfo. See merge request !43
-rw-r--r--system/ncurses/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/system/ncurses/APKBUILD b/system/ncurses/APKBUILD
index eb57797a1..eaa4508bf 100644
--- a/system/ncurses/APKBUILD
+++ b/system/ncurses/APKBUILD
@@ -2,7 +2,7 @@
pkgname=ncurses
pkgver=6.1_p20180609
_ver=${pkgver%_p*}-${pkgver#*_p}
-pkgrel=4
+pkgrel=5
pkgdesc="Console display library"
url="https://invisible-island.net/ncurses/ncurses.html"
arch="all"
@@ -66,9 +66,10 @@ package() {
dev() {
default_dev
- # force link against *w.so
+ # force link against *w.so and *w.a
for lib in ncurses ncurses++ form panel menu tinfo; do
echo "INPUT(-l${lib}w)" > "$subpkgdir"/lib/lib${lib}.so
+ echo "INPUT(-l${lib}w)" > "$subpkgdir"/lib/lib${lib}.a
ln -s ${lib}w.pc "$subpkgdir"/usr/lib/pkgconfig/${lib}.pc
done
# link curses -> ncurses