summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2023-01-04 02:32:30 +0000
committerZach van Rijn <me@zv.io>2023-01-04 02:35:23 +0000
commitb75332c999508e359ef1e031380dd80d81b396ae (patch)
tree1567d297f7357a771e33c41591b8a486e24a5fda
parente16b285c8e8c54bed0ec0eba419c2959e7e22b07 (diff)
downloadpackages-b75332c999508e359ef1e031380dd80d81b396ae.tar.gz
packages-b75332c999508e359ef1e031380dd80d81b396ae.tar.bz2
packages-b75332c999508e359ef1e031380dd80d81b396ae.tar.xz
packages-b75332c999508e359ef1e031380dd80d81b396ae.zip
user/gitlab-runner: patch armv7 for multiple redefinition 'seek'.
the file: sys/unix/syscall_linux_arm.go seems to declare 'seek()' as a prototype, the implementation being: sys/unix/syscall_linux_gccgo_arm.go however it isn't immediately clear why the conflict occurs, unless it has to do with our Makefile patches, which CGO_ENABLED=1? fixes #956
-rw-r--r--user/gitlab-runner/APKBUILD9
-rw-r--r--user/gitlab-runner/fix-multiple-redef-seek.patch38
2 files changed, 44 insertions, 3 deletions
diff --git a/user/gitlab-runner/APKBUILD b/user/gitlab-runner/APKBUILD
index 62c9ef24c..a2ef8fd9c 100644
--- a/user/gitlab-runner/APKBUILD
+++ b/user/gitlab-runner/APKBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Max Rees <maxcrees@me.com>
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Zach van Rijn <me@zv.io>
pkgname=gitlab-runner
pkgver=12.1.0
-pkgrel=0
+pkgrel=1
_testver=91956efe
_branch="${pkgver%.*}"
_branch="${pkgver%%.*}-${_branch#*.}-stable"
@@ -27,6 +28,7 @@ source="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v$pkgver/gitlab-ru
posix-shell.patch
posix-shell-escape.patch
tests.patch
+ fix-multiple-redef-seek.patch
"
builddir="$srcdir/$pkgname-v$pkgver"
@@ -85,4 +87,5 @@ a32b7a6fa28c7f5bcb505308e615f17de179c15ce8c2ef73078143204195e36d99b18489114ce694
4bc8f827cbcec212fcb1c5598aaf725138efa9a1de699d6261a65207cca7ef46f441edc02987efdd6d7c6e62943fda8f3f2a5a596d8d33b49fb78ba5df612e8b gccgo.patch
444adec507c5eebcfae268f2f475d29316119f30750f06877a91dff56942d0e4d34ed3011b774b0d7acd59acfe2ddbe75082b3cd5aebd72ddb4703fd083ad301 posix-shell.patch
05d12046448c79a12bf92974089ff97781304083f7bf35abb0b0c0f990c536bd6ff51652e16035a38e4ba5620dcad6e051ecdf4a80eb62039a15371073e525b5 posix-shell-escape.patch
-dae9c3f86fdf21bd41202fc2c0bc7dd764078ea9215d7ddbac1f7bc47b0943f7a912250a3006122f74ed50052378ed2c946eefe5c1ce8400cd682b183221025a tests.patch"
+dae9c3f86fdf21bd41202fc2c0bc7dd764078ea9215d7ddbac1f7bc47b0943f7a912250a3006122f74ed50052378ed2c946eefe5c1ce8400cd682b183221025a tests.patch
+693d3abd94a85be70337bdfcbc3c643d65b95991689e085c573a793e4568f71966e398be960fd6bd985481613a1b85c459af814f83396d23e773afeee956b9f3 fix-multiple-redef-seek.patch"
diff --git a/user/gitlab-runner/fix-multiple-redef-seek.patch b/user/gitlab-runner/fix-multiple-redef-seek.patch
new file mode 100644
index 000000000..5a9d1ef10
--- /dev/null
+++ b/user/gitlab-runner/fix-multiple-redef-seek.patch
@@ -0,0 +1,38 @@
+diff -ur a/vendor/golang.org/x/sys/unix/syscall_linux_arm.go b/vendor/golang.org/x/sys/unix/syscall_linux_arm.go
+--- a/vendor/golang.org/x/sys/unix/syscall_linux_arm.go 2023-01-04 02:17:18.689781320 +0000
++++ b/vendor/golang.org/x/sys/unix/syscall_linux_arm.go 2023-01-04 02:19:46.688219811 +0000
+@@ -45,7 +45,13 @@
+
+ // Underlying system call writes to newoffset via pointer.
+ // Implemented in assembly to avoid allocation.
+-func seek(fd int, offset int64, whence int) (newoffset int64, err syscall.Errno)
++func seek(fd int, offset int64, whence int) (int64, syscall.Errno) {
++ var newoffset int64
++ offsetLow := uint32(offset & 0xffffffff)
++ offsetHigh := uint32((offset >> 32) & 0xffffffff)
++ _, _, err := Syscall6(SYS__LLSEEK, uintptr(fd), uintptr(offsetHigh), uintptr(offsetLow), uintptr(unsafe.Pointer(&newoffset)), uintptr(whence), 0)
++ return newoffset, err
++}
+
+ func Seek(fd int, offset int64, whence int) (newoffset int64, err error) {
+ newoffset, errno := seek(fd, offset, whence)
+diff -ur a/vendor/golang.org/x/sys/unix/syscall_linux_gccgo_arm.go b/vendor/golang.org/x/sys/unix/syscall_linux_gccgo_arm.go
+--- a/vendor/golang.org/x/sys/unix/syscall_linux_gccgo_arm.go 2023-01-04 02:17:18.689781320 +0000
++++ b/vendor/golang.org/x/sys/unix/syscall_linux_gccgo_arm.go 2023-01-04 02:20:04.283558738 +0000
+@@ -2,7 +2,7 @@
+ // Use of this source code is governed by a BSD-style
+ // license that can be found in the LICENSE file.
+
+-// +build linux,gccgo,arm
++// +build linux,!gccgo,arm
+
+ package unix
+
+@@ -11,6 +11,7 @@
+ "unsafe"
+ )
+
++// this file should not be built
+ func seek(fd int, offset int64, whence int) (int64, syscall.Errno) {
+ var newoffset int64
+ offsetLow := uint32(offset & 0xffffffff)