summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-05-25 11:36:45 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-06-11 14:03:55 -0500
commitd122ea2b9f9b6680e05bca638843d807a05f8a12 (patch)
tree47eea0b2bed1731678fc8df848577f28c16d372d
parent1953aebc2862fedcfc484022c6f61dd70dc5181b (diff)
downloadpackages-d122ea2b9f9b6680e05bca638843d807a05f8a12.tar.gz
packages-d122ea2b9f9b6680e05bca638843d807a05f8a12.tar.bz2
packages-d122ea2b9f9b6680e05bca638843d807a05f8a12.tar.xz
packages-d122ea2b9f9b6680e05bca638843d807a05f8a12.zip
system/heirloom-devtools: Use C++98 standard
This fixes a build error with newer GCC that defaults to the C++17 standard. Basic operation was tested and remains functional. It would be a *lot* better to rearchitect this, especially with how many times it hits -Wwrite-strings. Anyone willing to do that work would be highly praised :)
-rw-r--r--system/heirloom-devtools/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/system/heirloom-devtools/APKBUILD b/system/heirloom-devtools/APKBUILD
index c6ca8892f..cbf0633d5 100644
--- a/system/heirloom-devtools/APKBUILD
+++ b/system/heirloom-devtools/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=heirloom-devtools
pkgver=070527
-pkgrel=1
+pkgrel=2
pkgdesc="Development tools compatible with UNIX"
url="http://heirloom.sourceforge.net/devtools.html"
arch="all"
@@ -20,7 +20,7 @@ source="https://downloads.sourceforge.net/heirloom/heirloom-devtools/$pkgver/hei
$pkgname-$pkgver-64-bit.patch"
build() {
- make -j1 CXXFLAGS="${CXXFLAGS} -DMAXNETNAMELEN=255"
+ make -j1 CXXFLAGS="${CXXFLAGS} -DMAXNETNAMELEN=255 -std=c++98"
}
package() {