summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-08-13 01:59:09 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-11-19 00:57:00 -0600
commit558269dc61931cfeec20013263a8dcc207bd9d2c (patch)
treeaab8d18d72660952f1aa1d1f5c482507d50522eb
parent8ee2a4b339d11ea9807307f05f279e19c268077e (diff)
downloadpackages-558269dc61931cfeec20013263a8dcc207bd9d2c.tar.gz
packages-558269dc61931cfeec20013263a8dcc207bd9d2c.tar.bz2
packages-558269dc61931cfeec20013263a8dcc207bd9d2c.tar.xz
packages-558269dc61931cfeec20013263a8dcc207bd9d2c.zip
user/openmsx: Update to 0.4.2
-rw-r--r--user/openmsx/APKBUILD11
-rw-r--r--user/openmsx/python3.patch265
2 files changed, 4 insertions, 272 deletions
diff --git a/user/openmsx/APKBUILD b/user/openmsx/APKBUILD
index c3aedd777..7bc33e5df 100644
--- a/user/openmsx/APKBUILD
+++ b/user/openmsx/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: A. Wilcox <awilfox@adelielinux.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=openmsx
-pkgver=0.3.1
+pkgver=0.4.2
pkgrel=0
pkgdesc="Music files for OpenTTD"
url="https://www.openttd.org/en/"
@@ -11,8 +11,7 @@ license="GPL-2.0-only"
depends=""
makedepends="python3"
subpackages=""
-source="https://cdn.openttd.org/$pkgname-releases/$pkgver/$pkgname-$pkgver-source.tar.gz
- python3.patch
+source="https://cdn.openttd.org/$pkgname-releases/$pkgver/$pkgname-$pkgver-source.tar.xz
python3-bang.patch
"
builddir="$srcdir/$pkgname-$pkgver-source"
@@ -22,13 +21,11 @@ build() {
}
package() {
- cd "$builddir"/$pkgname-$pkgver
- for _file in *.mid openmsx.obm; do
+ for _file in src/*.mid openmsx.obm; do
install -D -m644 -g games $_file \
"$pkgdir"/usr/share/games/openttd/gm/$_file
done
}
-sha512sums="e455f99f32d1daa77157def4f109dd1456169ae2b527290035b6a52f591c13fb7464fd221e00eb46bf03f51e8d0101de08a9e47cebe2430ad05a840ab235973e openmsx-0.3.1-source.tar.gz
-b6690158831cb3da9e0e65a523529ee0bb694a4a8b23c89f615b2481601a71fd84caecf29430054e69afa3ffcb53cf8dd5826358d7ef89429c661dd4d47bbb74 python3.patch
+sha512sums="65a06792032d0a7f6db5c9495bf5b382fdc29ca84db0535b61ea95b57e8ef961820e75dad2f8dc74de0608502839bea7af28fd342756ebfcc12ee8ac1f5553ab openmsx-0.4.2-source.tar.xz
f981aff74f9cd33650641badd977f38c1cbbc749198a45ca016de3be83d8bec6c4f82c0614340a11f7bda7b4b98d48e26fd03a74bbf233af6deb588874d34145 python3-bang.patch"
diff --git a/user/openmsx/python3.patch b/user/openmsx/python3.patch
deleted file mode 100644
index 191aacfd6..000000000
--- a/user/openmsx/python3.patch
+++ /dev/null
@@ -1,265 +0,0 @@
---- openmsx-0.3.1-source/scripts/authorlist.py.old 2010-08-09 22:34:42.000000000 +0000
-+++ openmsx-0.3.1-source/scripts/authorlist.py 2019-01-12 18:12:26.010000000 +0000
-@@ -10,7 +10,6 @@
- # <http://www.gnu.org/licenses/>.
- #
-
--import string
- import sys
-
- while 1:
-@@ -18,10 +17,10 @@
- if data != '':
- # do some processing of the contents of
- # the data variable
-- separate = string.split(data,";")
-- print '%-30s %s' % (separate[1]+":", separate[2])
-+ separate = data.split(";")
-+ print('%-30s %s' % (separate[1]+":", separate[2]))
- # end of data processing command group
-- # sys.stdout.write(res)
-+ # sys.stdout.write(res)
- else:
- sys.stdout.flush()
- break
---- openmsx-0.3.1-source/scripts/md5list.py.old 2010-08-09 22:34:42.000000000 +0000
-+++ openmsx-0.3.1-source/scripts/md5list.py 2019-01-12 18:16:21.260000000 +0000
-@@ -10,7 +10,6 @@
- # <http://www.gnu.org/licenses/>.
- #
-
--import string
- import sys
- import subprocess
- import os
-@@ -18,25 +17,25 @@
- while 1:
- data = sys.stdin.readline()
- if data != '':
-- # leave out all comment lines (lines starting with '#')
-- comment_pos = string.find(data,'#')
-- if comment_pos == 0:
-- continue
-- # separate the single entries by ';'
-- separate = string.split(data,";")
-- if len(separate) != 4:
-- continue
-- systemtype = (os.uname())[0]
-- if systemtype == 'Linux':
-- md5call = ["md5sum"]
-- elif systemtype == 'Darwin':
-- md5call = ["md5", "-r"]
-- else:
-- md5call = ["md5sum"]
-- md5call = md5call + ["src/"+string.strip(separate[1])]
-- md5sum = subprocess.Popen(md5call, stdout=subprocess.PIPE).communicate()[0]
-- md5sum = string.split(md5sum)
-- res = "%-32s = %s\n" % (separate[1], md5sum[0])
-+ # leave out all comment lines (lines starting with '#')
-+ comment_pos = data.find('#')
-+ if comment_pos == 0:
-+ continue
-+ # separate the single entries by ';'
-+ separate = data.split(";")
-+ if len(separate) != 4:
-+ continue
-+ systemtype = (os.uname())[0]
-+ if systemtype == 'Linux':
-+ md5call = ["md5sum"]
-+ elif systemtype == 'Darwin':
-+ md5call = ["md5", "-r"]
-+ else:
-+ md5call = ["md5sum"]
-+ md5call = md5call + ["src/"+separate[1].strip()]
-+ md5sum = subprocess.Popen(md5call, stdout=subprocess.PIPE).communicate()[0]
-+ md5sum = md5sum.split()
-+ res = "%-32s = %s\n" % (separate[1], md5sum[0].decode('utf-8'))
- sys.stdout.write(res)
- else:
- sys.stdout.flush()
---- openmsx-0.3.1-source/scripts/midifiles.py.old 2010-08-09 22:34:42.000000000 +0000
-+++ openmsx-0.3.1-source/scripts/midifiles.py 2019-01-12 18:09:21.660000000 +0000
-@@ -10,23 +10,22 @@
- # <http://www.gnu.org/licenses/>.
- #
-
--import string
- import sys
-
- res = ""
- while 1:
- data = sys.stdin.readline()
- if data != '':
-- # leave out all comment lines (lines starting with '#')
-- comment_pos = string.find(data,'#')
-- if comment_pos == 0:
-- continue
-- # separate the single entries by ';'
-- separate = string.split(data,";")
-- if len(separate) != 4:
-- continue
-- res = res + " src/" + string.strip(separate[1])
-+ # leave out all comment lines (lines starting with '#')
-+ comment_pos = data.find('#')
-+ if comment_pos == 0:
-+ continue
-+ # separate the single entries by ';'
-+ separate = data.split(";")
-+ if len(separate) != 4:
-+ continue
-+ res = res + " src/" + separate[1].strip()
- else:
-- sys.stdout.write(res)
-+ sys.stdout.write(res)
- sys.stdout.flush()
- break
---- openmsx-0.3.1-source/scripts/namelist.py.old 2010-08-09 22:34:42.000000000 +0000
-+++ openmsx-0.3.1-source/scripts/namelist.py 2019-01-12 18:24:41.820000000 +0000
-@@ -10,27 +10,26 @@
- # <http://www.gnu.org/licenses/>.
- #
-
--import string
- import sys
-
- while 1:
- data = sys.stdin.readline()
- if data != '':
-- # leave out all comment lines (lines starting with '#')
-- comment_pos = string.find(data,'#')
-- if comment_pos == 0:
-- continue
-- # separate the single entries by ';'
-- separate = string.split(data,";")
-- if len(separate) != 4:
-- continue
-- res = "%-32s = %s\n" % (separate[1], string.strip(separate[3]))
-+ # leave out all comment lines (lines starting with '#')
-+ comment_pos = data.find('#')
-+ if comment_pos == 0:
-+ continue
-+ # separate the single entries by ';'
-+ separate = data.split(";")
-+ if len(separate) != 4:
-+ continue
-+ res = "%-32s = %s\n" % (separate[1], separate[3].strip())
- sys.stdout.write(res)
- else:
- sys.stdout.flush()
- break
-
- def authorlist(mystr):
-- separate = string.split()
-- for str in separate:
-- print string.strip(str)
-\ No newline at end of file
-+ separate = mystr.split()
-+ for str in separate:
-+ print(str.strip())
---- openmsx-0.3.1-source/scripts/playlist.py.old 2010-08-09 22:34:42.000000000 +0000
-+++ openmsx-0.3.1-source/scripts/playlist.py 2019-01-12 18:24:46.440000000 +0000
-@@ -10,31 +10,30 @@
- # <http://www.gnu.org/licenses/>.
- #
-
--import string
- import sys
-
- while 1:
- data = sys.stdin.readline()
- if data != '':
-- # leave out all comment lines (lines starting with '#')
-- comment_pos = string.find(data,'#')
-- if comment_pos == 0:
-- continue
-- # separate the single entries by ';'
-- separate = string.split(data,";")
-- res = ""
-- # leave out all lines which don't have the proper number of elements
-- if len(separate) >= 1:
-- res = string.strip(separate[0]) + " = "
-- if len(separate) == 4:
-- res = res + separate[1]
-- res = res + "\n"
-+ # leave out all comment lines (lines starting with '#')
-+ comment_pos = data.find('#')
-+ if comment_pos == 0:
-+ continue
-+ # separate the single entries by ';'
-+ separate = data.split(";")
-+ res = ""
-+ # leave out all lines which don't have the proper number of elements
-+ if len(separate) >= 1:
-+ res = separate[0].strip() + " = "
-+ if len(separate) == 4:
-+ res = res + separate[1]
-+ res = res + "\n"
- sys.stdout.write(res)
- else:
- sys.stdout.flush()
- break
-
- def authorlist(mystr):
-- separate = string.split()
-- for str in separate:
-- print string.strip(str)
-\ No newline at end of file
-+ separate = mystr.split()
-+ for str in separate:
-+ print(str.strip())
---- openmsx-0.3.1-source/scripts/sanitize_list.py.old 2010-08-09 22:34:42.000000000 +0000
-+++ openmsx-0.3.1-source/scripts/sanitize_list.py 2019-01-12 18:25:21.200000000 +0000
-@@ -10,34 +10,33 @@
- # <http://www.gnu.org/licenses/>.
- #
-
--import string
- import sys
-
- while 1:
- data = sys.stdin.readline()
- if data != '':
-- # leave out all comment lines (lines starting with '#')
-- comment_pos = string.find(data,'#')
-- if comment_pos == 0:
-- continue
-- # separate the single entries by ';'
-- separate = string.split(data,";")
-- if len(separate) != 4:
-- continue
-- res = ""
-- for str in separate:
-- if res != '':
-- res = res + ";" + string.strip(str)
-- else:
-- res = string.strip(str)
-+ # leave out all comment lines (lines starting with '#')
-+ comment_pos = data.find('#')
-+ if comment_pos == 0:
-+ continue
-+ # separate the single entries by ';'
-+ separate = data.split(";")
-+ if len(separate) != 4:
-+ continue
-+ res = ""
-+ for str in separate:
-+ if res != '':
-+ res = res + ";" + str.strip()
-+ else:
-+ res = str.strip()
- # end of data processing command group
-- res = res + "\n"
-+ res = res + "\n"
- sys.stdout.write(res)
- else:
- sys.stdout.flush()
- break
-
- def authorlist(mystr):
-- separate = string.split()
-- for str in separate:
-- print string.strip(str)
-\ No newline at end of file
-+ separate = mystr.split()
-+ for str in separate:
-+ print(str.strip())