summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-08-12 00:13:03 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-11-19 00:56:58 -0600
commitdcb76489a5786f16f50eb1ae12598c9cb4607cf9 (patch)
treea0f6ef53caee56e59010f263ee37e08df5b74295
parent43e842ea9b26ad44c88000cc4d9bd6cf8473afca (diff)
downloadpackages-dcb76489a5786f16f50eb1ae12598c9cb4607cf9.tar.gz
packages-dcb76489a5786f16f50eb1ae12598c9cb4607cf9.tar.bz2
packages-dcb76489a5786f16f50eb1ae12598c9cb4607cf9.tar.xz
packages-dcb76489a5786f16f50eb1ae12598c9cb4607cf9.zip
system/icu: Correct Islamic calendar calculations
Upstream commit d43d216feb left an extra addition when refactoring overflow-checking maths, which caused some dates to be an erroneous year in the future from where they should have been.
-rw-r--r--system/icu/APKBUILD4
-rw-r--r--system/icu/icu-60.2-always-use-utf8.patch4
-rw-r--r--system/icu/islamic-calendar.patch14
3 files changed, 19 insertions, 3 deletions
diff --git a/system/icu/APKBUILD b/system/icu/APKBUILD
index 4d5f37085..17741042d 100644
--- a/system/icu/APKBUILD
+++ b/system/icu/APKBUILD
@@ -17,6 +17,7 @@ makedepends=""
subpackages="$pkgname-static $pkgname-dev $pkgname-doc $pkgname-libs"
source="https://github.com/unicode-org/icu/releases/download/release-$(printf '%s' "$pkgver" | tr . -)/${pkgname}4c-$_ver-src.tgz
icu-60.2-always-use-utf8.patch
+ islamic-calendar.patch
"
# secfixes:
@@ -79,4 +80,5 @@ static() {
}
sha512sums="70ea842f0d5f1f6c6b65696ac71d96848c4873f4d794bebc40fd87af2ad4ef064c61a786bf7bc430ce4713ec6deabb8cc1a8cc0212eab148cee2d498a3683e45 icu4c-75_1-src.tgz
-f86c62422f38f6485c58d4766e629bab69e4b0e00fa910854e40e7db1ace299152eaefa99ae2fbab7465e65d3156cbea7124612defa60680db58ab5c34d6262f icu-60.2-always-use-utf8.patch"
+f89e9f389621ed9a58548ac961fc93fca8377b91fbb0df1991049757deadf72f6f11346eb7af883040c85b28621140805636a7f90d94f3b53e666d67b9681989 icu-60.2-always-use-utf8.patch
+1a4305e6145ecab171d044e4cc14e074294c73e221f780803363823bafa2f79d2efd77d63f6c0bb6df6d5f9767de38d321196d85649be929a583f1abc27dbdd0 islamic-calendar.patch"
diff --git a/system/icu/icu-60.2-always-use-utf8.patch b/system/icu/icu-60.2-always-use-utf8.patch
index 773687174..801a907d0 100644
--- a/system/icu/icu-60.2-always-use-utf8.patch
+++ b/system/icu/icu-60.2-always-use-utf8.patch
@@ -1,7 +1,7 @@
--- source/common/unicode/platform.h 2017-10-25 13:41:15.000000000 -0500
+++ source/common/unicode/platform.h 2018-04-04 02:07:28.851222016 -0500
-@@ -634,7 +634,7 @@
- #elif U_PLATFORM == U_PF_ANDROID || U_PLATFORM_IS_DARWIN_BASED
+@@ -606,7 +606,7 @@
+ U_PLATFORM == U_PF_EMSCRIPTEN
# define U_CHARSET_IS_UTF8 1
#else
-# define U_CHARSET_IS_UTF8 0
diff --git a/system/icu/islamic-calendar.patch b/system/icu/islamic-calendar.patch
new file mode 100644
index 000000000..bae9734af
--- /dev/null
+++ b/system/icu/islamic-calendar.patch
@@ -0,0 +1,14 @@
+The addition is duplicated, causing some dates to be one year off.
+
+Fixes: d43d216feb ("ICU-22633 Test and fix int32_t overflow for Calendar set")
+
+--- source/i18n/islamcal.cpp.old 2024-04-16 16:08:53.000000000 -0500
++++ source/i18n/islamcal.cpp 2024-08-12 00:03:20.102380147 -0500
+@@ -452,7 +452,6 @@
+ // This may be called by Calendar::handleComputeJulianDay with months out of the range
+ // 0..11. Need to handle that here since monthStart requires months in the range 0.11.
+ if (month > 11) {
+- eyear += (month / 12);
+ if (uprv_add32_overflow(eyear, (month / 12), &eyear)) {
+ status = U_ILLEGAL_ARGUMENT_ERROR;
+ return 0;