summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-08-16 06:18:43 +0000
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2018-08-16 06:18:43 +0000
commit582584d7bcffdb6ad70221c41f0b1b0765cfe00d (patch)
tree8c44a28430d92f57fae401a84a944808d217f797
parent2046e295ceb72f673a006009583c937ecabb6211 (diff)
downloadpackages-582584d7bcffdb6ad70221c41f0b1b0765cfe00d.tar.gz
packages-582584d7bcffdb6ad70221c41f0b1b0765cfe00d.tar.bz2
packages-582584d7bcffdb6ad70221c41f0b1b0765cfe00d.tar.xz
packages-582584d7bcffdb6ad70221c41f0b1b0765cfe00d.zip
system/easy-kernel: UAPI fix for linux-headers
-rw-r--r--system/easy-kernel/APKBUILD4
-rw-r--r--system/easy-kernel/revert-broken-uapi.patch (renamed from system/linux-headers/revert-broken-uapi.patch)0
-rw-r--r--system/linux-headers/APKBUILD54
3 files changed, 3 insertions, 55 deletions
diff --git a/system/easy-kernel/APKBUILD b/system/easy-kernel/APKBUILD
index e355ad1a3..4a9395acd 100644
--- a/system/easy-kernel/APKBUILD
+++ b/system/easy-kernel/APKBUILD
@@ -22,7 +22,8 @@ source="https://cdn.kernel.org/pub/linux/kernel/v4.x/linux-4.14.tar.xz
config-ppc
config-x86_64
config-pmmx
- config-aarch64"
+ config-aarch64
+ "
builddir="$srcdir/linux-4.14"
prepare() {
@@ -78,6 +79,7 @@ modules() {
headers() {
pkgdesc="System headers provided by the Linux kernel"
cd "$builddir"
+ patch -Np1 -i "$srcdir"/../revert-broken-uapi.patch
mkdir -p "$subpkgdir"/usr
make headers_install INSTALL_HDR_PATH="$subpkgdir/usr"
diff --git a/system/linux-headers/revert-broken-uapi.patch b/system/easy-kernel/revert-broken-uapi.patch
index 186ef7196..186ef7196 100644
--- a/system/linux-headers/revert-broken-uapi.patch
+++ b/system/easy-kernel/revert-broken-uapi.patch
diff --git a/system/linux-headers/APKBUILD b/system/linux-headers/APKBUILD
deleted file mode 100644
index 7beaa2272..000000000
--- a/system/linux-headers/APKBUILD
+++ /dev/null
@@ -1,54 +0,0 @@
-# Maintainer: Adelie Platform Group <adelie-devel@lists.adelielinux.org>
-pkgname=linux-headers
-pkgver=4.14.48
-pkgrel=8
-pkgdesc="Linux system headers"
-url="https://kernel.org"
-arch="all"
-options="!check !dbg !strip !tracedeps" # Headers only
-license="GPL-2.0-only"
-makedepends="perl"
-source="https://kernel.org/pub/linux/kernel/v4.x/linux-4.14.tar.xz
- https://distfiles.adelielinux.org/source/linux-4.14-mc$pkgrel.patch.xz
- revert-broken-uapi.patch
- "
-builddir="$srcdir/linux-4.14"
-
-prepare() {
- cd "$srcdir"
- cat linux-4.14-mc$pkgrel.patch.xz | unxz -> linux-4.14-mc$pkgrel.patch
- cd "$builddir"
- patch -Np1 <../linux-4.14-mc$pkgrel.patch
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-package() {
- local _carch=$CARCH
-
- case "$_carch" in
- aarch64*) _carch="arm64" ;;
- arm*) _carch="arm" ;;
- mips*) _carch="mips" ;;
- s390*) _carch="s390" ;;
- ppc*) _carch="powerpc" ;;
- pmmx) _carch="x86" ;;
- esac
-
- cd "$builddir"
- mkdir -p "$pkgdir/usr"
- make headers_install ARCH="${_carch}" INSTALL_HDR_PATH="$pkgdir/usr"
-
- find "$pkgdir/usr" \( -name .install -o -name ..install.cmd \) -exec \
- rm -f {} \;
-
- # provided by libdrm
- rm -rf "$pkgdir"/usr/include/drm
-}
-
-sha512sums="77e43a02d766c3d73b7e25c4aafb2e931d6b16e870510c22cef0cdb05c3acb7952b8908ebad12b10ef982c6efbe286364b1544586e715cf38390e483927904d8 linux-4.14.tar.xz
-3fe2da1714cc83d909ba43d27c7f22ef4f2a6ecfd91ff81e0e141a0dd742ec78ad11392186871762f410615ae7c7f33dd814e0f194c7f7aed1dee2d9fca0252d linux-4.14-mc8.patch.xz
-32597f2672d1ec365a936d15041a7cf219ef9353241d4a5c378244cf2fc155610443a19bbcd391c86099a0b08486c45e042ec7c90b0d04fe675c3ad0ffc36b53 revert-broken-uapi.patch"