summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-05-30 03:16:06 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-06-11 14:04:10 -0500
commit3a6f81dea5a725d5e251576436b2be290c0f8ea6 (patch)
tree840857ca4aa150c86ad3180c7a22f1f436588d09
parent3d25cc520363282c5b517a82515ea1ef40cb3c05 (diff)
downloadpackages-3a6f81dea5a725d5e251576436b2be290c0f8ea6.tar.gz
packages-3a6f81dea5a725d5e251576436b2be290c0f8ea6.tar.bz2
packages-3a6f81dea5a725d5e251576436b2be290c0f8ea6.tar.xz
packages-3a6f81dea5a725d5e251576436b2be290c0f8ea6.zip
user/squashfs-tools: Update to 4.6.1
Also, move tools to /usr/sbin because lzo/lz4 are in /usr/lib.
-rw-r--r--user/squashfs-tools/APKBUILD15
-rw-r--r--user/squashfs-tools/fix-compat.patch28
2 files changed, 21 insertions, 22 deletions
diff --git a/user/squashfs-tools/APKBUILD b/user/squashfs-tools/APKBUILD
index e33b06b16..be6eddb44 100644
--- a/user/squashfs-tools/APKBUILD
+++ b/user/squashfs-tools/APKBUILD
@@ -1,9 +1,9 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=squashfs-tools
-pkgver=4.4
+pkgver=4.6.1
pkgrel=0
pkgdesc="Tools for SquashFS, a highly compressed read-only filesystem"
-url="http://squashfs.sourceforge.net"
+url="https://squashfs.sourceforge.net"
arch="all"
options="!check" # No test suite.
license="GPL-2.0+"
@@ -12,7 +12,6 @@ makedepends="attr-dev lz4-dev lzo-dev xz-dev zlib-dev"
source="https://downloads.sourceforge.net/squashfs/squashfs$pkgver.tar.gz
fix-compat.patch
"
-builddir="$srcdir/squashfs$pkgver/$pkgname"
# secfixes:
# 4.3-r5:
@@ -21,13 +20,13 @@ builddir="$srcdir/squashfs$pkgver/$pkgname"
# - CVE-2015-4646
build() {
- make XZ_SUPPORT=1 LZO_SUPPORT=1 LZ4_SUPPORT=1
+ make XZ_SUPPORT=1 LZO_SUPPORT=1 LZ4_SUPPORT=1 -C squashfs-tools
}
package() {
- mkdir -p "$pkgdir"/sbin
- cp -a mksquashfs unsquashfs "$pkgdir"/sbin
+ mkdir -p "$pkgdir"/usr/sbin
+ cp -a squashfs-tools/mksquashfs squashfs-tools/unsquashfs "$pkgdir"/usr/sbin
}
-sha512sums="e7119f82cea0eda8dffcbf15c9ee511ad457e004bfc0c5a5685e84785e49cf34f3c053036449af6bba0012cef48426f65958c97b9958d58f1b31175cb0bbbe24 squashfs4.4.tar.gz
-12f5739aa32b9e15ba3d22e5953034f17867a8837475f13bde5bbc378dbded0483cde42c0cdfc5d33ab3723b9de752c71b5ba8f4301ca7b59aa4054d669c262d fix-compat.patch"
+sha512sums="10e8a4b1e2327e062aef4f85860e76ebcd7a29e4c19e152ff7edec4a38316982b5bcfde4ab69da6bcb931258d264c2b6cb40cb5f635f9e6f6eba1ed5976267cb squashfs4.6.1.tar.gz
+7572f2fab6357525bc607a8db92b0c1f5fc7d482e935c3ee1828543a3de474162b71b8441f77ee1656873def8593d99158b14c55ec44799f22eed2978aa19147 fix-compat.patch"
diff --git a/user/squashfs-tools/fix-compat.patch b/user/squashfs-tools/fix-compat.patch
index e93b6b827..adc7e420d 100644
--- a/user/squashfs-tools/fix-compat.patch
+++ b/user/squashfs-tools/fix-compat.patch
@@ -1,6 +1,6 @@
---- squashfs-tools/action.c
-+++ squashfs-tools/action.c
-@@ -2236,6 +2236,9 @@
+--- a/squashfs-tools/action.c
++++ b/squashfs-tools/action.c
+@@ -2562,6 +2562,9 @@
return 1;
}
@@ -10,21 +10,21 @@
TEST_FN(name, ACTION_ALL_LNK, \
return fnmatch(atom->argv[0], action_data->name,
---- squashfs-tools/mksquashfs.c
-+++ squashfs-tools/mksquashfs.c
-@@ -4665,6 +4665,9 @@
- return paths;
+--- a/squashfs-tools/mksquashfs.c
++++ b/squashfs-tools/mksquashfs.c
+@@ -4557,6 +4557,9 @@
+ return source;
}
+#ifndef FNM_EXTMATCH
+#define FNM_EXTMATCH 0
+#endif
- int excluded_match(char *name, struct pathname *path, struct pathnames **new)
- {
---- squashfs-tools/unsquashfs.c
-+++ squashfs-tools/unsquashfs.c
-@@ -1457,6 +1457,9 @@
+ static struct dir_info *add_source(struct dir_info *sdir, char *source,
+ char *subpath, char *file, char **prefix,
+--- a/squashfs-tools/unsquashfs.c
++++ b/squashfs-tools/unsquashfs.c
+@@ -1450,6 +1450,9 @@
free(paths);
}
@@ -32,5 +32,5 @@
+#define FNM_EXTMATCH 0
+#endif
- int matches(struct pathnames *paths, char *name, struct pathnames **new)
- {
+ struct pathname *add_path(struct pathname *paths, int type, char *target,
+ char *alltarget)