summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-05-29 22:02:06 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-06-11 14:04:08 -0500
commit4a699491b04a1a9458ec022a1cd150085fd04d97 (patch)
treebf154a4f016c5f37ada9a63673bbd8642699537a
parent22fdcc4f20f6aa4b4c926eb39f5bd9208a96dc5e (diff)
downloadpackages-4a699491b04a1a9458ec022a1cd150085fd04d97.tar.gz
packages-4a699491b04a1a9458ec022a1cd150085fd04d97.tar.bz2
packages-4a699491b04a1a9458ec022a1cd150085fd04d97.tar.xz
packages-4a699491b04a1a9458ec022a1cd150085fd04d97.zip
user/liblbxutil: Patch for -fno-common
No upstream any more, so not submitted.
-rw-r--r--user/liblbxutil/APKBUILD9
-rw-r--r--user/liblbxutil/gcc10.patch18
2 files changed, 24 insertions, 3 deletions
diff --git a/user/liblbxutil/APKBUILD b/user/liblbxutil/APKBUILD
index 2c7f03f5d..1e3c56c36 100644
--- a/user/liblbxutil/APKBUILD
+++ b/user/liblbxutil/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=liblbxutil
pkgver=1.1.0
-pkgrel=0
+pkgrel=1
pkgdesc="Utility library for X11 Low Bandwidth extension"
url="https://www.X.Org/"
arch="all"
@@ -10,7 +10,9 @@ license="MIT"
depends=""
makedepends="xorgproto-dev zlib-dev"
subpackages="$pkgname-dev"
-source="https://www.x.org/releases/individual/lib/liblbxutil-$pkgver.tar.bz2"
+source="https://www.x.org/releases/individual/lib/liblbxutil-$pkgver.tar.bz2
+ gcc10.patch
+ "
prepare() {
default_prepare
@@ -37,4 +39,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="93bdefef297d46a301dd1cab35ad186438e340822ba5aac20e9d8f4c51cd66e4118b0d9f4afc48ef33a67c6e413f551bcb59089d01597ed175b400902b9f23f4 liblbxutil-1.1.0.tar.bz2"
+sha512sums="93bdefef297d46a301dd1cab35ad186438e340822ba5aac20e9d8f4c51cd66e4118b0d9f4afc48ef33a67c6e413f551bcb59089d01597ed175b400902b9f23f4 liblbxutil-1.1.0.tar.bz2
+c1abd8d42e11d84019f5bc3e93774a1b65201c9e08b70a5cf0b78680bdc9d6a49043908510c2dccdf1b53dc6b434261377b0330ab603c8d4929cf001b802f44c gcc10.patch"
diff --git a/user/liblbxutil/gcc10.patch b/user/liblbxutil/gcc10.patch
new file mode 100644
index 000000000..5e9b99d91
--- /dev/null
+++ b/user/liblbxutil/gcc10.patch
@@ -0,0 +1,18 @@
+--- liblbxutil-1.1.0/src/lbx_zlib/lbx_zlib.h.old 2009-11-02 23:52:21.000000000 -0600
++++ liblbxutil-1.1.0/src/lbx_zlib/lbx_zlib.h 2024-05-29 21:33:09.169332780 -0500
+@@ -136,9 +136,9 @@
+ #endif
+
+ /* lbx_zlib.c */
+-unsigned long stream_out_compressed;
+-unsigned long stream_out_uncompressed;
+-unsigned long stream_out_plain;
+-unsigned long stream_in_compressed;
+-unsigned long stream_in_uncompressed;
+-unsigned long stream_in_plain;
++extern unsigned long stream_out_compressed;
++extern unsigned long stream_out_uncompressed;
++extern unsigned long stream_out_plain;
++extern unsigned long stream_in_compressed;
++extern unsigned long stream_in_uncompressed;
++extern unsigned long stream_in_plain;