summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-05-27 15:19:30 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-06-11 14:03:58 -0500
commit6d7eee150382c2dba5365035b553a0357051270d (patch)
treec0cbe27272ae65f287b2264f73fdbe851f939fe0
parent313ca51c78a5625fa8b7d14cc0181ae9add48592 (diff)
downloadpackages-6d7eee150382c2dba5365035b553a0357051270d.tar.gz
packages-6d7eee150382c2dba5365035b553a0357051270d.tar.bz2
packages-6d7eee150382c2dba5365035b553a0357051270d.tar.xz
packages-6d7eee150382c2dba5365035b553a0357051270d.zip
user/qt5-qtwebkit: Patch missing header
GCC 13 C++ STL doesn't bring in <cstdint>, needed by ANGLE for uint32_t.
-rw-r--r--user/qt5-qtwebkit/APKBUILD4
-rw-r--r--user/qt5-qtwebkit/missing-header.patch11
2 files changed, 14 insertions, 1 deletions
diff --git a/user/qt5-qtwebkit/APKBUILD b/user/qt5-qtwebkit/APKBUILD
index 63e18cb07..d4c677f39 100644
--- a/user/qt5-qtwebkit/APKBUILD
+++ b/user/qt5-qtwebkit/APKBUILD
@@ -4,7 +4,7 @@ pkgname=qt5-qtwebkit
_realname=qtwebkit
pkgver=5.212.0_git20200924
_ts=1600955993
-pkgrel=1
+pkgrel=2
pkgdesc="Open source Web browser engine"
url="https://github.com/qtwebkit/qtwebkit/wiki"
arch="all"
@@ -25,6 +25,7 @@ source="https://download.qt.io/snapshots/ci/qtwebkit/${pkgver%.*}/$_ts/src/submo
glib-compat.patch
icu-68.patch
jsc-musl.patch
+ missing-header.patch
ppc-llint.patch
ppc-ucontext.patch
ppc64-llint.patch
@@ -91,6 +92,7 @@ ca77802de1b945c05b6a88d5cc0cbb093a751ef16626d221c8b2ca5cf841f5d42fffe62087df1ce0
9f42f3d64657fb9487d9299ad5931381f9aa91a746a5986dc361def5e9a6e02933054a66132fa99057460ad6de0c19e9b51e07594451cc4f38b19012a69d205c glib-compat.patch
5f0ca182c68c55a6f221e96bf2221784c7126006ea8db3e9eee2b66dbdda18d7d0f9830e8345ac2b0bc6f557af5d2a54a321b06be4a2c845dd1003282b053443 icu-68.patch
9e3638d4d5c6e56510525931b278c8d6e28134917c300837b4eccf1b9298af1e274668318af82091137e99b83da0f78904084b7ee9dd8422b347a0f35e765c31 jsc-musl.patch
+ee3d06d3c350980a2a042961b6943d42706599b39270addce3904535811b18a2af8f74842f2d21267ce71250b97c05de600ec416e042f4d1cdbc2701711b5f4a missing-header.patch
4a3a15f8b1e63cade07c589be45afd794b45b34ee98e4d2d3fc2f52662c26c518d400b44c9314e41113cad847b9efd544d2a4c02425c9892ca9729e218ae9306 ppc-llint.patch
48f81c6a2c0f4e9b215dada4c0bebdafc66feb75178a7b1ca661f2bbcddd6b573e7db4dd179f6e4b6345c7ebcf17ce1c6647cc6ce39dbac8ba68f8863a98bdc0 ppc-ucontext.patch
db98d710815eb68f1fb025098b04c34b33518750c193e702383ca879e145c52ba4786fa4721f384f01f90231c32be9478d507c1000eb761621751edcd071b966 ppc64-llint.patch"
diff --git a/user/qt5-qtwebkit/missing-header.patch b/user/qt5-qtwebkit/missing-header.patch
new file mode 100644
index 000000000..da0eed43c
--- /dev/null
+++ b/user/qt5-qtwebkit/missing-header.patch
@@ -0,0 +1,11 @@
+The GCC 13 C++ stdlib doesn't include <stdint.h> any more, which is used for uint32_t.
+--- qtwebkit-opensource-src-5.212/Source/ThirdParty/ANGLE/src/common/mathutil.h.old 2020-09-22 06:30:04.000000000 -0500
++++ qtwebkit-opensource-src-5.212/Source/ThirdParty/ANGLE/src/common/mathutil.h 2024-05-27 14:43:22.625301664 -0500
+@@ -14,6 +14,7 @@
+
+ #include <limits>
+ #include <algorithm>
++#include <stdint.h>
+ #include <string.h>
+ #include <stdlib.h>
+