summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2022-04-24 21:48:56 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2022-04-24 21:48:56 -0500
commitf0dcb63ebf1cf89d813ec0618a7ce0ef4a6af5c5 (patch)
treee200b09345d16d5a7ed5ad1e5ec0d73095920d81
parent960498f20d23a1dffad2aa308ce54d538ba079fa (diff)
downloadpackages-f0dcb63ebf1cf89d813ec0618a7ce0ef4a6af5c5.tar.gz
packages-f0dcb63ebf1cf89d813ec0618a7ce0ef4a6af5c5.tar.bz2
packages-f0dcb63ebf1cf89d813ec0618a7ce0ef4a6af5c5.tar.xz
packages-f0dcb63ebf1cf89d813ec0618a7ce0ef4a6af5c5.zip
system/libxml2: Update to 2.9.13 release and fix
* URL has moved to GNOME infrastructure, as have release tarballs. * Test suite has been fixed, which closes #465. musl iconv stil doesn't work right with EUC-JP; I've disabled iconv entirely for libxml2. Yes, this is a big hammer, but the alternative would be to somehow teach libxml2 that *only* for EUC-JP, use ICU instead. It seems cleaner to just disable iconv until musl works right with EUC-JP code.
-rw-r--r--system/libxml2/APKBUILD21
1 files changed, 9 insertions, 12 deletions
diff --git a/system/libxml2/APKBUILD b/system/libxml2/APKBUILD
index 9c294b6e7..57845daa8 100644
--- a/system/libxml2/APKBUILD
+++ b/system/libxml2/APKBUILD
@@ -1,22 +1,20 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libxml2
-pkgver=2.9.13_pre1
-pkgdate=20220112
+pkgver=2.9.13
pkgrel=0
pkgdesc="XML parsing library"
-url="http://www.xmlsoft.org/"
+url="https://gitlab.gnome.org/GNOME/libxml2/-/wikis/home"
arch="all"
-options="!strip" # Impossible to run on Python 3
+options="!strip"
license="MIT"
depends=""
depends_dev="zlib-dev icu-dev"
checkdepends="perl libarchive"
-makedepends="$depends_dev python3-dev autoconf automake libtool"
+makedepends="$depends_dev python3-dev"
subpackages="$pkgname-doc $pkgname-dev py-libxml2:py"
provides="$pkgname-utils=$pkgver-r$pkgrel"
-#source="ftp://ftp.xmlsoft.org/${pkgname}/${pkgname}-${pkgver}.tar.gz"
-source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver-$pkgdate.tar.gz
+source="https://download.gnome.org/sources/libxml2/2.9/libxml2-$pkgver.tar.xz
python-segfault-fix.patch
"
@@ -31,14 +29,12 @@ source="https://distfiles.adelielinux.org/source/$pkgname-$pkgver-$pkgdate.tar.g
# - CVE-2019-20388
# - CVE-2020-7595
-builddir="$srcdir/$pkgname-$pkgver-$pkgdate"
-
prepare() {
default_prepare
}
build() {
- ./autogen.sh \
+ ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
@@ -46,12 +42,13 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--with-icu \
+ --without-iconv \
--with-python=/usr/bin/python3
make
}
check() {
- make -ik check # FIXME: #465
+ make check
}
package() {
@@ -70,5 +67,5 @@ py() {
mv "$pkgdir"/usr/lib/python3* "$subpkgdir"/usr/lib/
}
-sha512sums="fed9e35478f169411700e5216ebf9735afbde5bcc2a6f9ad81959d11907d28d9ed4281613af31ef410aeef6acbd6e62dd168268f75454a9942261a86db3933ff libxml2-2.9.13_pre1-20220112.tar.gz
+sha512sums="fc51980cb9222bd3b5242f73d28b55fa15a80e68e52e1c45274f1eda11500ed385853209edb3b2a1f06b9de0be304c159a9bd898c7d84b0899eacb00723d98b5 libxml2-2.9.13.tar.xz
384b3d2031cd8f77528190bbb7652faa9ccb22bc604bcf4927e59046d38830dac38010828fe1568b6514976f725981a6d3ac1aa595d31477a36db2afe491452c python-segfault-fix.patch"