summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-01-07 22:08:41 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-01-07 22:08:41 +0000
commitd0d3e4bb8a64e976e0d7ff8d25fcdbda4556648f (patch)
treeeee20c0afd09b50da7c4ef94e7775b85dd4aca18
parent14cd2a940d42e9a28c6c51ee7fb8fde9e64efb3e (diff)
parent677a7de7f445dad6dab7c8531029f3e45fab8a0a (diff)
downloadpackages-d0d3e4bb8a64e976e0d7ff8d25fcdbda4556648f.tar.gz
packages-d0d3e4bb8a64e976e0d7ff8d25fcdbda4556648f.tar.bz2
packages-d0d3e4bb8a64e976e0d7ff8d25fcdbda4556648f.tar.xz
packages-d0d3e4bb8a64e976e0d7ff8d25fcdbda4556648f.zip
Merge branch 'abiword' into 'master'
New packages: AbiWord + dependencies APKBUILDs converted from Alpine, with some changes to bring AbiWord's plugins into a single `abiword` package and cleaning of the licence lines. This has been tested on x86_64 (2007 Macbook Pro), and AbiWord shows some rendering flicker, which I'm not sure how to debug, but otherwise appears to run fine. See merge request !141
-rw-r--r--user/abiword/APKBUILD50
-rw-r--r--user/abiword/fix-black-drawing-regression.patch54
-rw-r--r--user/goffice/APKBUILD39
-rw-r--r--user/wv/APKBUILD36
4 files changed, 179 insertions, 0 deletions
diff --git a/user/abiword/APKBUILD b/user/abiword/APKBUILD
new file mode 100644
index 000000000..351961055
--- /dev/null
+++ b/user/abiword/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: multiplexd <multi@in-addr.xyz>
+pkgname=abiword
+pkgver=3.0.2
+pkgrel=0
+pkgdesc="A fully-featured word processor"
+url="https://www.abisource.com"
+arch="all"
+options="!check" # Test suite requires valgrind, etc
+license="GPL-2.0+"
+makedepends="bzip2-dev enchant-dev fribidi-dev goffice-dev gtk+3.0-dev
+ libgsf-dev libjpeg-turbo-dev librsvg-dev libxslt-dev pcre-dev
+ popt-dev wv-dev"
+
+# openxml plugin
+makedepends="$makedepends boost-dev"
+
+# collab plugin
+makedepends="$makedepends gnutls-dev libsoup-dev dbus-glib-dev"
+
+subpackages="$pkgname-dev $pkgname-doc"
+
+_plugins="applix babelfish bmp clarisworks collab docbook eml epub \
+ freetranslation garble gdict gimp google hancom hrtext iscii kword \
+ latex loadbindings mht mif mswrite openwriter openxml opml paint \
+ passepartout pdb pdf presentation s5 sdw t602 urldict wikipedia wml \
+ xslfo"
+
+source="https://www.abisource.com/downloads/$pkgname/$pkgver/source/$pkgname-$pkgver.tar.gz
+ fix-black-drawing-regression.patch"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --enable-shared \
+ --disable-static \
+ --enable-plugins="$_plugins"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="29ce9e80b3b85ab2933e7d39216771d8c4e05db5255eaed0cf8e1d032ffaac2cb1880bf24e754196ad5dae4969a1c2101ce4dc9c1db14604adc2f852b6a17fe3 abiword-3.0.2.tar.gz
+cae9a08047cd97d11acea25a2f0b0ca4e8e4556b462eb476507fa178a7412221839febfeb36bebf491bb94d53525c4584d86230f96c403a7ceb2dec4223be8fe fix-black-drawing-regression.patch"
diff --git a/user/abiword/fix-black-drawing-regression.patch b/user/abiword/fix-black-drawing-regression.patch
new file mode 100644
index 000000000..dbce8c696
--- /dev/null
+++ b/user/abiword/fix-black-drawing-regression.patch
@@ -0,0 +1,54 @@
+From cec2fda355b67b5b814a803c5ed128c425cbb030 Mon Sep 17 00:00:00 2001
+From: Hubert Figuiere <hub@figuiere.net>
+Date: Thu, 8 Dec 2016 02:03:10 +0000
+Subject: [PATCH] Bug 13815 - draw event should return TRUE
+
+This fix the black drawing regression with Gtk3.22
+
+git-svn-id: svn+ssh://svn.abisource.com/svnroot/abiword/branches/ABI-3-0-0-STABLE@35394 bcba8976-2d24-0410-9c9c-aab3bd5fdfd6
+---
+ src/af/xap/gtk/xap_UnixFrameImpl.cpp | 6 +++---
+ src/af/xap/gtk/xap_UnixFrameImpl.h | 4 ++--
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/src/af/xap/gtk/xap_UnixFrameImpl.cpp b/src/af/xap/gtk/xap_UnixFrameImpl.cpp
+index 780000e..10f8e00 100644
+--- a/src/af/xap/gtk/xap_UnixFrameImpl.cpp
++++ b/src/af/xap/gtk/xap_UnixFrameImpl.cpp
+@@ -1208,9 +1208,9 @@ gint XAP_UnixFrameImpl::_fe::delete_event(GtkWidget * w, GdkEvent * /*event*/, g
+ }
+
+ #if GTK_CHECK_VERSION(3,0,0)
+-gint XAP_UnixFrameImpl::_fe::draw(GtkWidget * w, cairo_t * cr)
++gboolean XAP_UnixFrameImpl::_fe::draw(GtkWidget * w, cairo_t * cr)
+ #else
+-gint XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
++gboolean XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
+ #endif
+ {
+ XAP_UnixFrameImpl * pUnixFrameImpl = static_cast<XAP_UnixFrameImpl *>(g_object_get_data(G_OBJECT(w), "user_data"));
+@@ -1243,7 +1243,7 @@ gint XAP_UnixFrameImpl::_fe::expose(GtkWidget * w, GdkEventExpose* pExposeEvent)
+ pView->draw(&rClip);
+ #endif
+ }
+- return FALSE;
++ return TRUE;
+ }
+
+ static bool bScrollWait = false;
+diff --git a/src/af/xap/gtk/xap_UnixFrameImpl.h b/src/af/xap/gtk/xap_UnixFrameImpl.h
+index 30ee5d8..a0ff57f 100644
+--- a/src/af/xap/gtk/xap_UnixFrameImpl.h
++++ b/src/af/xap/gtk/xap_UnixFrameImpl.h
+@@ -152,9 +152,9 @@ class XAP_UnixFrameImpl : public XAP_FrameImpl
+ static gint key_release_event(GtkWidget* w, GdkEventKey* e);
+ static gint delete_event(GtkWidget * w, GdkEvent * /*event*/, gpointer /*data*/);
+ #if GTK_CHECK_VERSION(3,0,0)
+- static gint draw(GtkWidget * w, cairo_t * cr);
++ static gboolean draw(GtkWidget * w, cairo_t * cr);
+ #else
+- static gint expose(GtkWidget * w, GdkEventExpose* pExposeEvent);
++ static gboolean expose(GtkWidget * w, GdkEventExpose* pExposeEvent);
+ #endif
+ static gint do_ZoomUpdate( gpointer /* xap_UnixFrame * */ p);
+ static void vScrollChanged(GtkAdjustment * w, gpointer /*data*/);
diff --git a/user/goffice/APKBUILD b/user/goffice/APKBUILD
new file mode 100644
index 000000000..0b5fc833b
--- /dev/null
+++ b/user/goffice/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: multiplexd <multi@in-addr.xyz>
+pkgname=goffice
+pkgver=0.10.44
+pkgrel=0
+pkgdesc="Library of document-centric objects and utilities built on top of GLib and Gtk+"
+url="https://www.gnome.org"
+arch="all"
+license="(GPL-2.0-only OR GPL-3.0-only) AND GPL-2.0+ AND MIT"
+makedepends="librsvg-dev intltool gtk+2.0-dev libtool gtk-doc
+ libxslt-dev gobject-introspection-dev glib-dev libgsf-dev cairo-dev
+ libxml2-dev gtk+3.0-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-introspection
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="9e86440afaee4d6eadd31c328a13dc54fb4056dfc70ef0196d83bada5f05eb4fc12daf35fc4e79ea6ebfe8a97dc6ed74b50e514f9d27f08bff776ab898f1c71d goffice-0.10.44.tar.xz"
diff --git a/user/wv/APKBUILD b/user/wv/APKBUILD
new file mode 100644
index 000000000..ec9a0a081
--- /dev/null
+++ b/user/wv/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: multiplexd <multi@in-addr.xyz>
+pkgname=wv
+pkgver=1.2.9
+pkgrel=0
+pkgdesc="A library that can load and parse Word 2000, 97, 95 and 6 file formats"
+url="https://sourceforge.net/projects/wvware"
+arch="all"
+options="!check" # No test suite.
+license="GPL-2.0+ AND RSA-MD5"
+subpackages="$pkgname-dev $pkgname-doc"
+depends=""
+makedepends="libgsf-dev libpng-dev bzip2-dev"
+source="https://www.abisource.com/downloads/wv/$pkgver/wv-$pkgver.tar.gz"
+
+prepare() {
+ update_config_sub
+ default_prepare
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="ae5c762012595ce8922bfda8749ad3e9cb055edab30152c3a5feaaf3ca6601f357d1e301b179e9a5860cd99452dd6e63e5f44f5bcc12f8db148bdd334e0200a5 wv-1.2.9.tar.gz"