summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2023-12-08 04:07:16 +0000
committerZach van Rijn <me@zv.io>2023-12-08 04:07:23 +0000
commit34bd072dbef9f246959a74237f85c486c0f74fe5 (patch)
treeb3eea6a7c1e18480dd266c2e132601af78ef4ad7
parent0f1e27f9dd51d8dceffb2f1ac4b8370e8f915e0a (diff)
downloadpackages-34bd072dbef9f246959a74237f85c486c0f74fe5.tar.gz
packages-34bd072dbef9f246959a74237f85c486c0f74fe5.tar.bz2
packages-34bd072dbef9f246959a74237f85c486c0f74fe5.tar.xz
packages-34bd072dbef9f246959a74237f85c486c0f74fe5.zip
system/curl: add missing test dependency.
See: https://github.com/curl/curl/issues/12462 This was an oversight with the 8.5.0 release and should be included in subsequent releases.
-rw-r--r--system/curl/APKBUILD13
-rw-r--r--system/curl/errorcodes.pl99
2 files changed, 110 insertions, 2 deletions
diff --git a/system/curl/APKBUILD b/system/curl/APKBUILD
index 848cd084f..f66ade976 100644
--- a/system/curl/APKBUILD
+++ b/system/curl/APKBUILD
@@ -13,7 +13,9 @@ depends="ca-certificates"
makedepends_build="perl"
makedepends_host="libssh2-dev nghttp2-dev openssl-dev zlib-dev zstd-dev"
makedepends="$makedepends_build $makedepends_host"
-source="https://curl.haxx.se/download/$pkgname-$pkgver.tar.xz"
+source="https://curl.haxx.se/download/$pkgname-$pkgver.tar.xz
+ errorcodes.pl
+ "
subpackages="$pkgname-dbg $pkgname-doc $pkgname-dev libcurl"
# secfixes:
@@ -100,6 +102,12 @@ subpackages="$pkgname-dbg $pkgname-doc $pkgname-dev libcurl"
# - CVE-2014-0138
# - CVE-2014-0139
+prepare() {
+ default_prepare
+
+ cp "$srcdir"/errorcodes.pl "$builddir"/tests/errorcodes.pl
+}
+
build() {
./configure \
--build=$CBUILD \
@@ -132,4 +140,5 @@ libcurl() {
mv "$pkgdir"/usr/lib "$subpkgdir"/usr
}
-sha512sums="acffa2cf61d9b8e4188575a1b40227da8d722df2e5fe8bb82a222b4eb2fd64bf8aebd90852ce050c79fb5e517d5cee2546bf7de92ede1dd394263e231cb741a3 curl-8.5.0.tar.xz"
+sha512sums="acffa2cf61d9b8e4188575a1b40227da8d722df2e5fe8bb82a222b4eb2fd64bf8aebd90852ce050c79fb5e517d5cee2546bf7de92ede1dd394263e231cb741a3 curl-8.5.0.tar.xz
+7848b1271e0bfe3be40221fb0582712d4af3ce1e1bdf16b5f0cac731d81bda145efc039f945a311af70caff279a44435a8ead6bb6e1db7570a4bd22df0a77fdb errorcodes.pl"
diff --git a/system/curl/errorcodes.pl b/system/curl/errorcodes.pl
new file mode 100644
index 000000000..9c8f9e882
--- /dev/null
+++ b/system/curl/errorcodes.pl
@@ -0,0 +1,99 @@
+#!/usr/bin/env perl
+#***************************************************************************
+# _ _ ____ _
+# Project ___| | | | _ \| |
+# / __| | | | |_) | |
+# | (__| |_| | _ <| |___
+# \___|\___/|_| \_\_____|
+#
+# Copyright (C) Daniel Stenberg, <daniel@haxx.se>, et al.
+#
+# This software is licensed as described in the file COPYING, which
+# you should have received as part of this distribution. The terms
+# are also available at https://curl.se/docs/copyright.html.
+#
+# You may opt to use, copy, modify, merge, publish, distribute and/or sell
+# copies of the Software, and permit persons to whom the Software is
+# furnished to do so, under the terms of the COPYING file.
+#
+# This software is distributed on an "AS IS" basis, WITHOUT WARRANTY OF ANY
+# KIND, either express or implied.
+#
+# SPDX-License-Identifier: curl
+#
+###########################################################################
+
+# Check that libcurl-errors.3 and the public header files have the same set of
+# error codes.
+
+use strict;
+use warnings;
+
+# we may get the dir roots pointed out
+my $root=$ARGV[0] || ".";
+my $manpge = "$root/docs/libcurl/libcurl-errors.3";
+my $curlh = "$root/include/curl";
+my $errors=0;
+
+my @hnames;
+my %wherefrom;
+my @mnames;
+my %manfrom;
+
+sub scanheader {
+ my ($file)=@_;
+ open H, "<$file";
+ my $line = 0;
+ while(<H>) {
+ $line++;
+ if($_ =~ /^ (CURL(E|UE|SHE|HE|M)_[A-Z0-9_]*)/) {
+ my ($name)=($1);
+ if(($name !~ /OBSOLETE/) && ($name !~ /_LAST\z/)) {
+ push @hnames, $name;
+ if($wherefrom{$name}) {
+ print STDERR "double: $name\n";
+ }
+ $wherefrom{$name}="$file:$line";
+ }
+ }
+ }
+ close(H);
+}
+
+sub scanmanpage {
+ my ($file)=@_;
+ open H, "<$file";
+ my $line = 0;
+ while(<H>) {
+ $line++;
+ if($_ =~ /^\.IP \"(CURL(E|UE|SHE|HE|M)_[A-Z0-9_]*)/) {
+ my ($name)=($1);
+ push @mnames, $name;
+ $manfrom{$name}="$file:$line";
+ }
+ }
+ close(H);
+}
+
+
+opendir(my $dh, $curlh) || die "Can't opendir $curlh: $!";
+my @hfiles = grep { /\.h$/ } readdir($dh);
+closedir $dh;
+
+for(sort @hfiles) {
+ scanheader("$curlh/$_");
+}
+scanmanpage($manpge);
+
+print "Result\n";
+for my $h (sort @hnames) {
+ if(!$manfrom{$h}) {
+ printf "$h from %s, not in man page\n", $wherefrom{$h};
+ }
+}
+
+for my $m (sort @mnames) {
+ if(!$wherefrom{$m}) {
+ printf "$m from %s, not in any header\n", $manfrom{$m};
+ }
+}