summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2023-12-01 00:19:17 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2023-12-01 00:28:33 -0600
commite82bed3a2e82f672ecefe6bdba82d3217d71acc1 (patch)
tree22b0e35456aab7919caa4993336b41afb8b3f03f
parent2478ef9d52aeb22fd538f6b0f663c053d7734fba (diff)
downloadpackages-e82bed3a2e82f672ecefe6bdba82d3217d71acc1.tar.gz
packages-e82bed3a2e82f672ecefe6bdba82d3217d71acc1.tar.bz2
packages-e82bed3a2e82f672ecefe6bdba82d3217d71acc1.tar.xz
packages-e82bed3a2e82f672ecefe6bdba82d3217d71acc1.zip
system/argon2: Use upstream version in .pc file
Closes: #1130
-rw-r--r--system/argon2/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/system/argon2/APKBUILD b/system/argon2/APKBUILD
index c7a1bd6c2..14427ad12 100644
--- a/system/argon2/APKBUILD
+++ b/system/argon2/APKBUILD
@@ -4,7 +4,7 @@
pkgname=argon2
_pkgname=phc-winner-argon2
pkgver=20190702
-pkgrel=1
+pkgrel=2
pkgdesc="Password hashing library"
url="https://github.com/P-H-C/phc-winner-argon2"
arch="all"
@@ -18,17 +18,17 @@ builddir="$srcdir/$_pkgname-$pkgver"
build() {
# musl >= 1.1.20 has explicit_bzero for better security
export CFLAGS="$CFLAGS -DHAVE_EXPLICIT_BZERO=1"
- make OPTTARGET=none
+ make OPTTARGET=none ARGON2_VERSION=$pkgver
}
check() {
- make OPTTARGET=none test
+ make OPTTARGET=none ARGON2_VERSION=$pkgver test
}
package() {
# pkgconfig file has it in /usr/lib...
sed -i 's#libdir=${prefix}/lib#libdir=/lib#' "$builddir"/libargon2.pc
- make OPTTARGET=none DESTDIR="$pkgdir" LIBRARY_REL=lib install
+ make OPTTARGET=none ARGON2_VERSION=$pkgver DESTDIR="$pkgdir" LIBRARY_REL=lib install
# ...but cryptsetup needs this in /lib for early-boot
mkdir "$pkgdir"/lib
mv "$pkgdir"/usr/lib/lib* "$pkgdir"/lib