summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorst G. Burkhardt <horst@adelielinux.org>2018-04-30 01:10:18 +0000
committerHorst G. Burkhardt <horst@adelielinux.org>2018-04-30 01:10:18 +0000
commit75c24f1096efec918b5483e0efcb39a352edcb77 (patch)
tree4e5a50f4365b59fbef0cc91c28d8bfd097ce861f
parente7943d2200389ce25601aa72156f838647477596 (diff)
downloadpackages-75c24f1096efec918b5483e0efcb39a352edcb77.tar.gz
packages-75c24f1096efec918b5483e0efcb39a352edcb77.tar.bz2
packages-75c24f1096efec918b5483e0efcb39a352edcb77.tar.xz
packages-75c24f1096efec918b5483e0efcb39a352edcb77.zip
user/mednafen: new package
-rw-r--r--user/mednafen/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/user/mednafen/APKBUILD b/user/mednafen/APKBUILD
new file mode 100644
index 000000000..ac9e86e2b
--- /dev/null
+++ b/user/mednafen/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Horst Burkhardt <horst@adelielinux.org>
+# Maintainer: Horst Burkhardt <horst@adelielinux.org>
+pkgname=mednafen
+pkgver=1.21.2
+pkgrel=0
+pkgdesc="an emulator for various home gaming consoles"
+url="https://mednafen.github.io/"
+arch="all !s390x"
+options="!check" # mednafen does not ship actual tests
+subpackages="$pkgname-doc"
+license="GPL-2.0-only"
+depends=""
+makedepends="libogg-dev libvorbis-dev flac-dev lzo-dev sdl2-dev libsndfile-dev alsa-lib-dev"
+source="https://mednafen.github.io/releases/files/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir/$pkgname"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr --enable-ss=no
+ make
+}
+
+package() {
+ make install
+}
+
+sha512sums="f1eef8cfccc26a40587d0d2c4f7c4aa74ede90889869d620c127e26a500650a4cec801e3fb6d38a62b441e986234803d9ec2099c85ac06f1448c61039de927ed mednafen-1.21.2.tar.xz"