summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-11-01 05:47:14 +0000
committerZach van Rijn <me@zv.io>2022-11-01 05:47:14 +0000
commit0b29f41ffd5a2733443c43e80535c0f7f6adaec5 (patch)
tree16d6797e22b2fc4403fd8146aed5c415500f2bf7
parent895abb5387a2f4121dbac4301ab00156acda16bd (diff)
downloadpackages-0b29f41ffd5a2733443c43e80535c0f7f6adaec5.tar.gz
packages-0b29f41ffd5a2733443c43e80535c0f7f6adaec5.tar.bz2
packages-0b29f41ffd5a2733443c43e80535c0f7f6adaec5.tar.xz
packages-0b29f41ffd5a2733443c43e80535c0f7f6adaec5.zip
system/zlib: bump { 1.2.12 --> 1.2.13 }. fixes #820.
-rw-r--r--system/zlib/APKBUILD11
-rw-r--r--system/zlib/fix-configure-issue.patch24
-rw-r--r--system/zlib/keep-legacy-crc-behavior.patch51
3 files changed, 3 insertions, 83 deletions
diff --git a/system/zlib/APKBUILD b/system/zlib/APKBUILD
index 39490a78b..cd9f15ccc 100644
--- a/system/zlib/APKBUILD
+++ b/system/zlib/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Zach van Rijn <me@zv.io>
pkgname=zlib
-pkgver=1.2.12
+pkgver=1.2.13
pkgrel=0
pkgdesc="A compression/decompression Library"
arch="all"
@@ -9,10 +9,7 @@ url="https://zlib.net"
depends=""
makedepends=""
subpackages="$pkgname-dev $pkgname-doc"
-source="https://zlib.net/$pkgname-$pkgver.tar.gz
- fix-configure-issue.patch
- keep-legacy-crc-behavior.patch
- "
+source="https://zlib.net/$pkgname-$pkgver.tar.gz"
build() {
CHOST="${CHOST}" ./configure \
@@ -32,6 +29,4 @@ package() {
DESTDIR="$pkgdir"
}
-sha512sums="cc2366fa45d5dfee1f983c8c51515e0cff959b61471e2e8d24350dea22d3f6fcc50723615a911b046ffc95f51ba337d39ae402131a55e6d1541d3b095d6c0a14 zlib-1.2.12.tar.gz
-078f85be91fa0051d50950148894356a4a3e179aea78163499f929c4f4f1d7b87087d082af4ba2f6fd7eb2574f3ec4082a32f8877a863ca20673717cb66e9f4d fix-configure-issue.patch
-38f0593a0bc17336d31191b7af684e31ec2eb34bd3add49bcb1f95c5e2bfb4405ffc341c2650d52c4fbf417ab4f80a0cc82fb868c9816b04d25210ae29a71f2c keep-legacy-crc-behavior.patch"
+sha512sums="99f0e843f52290e6950cc328820c0f322a4d934a504f66c7caa76bd0cc17ece4bf0546424fc95135de85a2656fed5115abb835fd8d8a390d60ffaf946c8887ad zlib-1.2.13.tar.gz"
diff --git a/system/zlib/fix-configure-issue.patch b/system/zlib/fix-configure-issue.patch
deleted file mode 100644
index 0136071ea..000000000
--- a/system/zlib/fix-configure-issue.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 05796d3d8d5546cf1b4dfe2cd72ab746afae505d Mon Sep 17 00:00:00 2001
-From: Mark Adler <madler@alumni.caltech.edu>
-Date: Mon, 28 Mar 2022 18:34:10 -0700
-Subject: [PATCH] Fix configure issue that discarded provided CC definition.
-
----
- configure | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/configure b/configure
-index 52ff4a04e..3fa3e8618 100755
---- a/configure
-+++ b/configure
-@@ -174,7 +174,10 @@ if test -z "$CC"; then
- else
- cc=${CROSS_PREFIX}cc
- fi
-+else
-+ cc=${CC}
- fi
-+
- cflags=${CFLAGS-"-O3"}
- # to force the asm version use: CFLAGS="-O3 -DASMV" ./configure
- case "$cc" in
diff --git a/system/zlib/keep-legacy-crc-behavior.patch b/system/zlib/keep-legacy-crc-behavior.patch
deleted file mode 100644
index 85a6a7e3a..000000000
--- a/system/zlib/keep-legacy-crc-behavior.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From ec3df00224d4b396e2ac6586ab5d25f673caa4c2 Mon Sep 17 00:00:00 2001
-From: Mark Adler <madler@alumni.caltech.edu>
-Date: Wed, 30 Mar 2022 11:14:53 -0700
-Subject: [PATCH] Correct incorrect inputs provided to the CRC functions.
-
-The previous releases of zlib were not sensitive to incorrect CRC
-inputs with bits set above the low 32. This commit restores that
-behavior, so that applications with such bugs will continue to
-operate as before.
----
- crc32.c | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/crc32.c b/crc32.c
-index a1bdce5c2..451887bc7 100644
---- a/crc32.c
-+++ b/crc32.c
-@@ -630,7 +630,7 @@ unsigned long ZEXPORT crc32_z(crc, buf, len)
- #endif /* DYNAMIC_CRC_TABLE */
-
- /* Pre-condition the CRC */
-- crc ^= 0xffffffff;
-+ crc = (~crc) & 0xffffffff;
-
- /* Compute the CRC up to a word boundary. */
- while (len && ((z_size_t)buf & 7) != 0) {
-@@ -749,7 +749,7 @@ unsigned long ZEXPORT crc32_z(crc, buf, len)
- #endif /* DYNAMIC_CRC_TABLE */
-
- /* Pre-condition the CRC */
-- crc ^= 0xffffffff;
-+ crc = (~crc) & 0xffffffff;
-
- #ifdef W
-
-@@ -1077,7 +1077,7 @@ uLong ZEXPORT crc32_combine64(crc1, crc2, len2)
- #ifdef DYNAMIC_CRC_TABLE
- once(&made, make_crc_table);
- #endif /* DYNAMIC_CRC_TABLE */
-- return multmodp(x2nmodp(len2, 3), crc1) ^ crc2;
-+ return multmodp(x2nmodp(len2, 3), crc1) ^ (crc2 & 0xffffffff);
- }
-
- /* ========================================================================= */
-@@ -1112,5 +1112,5 @@ uLong crc32_combine_op(crc1, crc2, op)
- uLong crc2;
- uLong op;
- {
-- return multmodp(op, crc1) ^ crc2;
-+ return multmodp(op, crc1) ^ (crc2 & 0xffffffff);
- }