summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2018-12-01 18:29:38 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2018-12-01 18:29:38 +0000
commit3dc61fbde70d4f1b62d956f66d37d514668663dd (patch)
tree57cc0b33882f1ad55aeadc0e708dc170ec9e11b4
parentd121ff38fff65ed7267690946402a1e59692ad2b (diff)
parent7aee7fba78b839e52d01d5234a9bc1e5499c2a89 (diff)
downloadpackages-3dc61fbde70d4f1b62d956f66d37d514668663dd.tar.gz
packages-3dc61fbde70d4f1b62d956f66d37d514668663dd.tar.bz2
packages-3dc61fbde70d4f1b62d956f66d37d514668663dd.tar.xz
packages-3dc61fbde70d4f1b62d956f66d37d514668663dd.zip
Merge branch 'add-apcu' into 'master'
user/php7-apcu: new package APCu brings a userspace memory cache to PHP programs. It's one of the three major cache packages that Nextcloud supports (along with memcached and Redis), and is also the easiest to configure. See merge request !123
-rw-r--r--user/php7-apcu/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/user/php7-apcu/APKBUILD b/user/php7-apcu/APKBUILD
new file mode 100644
index 000000000..aa487a4e6
--- /dev/null
+++ b/user/php7-apcu/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: zlg <zlg+adelie@zlg.space>
+# Maintainer:
+pkgname=php7-apcu
+_pkgname=${pkgname#php7-}
+pkgver=5.1.14
+pkgrel=0
+pkgdesc="Userland cache for PHP"
+url="https://github.com/krakjoe/apcu"
+arch="all"
+license="PHP-3.01"
+depends="php7"
+makedepends="php7-dev"
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/krakjoe/${_pkgname}/archive/v${pkgver}.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ phpize
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --enable-apcu
+ make
+}
+
+check() {
+ cd "$builddir"
+ # The tests have a prompt at the end for sending stats
+ make NO_INTERACTION=1 test
+}
+
+package() {
+ cd "$builddir"
+ # It didn't listen to DESTDIR
+ make INSTALL_ROOT="$pkgdir" install
+}
+
+sha512sums="fe39d46d2905732296a70b79ab0977909c9ff7cb571118f35831e75a9a018edf909992954e39f79cc4710f9fdec93e6067068afea02304345e4ff6babc65a7d0 php7-apcu-5.1.14.tar.gz"