summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Bergren <adelie@bdragon.rtk0.net>2018-08-18 02:04:04 +0000
committerBrandon Bergren <adelie@bdragon.rtk0.net>2018-08-18 02:10:34 +0000
commitb384b8162f107febcb1a279d2836b51b1acabeda (patch)
tree7a5f311df8554f7eacec12fbd8c9a81e9fcb45aa
parent624b698e46800cd6c1aa44dbc3ae0a6f0f71095d (diff)
downloadpackages-b384b8162f107febcb1a279d2836b51b1acabeda.tar.gz
packages-b384b8162f107febcb1a279d2836b51b1acabeda.tar.bz2
packages-b384b8162f107febcb1a279d2836b51b1acabeda.tar.xz
packages-b384b8162f107febcb1a279d2836b51b1acabeda.zip
Use the same linker script trick as used on the .so files on the .a files to redirect to the wide version of the static libraries.
Fixes an issue with `llvm-config --system-libs --link-static` pulling in curses instead of tinfo.
-rw-r--r--system/ncurses/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/system/ncurses/APKBUILD b/system/ncurses/APKBUILD
index eb57797a1..eaa4508bf 100644
--- a/system/ncurses/APKBUILD
+++ b/system/ncurses/APKBUILD
@@ -2,7 +2,7 @@
pkgname=ncurses
pkgver=6.1_p20180609
_ver=${pkgver%_p*}-${pkgver#*_p}
-pkgrel=4
+pkgrel=5
pkgdesc="Console display library"
url="https://invisible-island.net/ncurses/ncurses.html"
arch="all"
@@ -66,9 +66,10 @@ package() {
dev() {
default_dev
- # force link against *w.so
+ # force link against *w.so and *w.a
for lib in ncurses ncurses++ form panel menu tinfo; do
echo "INPUT(-l${lib}w)" > "$subpkgdir"/lib/lib${lib}.so
+ echo "INPUT(-l${lib}w)" > "$subpkgdir"/lib/lib${lib}.a
ln -s ${lib}w.pc "$subpkgdir"/usr/lib/pkgconfig/${lib}.pc
done
# link curses -> ncurses