summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2018-09-12 23:18:26 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2018-09-12 23:18:26 +0000
commit02a2bd307242bf8520133412db3fdcc8d1062943 (patch)
treeadbdf481177bb8a29e76fa1a941ebe3216ace0fe
parent0109a488924c257ee7afa60c11ae79c052c8b13e (diff)
parent33f52096e9c8764c10be57ff860ad192a7ad7295 (diff)
downloadpackages-02a2bd307242bf8520133412db3fdcc8d1062943.tar.gz
packages-02a2bd307242bf8520133412db3fdcc8d1062943.tar.bz2
packages-02a2bd307242bf8520133412db3fdcc8d1062943.tar.xz
packages-02a2bd307242bf8520133412db3fdcc8d1062943.zip
Merge branch 'ethtool' into 'master'
user/ethtool: new package See merge request !55
-rw-r--r--user/ethtool/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/user/ethtool/APKBUILD b/user/ethtool/APKBUILD
new file mode 100644
index 000000000..8d4823e3d
--- /dev/null
+++ b/user/ethtool/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=ethtool
+pkgver=4.18
+pkgrel=0
+pkgdesc="Utility for controlling network drivers and hardware"
+url="https://mirrors.edge.kernel.org/pub/software/network/ethtool/"
+arch="all"
+license="GPL-2.0-only AND GPL-2.0+"
+makedepends="linux-headers"
+subpackages="$pkgname-doc"
+source="https://www.kernel.org/pub/software/network/ethtool/$pkgname-$pkgver.tar.xz"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="e77f9967be4634955640d9dccbc539455d333bcbad61326617dffea32cfd13a72a7dda4087caf6fff41b49c9ce476435cc1310e131705d0ad402685e10b4fb0e ethtool-4.18.tar.xz"