summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2016-10-29 07:07:21 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2016-10-29 07:07:21 -0500
commit95bc4e36e9b1247a847014ce51f0a9f1cc3cd195 (patch)
tree84480e1f652cb610c09f3b34081f26b8b8ebb780
parent1b21930673fe628a3a51cfdb201bd91649f14441 (diff)
downloadpackages-95bc4e36e9b1247a847014ce51f0a9f1cc3cd195.tar.gz
packages-95bc4e36e9b1247a847014ce51f0a9f1cc3cd195.tar.bz2
packages-95bc4e36e9b1247a847014ce51f0a9f1cc3cd195.tar.xz
packages-95bc4e36e9b1247a847014ce51f0a9f1cc3cd195.zip
games-misc/openmsx: Python 3 patch
-rw-r--r--games-misc/openmsx/Manifest1
-rw-r--r--games-misc/openmsx/files/openmsx-0.3.1-python3.patch217
-rw-r--r--games-misc/openmsx/openmsx-0.3.1-r3.ebuild38
-rw-r--r--profiles/categories1
4 files changed, 257 insertions, 0 deletions
diff --git a/games-misc/openmsx/Manifest b/games-misc/openmsx/Manifest
new file mode 100644
index 000000000..303c232b8
--- /dev/null
+++ b/games-misc/openmsx/Manifest
@@ -0,0 +1 @@
+DIST openmsx-0.3.1-source.tar.gz 152798 SHA256 ecb827353b727f3bd41e57d101a9c5f0438e961fee0bd3cc0e5b3ba34ec2535b SHA512 e455f99f32d1daa77157def4f109dd1456169ae2b527290035b6a52f591c13fb7464fd221e00eb46bf03f51e8d0101de08a9e47cebe2430ad05a840ab235973e WHIRLPOOL c5c04e0c5681206482a4baa4526fbcc6289e519187950639cbc3ec85f5f8744ecd5449855027b96f6178252ac38c88ba1245f39ea8d881e05fb92191b5677d9d
diff --git a/games-misc/openmsx/files/openmsx-0.3.1-python3.patch b/games-misc/openmsx/files/openmsx-0.3.1-python3.patch
new file mode 100644
index 000000000..bdba256ae
--- /dev/null
+++ b/games-misc/openmsx/files/openmsx-0.3.1-python3.patch
@@ -0,0 +1,217 @@
+--- openmsx-0.3.1-source/scripts/authorlist.py.py2 2016-10-29 06:56:51.064250908 -0500
++++ openmsx-0.3.1-source/scripts/authorlist.py 2016-10-29 06:57:50.504033762 -0500
+@@ -19,9 +19,8 @@
+ # do some processing of the contents of
+ # the data variable
+ separate = string.split(data,";")
+- print '%-30s %s' % (separate[1]+":", separate[2])
++ print('%-30s %s' % (separate[1]+":", separate[2]))
+ # end of data processing command group
+- # sys.stdout.write(res)
+ else:
+ sys.stdout.flush()
+ break
+--- openmsx-0.3.1-source/scripts/md5list.py.py2 2016-10-29 06:56:51.064250908 -0500
++++ openmsx-0.3.1-source/scripts/md5list.py 2016-10-29 06:58:34.880538273 -0500
+@@ -18,25 +18,25 @@
+ while 1:
+ data = sys.stdin.readline()
+ if data != '':
+- # leave out all comment lines (lines starting with '#')
+- comment_pos = string.find(data,'#')
+- if comment_pos == 0:
+- continue
+- # separate the single entries by ';'
+- separate = string.split(data,";")
+- if len(separate) != 4:
+- continue
+- systemtype = (os.uname())[0]
+- if systemtype == 'Linux':
+- md5call = ["md5sum"]
+- elif systemtype == 'Darwin':
+- md5call = ["md5", "-r"]
+- else:
+- md5call = ["md5sum"]
+- md5call = md5call + ["src/"+string.strip(separate[1])]
+- md5sum = subprocess.Popen(md5call, stdout=subprocess.PIPE).communicate()[0]
+- md5sum = string.split(md5sum)
+- res = "%-32s = %s\n" % (separate[1], md5sum[0])
++ # leave out all comment lines (lines starting with '#')
++ comment_pos = string.find(data,'#')
++ if comment_pos == 0:
++ continue
++ # separate the single entries by ';'
++ separate = string.split(data,";")
++ if len(separate) != 4:
++ continue
++ systemtype = (os.uname())[0]
++ if systemtype == 'Linux':
++ md5call = ["md5sum"]
++ elif systemtype == 'Darwin':
++ md5call = ["md5", "-r"]
++ else:
++ md5call = ["md5sum"]
++ md5call = md5call + ["src/"+string.strip(separate[1])]
++ md5sum = subprocess.Popen(md5call, stdout=subprocess.PIPE).communicate()[0]
++ md5sum = string.split(md5sum)
++ res = "%-32s = %s\n" % (separate[1], md5sum[0])
+ sys.stdout.write(res)
+ else:
+ sys.stdout.flush()
+--- openmsx-0.3.1-source/scripts/midifiles.py.py2 2016-10-29 06:56:51.064250908 -0500
++++ openmsx-0.3.1-source/scripts/midifiles.py 2016-10-29 06:58:46.643828615 -0500
+@@ -17,16 +17,16 @@
+ while 1:
+ data = sys.stdin.readline()
+ if data != '':
+- # leave out all comment lines (lines starting with '#')
+- comment_pos = string.find(data,'#')
+- if comment_pos == 0:
+- continue
+- # separate the single entries by ';'
++ # leave out all comment lines (lines starting with '#')
++ comment_pos = string.find(data,'#')
++ if comment_pos == 0:
++ continue
++ # separate the single entries by ';'
+ separate = string.split(data,";")
+- if len(separate) != 4:
+- continue
+- res = res + " src/" + string.strip(separate[1])
++ if len(separate) != 4:
++ continue
++ res = res + " src/" + string.strip(separate[1])
+ else:
+- sys.stdout.write(res)
++ sys.stdout.write(res)
+ sys.stdout.flush()
+ break
+--- openmsx-0.3.1-source/scripts/namelist.py.py2 2016-10-29 06:56:51.067584229 -0500
++++ openmsx-0.3.1-source/scripts/namelist.py 2016-10-29 06:59:37.260310273 -0500
+@@ -16,21 +16,21 @@
+ while 1:
+ data = sys.stdin.readline()
+ if data != '':
+- # leave out all comment lines (lines starting with '#')
+- comment_pos = string.find(data,'#')
+- if comment_pos == 0:
+- continue
+- # separate the single entries by ';'
++ # leave out all comment lines (lines starting with '#')
++ comment_pos = string.find(data,'#')
++ if comment_pos == 0:
++ continue
++ # separate the single entries by ';'
+ separate = string.split(data,";")
+- if len(separate) != 4:
+- continue
+- res = "%-32s = %s\n" % (separate[1], string.strip(separate[3]))
++ if len(separate) != 4:
++ continue
++ res = "%-32s = %s\n" % (separate[1], string.strip(separate[3]))
+ sys.stdout.write(res)
+ else:
+ sys.stdout.flush()
+ break
+
+ def authorlist(mystr):
+- separate = string.split()
+- for str in separate:
+- print string.strip(str)
+\ No newline at end of file
++ separate = string.split()
++ for str_ in separate:
++ print(string.strip(str_))
+--- openmsx-0.3.1-source/scripts/playlist.py.py2 2016-10-29 06:56:51.067584229 -0500
++++ openmsx-0.3.1-source/scripts/playlist.py 2016-10-29 07:00:52.353369055 -0500
+@@ -16,25 +16,25 @@
+ while 1:
+ data = sys.stdin.readline()
+ if data != '':
+- # leave out all comment lines (lines starting with '#')
+- comment_pos = string.find(data,'#')
+- if comment_pos == 0:
+- continue
+- # separate the single entries by ';'
++ # leave out all comment lines (lines starting with '#')
++ comment_pos = string.find(data,'#')
++ if comment_pos == 0:
++ continue
++ # separate the single entries by ';'
+ separate = string.split(data,";")
+- res = ""
+- # leave out all lines which don't have the proper number of elements
+- if len(separate) >= 1:
+- res = string.strip(separate[0]) + " = "
+- if len(separate) == 4:
+- res = res + separate[1]
+- res = res + "\n"
++ res = ""
++ # leave out all lines which don't have the proper number of elements
++ if len(separate) >= 1:
++ res = string.strip(separate[0]) + " = "
++ if len(separate) == 4:
++ res = res + separate[1]
++ res = res + "\n"
+ sys.stdout.write(res)
+ else:
+ sys.stdout.flush()
+ break
+
+ def authorlist(mystr):
+- separate = string.split()
+- for str in separate:
+- print string.strip(str)
+\ No newline at end of file
++ separate = string.split()
++ for str_ in separate:
++ print(string.strip(str_))
+--- openmsx-0.3.1-source/scripts/sanitize_list.py.py2 2016-10-29 06:56:51.067584229 -0500
++++ openmsx-0.3.1-source/scripts/sanitize_list.py 2016-10-29 07:01:32.659888316 -0500
+@@ -16,28 +16,28 @@
+ while 1:
+ data = sys.stdin.readline()
+ if data != '':
+- # leave out all comment lines (lines starting with '#')
+- comment_pos = string.find(data,'#')
+- if comment_pos == 0:
+- continue
+- # separate the single entries by ';'
++ # leave out all comment lines (lines starting with '#')
++ comment_pos = string.find(data,'#')
++ if comment_pos == 0:
++ continue
++ # separate the single entries by ';'
+ separate = string.split(data,";")
+- if len(separate) != 4:
+- continue
+- res = ""
+- for str in separate:
+- if res != '':
+- res = res + ";" + string.strip(str)
+- else:
+- res = string.strip(str)
++ if len(separate) != 4:
++ continue
++ res = ""
++ for str in separate:
++ if res != '':
++ res = res + ";" + string.strip(str)
++ else:
++ res = string.strip(str)
+ # end of data processing command group
+- res = res + "\n"
++ res = res + "\n"
+ sys.stdout.write(res)
+ else:
+ sys.stdout.flush()
+ break
+
+ def authorlist(mystr):
+- separate = string.split()
+- for str in separate:
+- print string.strip(str)
+\ No newline at end of file
++ separate = string.split()
++ for str_ in separate:
++ print(string.strip(str_))
diff --git a/games-misc/openmsx/openmsx-0.3.1-r3.ebuild b/games-misc/openmsx/openmsx-0.3.1-r3.ebuild
new file mode 100644
index 000000000..84b28b408
--- /dev/null
+++ b/games-misc/openmsx/openmsx-0.3.1-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+inherit python-any-r1 games
+
+DESCRIPTION="An ambiguously named music replacement set for OpenTTD"
+HOMEPAGE="http://bundles.openttdcoop.org/openmsx/"
+SRC_URI="http://bundles.openttdcoop.org/openmsx/releases/${PV}/${P}-source.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ~ppc64 x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+
+PATCHES=( ${FILESDIR}/${P}-python3.patch )
+
+S=${WORKDIR}/${P}-source
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_compile() {
+ emake _V= bundle || die
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/openttd/gm/${P}
+ doins ${P}/{*.mid,openmsx.obm} || die
+ dodoc ${P}/{changelog.txt,readme.txt} || die
+ prepgamesdirs
+}
diff --git a/profiles/categories b/profiles/categories
index e79efe485..1c720a580 100644
--- a/profiles/categories
+++ b/profiles/categories
@@ -1,6 +1,7 @@
app-text
dev-libs
dev-util
+games-misc
media-gfx
meta-desktop
sys-apps