summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <awilcox@wilcox-tech.com>2019-12-28 09:42:00 +0000
committerA. Wilcox <awilcox@wilcox-tech.com>2019-12-28 09:42:00 +0000
commitc25e051c138d15423a828a42fd7fbf85156a520e (patch)
tree88f95bc8b6023a799f08355774d7efaef93fd907
parentc7c0916fad338d4743257d0f05e357e9c0f1f670 (diff)
parentd3ea30be5b638892f5476c240b46880ca5379a99 (diff)
downloadpackages-c25e051c138d15423a828a42fd7fbf85156a520e.tar.gz
packages-c25e051c138d15423a828a42fd7fbf85156a520e.tar.bz2
packages-c25e051c138d15423a828a42fd7fbf85156a520e.tar.xz
packages-c25e051c138d15423a828a42fd7fbf85156a520e.zip
Merge branch 'jd/wgtools' into 'master'
user/wireguard-*: bump to 20191226 and account for repo changes See merge request adelie/packages!385
-rw-r--r--user/wireguard-module-power8-64k/APKBUILD8
-rw-r--r--user/wireguard-module-power8/APKBUILD8
-rw-r--r--user/wireguard-module/APKBUILD18
-rw-r--r--user/wireguard-tools/APKBUILD25
4 files changed, 29 insertions, 30 deletions
diff --git a/user/wireguard-module-power8-64k/APKBUILD b/user/wireguard-module-power8-64k/APKBUILD
index 6f50fd6cc..0d54026ba 100644
--- a/user/wireguard-module-power8-64k/APKBUILD
+++ b/user/wireguard-module-power8-64k/APKBUILD
@@ -3,11 +3,11 @@
# KEEP THIS IN SYNC with the other wireguard-module packages.
_kflavour="-power8-64k"
_kver="4.14.138-mc15"
-pkgver=0.0.20191012
+pkgver=0.0.20191226
pkgrel=0
_pkgname="wireguard-module$_kflavour"
pkgname="$_pkgname-$_kver"
-_pkgreal="WireGuard"
+_pkgreal="wireguard-linux-compat"
pkgdesc="Kernel module for the WireGuard VPN, built for easy-kernel"
url="https://www.wireguard.com/"
arch="ppc64"
@@ -16,7 +16,7 @@ license="GPL-2.0-only"
provides="$_pkgname=$pkgver"
depends="easy-kernel$_kflavour-modules-$_kver"
makedepends="easy-kernel$_kflavour-src-$_kver"
-source="https://git.zx2c4.com/WireGuard/snapshot/$_pkgreal-$pkgver.tar.xz"
+source="https://git.zx2c4.com/$_pkgreal/snapshot/$_pkgreal-$pkgver.tar.xz"
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
@@ -29,4 +29,4 @@ package() {
make -C src DEPMOD=true KERNELDIR="/usr/src/linux-$_kver$_kflavour" INSTALL_MOD_PATH="$pkgdir" module-install
}
-sha512sums="b15424036f26298d8511ca0d0d6a485ff0992726d61fabff8bf6dd64d0a65423bf901e5eb14d3080372017390b05d25faff89a72128932c7408f93f59165c321 WireGuard-0.0.20191012.tar.xz"
+sha512sums="7eba183128555ca5fd8b171179fe8ec7b9a67c618ad000bc9c5475ff74097e0e2c220a1f1dd82393fbde6dbbba5c1114bfd725e733a5f4acfbb23248538f6afb wireguard-linux-compat-0.0.20191226.tar.xz"
diff --git a/user/wireguard-module-power8/APKBUILD b/user/wireguard-module-power8/APKBUILD
index 24dee52f7..fe36fbbb8 100644
--- a/user/wireguard-module-power8/APKBUILD
+++ b/user/wireguard-module-power8/APKBUILD
@@ -3,11 +3,11 @@
# KEEP THIS IN SYNC with the other wireguard-module packages.
_kflavour="-power8"
_kver="4.14.138-mc15"
-pkgver=0.0.20191012
+pkgver=0.0.20191226
pkgrel=0
_pkgname="wireguard-module$_kflavour"
pkgname="$_pkgname-$_kver"
-_pkgreal="WireGuard"
+_pkgreal="wireguard-linux-compat"
pkgdesc="Kernel module for the WireGuard VPN, built for easy-kernel"
url="https://www.wireguard.com/"
arch="ppc64"
@@ -16,7 +16,7 @@ license="GPL-2.0-only"
provides="$_pkgname=$pkgver"
depends="easy-kernel$_kflavour-modules-$_kver"
makedepends="easy-kernel$_kflavour-src-$_kver"
-source="https://git.zx2c4.com/WireGuard/snapshot/$_pkgreal-$pkgver.tar.xz"
+source="https://git.zx2c4.com/$_pkgreal/snapshot/$_pkgreal-$pkgver.tar.xz"
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
@@ -29,4 +29,4 @@ package() {
make -C src DEPMOD=true KERNELDIR="/usr/src/linux-$_kver$_kflavour" INSTALL_MOD_PATH="$pkgdir" module-install
}
-sha512sums="b15424036f26298d8511ca0d0d6a485ff0992726d61fabff8bf6dd64d0a65423bf901e5eb14d3080372017390b05d25faff89a72128932c7408f93f59165c321 WireGuard-0.0.20191012.tar.xz"
+sha512sums="7eba183128555ca5fd8b171179fe8ec7b9a67c618ad000bc9c5475ff74097e0e2c220a1f1dd82393fbde6dbbba5c1114bfd725e733a5f4acfbb23248538f6afb wireguard-linux-compat-0.0.20191226.tar.xz"
diff --git a/user/wireguard-module/APKBUILD b/user/wireguard-module/APKBUILD
index 2e4a7e74f..0471f0a01 100644
--- a/user/wireguard-module/APKBUILD
+++ b/user/wireguard-module/APKBUILD
@@ -3,11 +3,11 @@
# KEEP THIS IN SYNC with the other wireguard-module packages.
_kflavour=""
_kver="4.14.138-mc15"
-pkgver=0.0.20191012
+pkgver=0.0.20191226
pkgrel=0
_pkgname="wireguard-module$_kflavour"
pkgname="$_pkgname-$_kver"
-_pkgreal="WireGuard"
+_pkgreal="wireguard-linux-compat"
pkgdesc="Kernel module for the WireGuard VPN, built for easy-kernel"
url="https://www.wireguard.com/"
arch="all"
@@ -16,7 +16,8 @@ license="GPL-2.0-only"
provides="$_pkgname=$pkgver"
depends="easy-kernel$_kflavour-modules-$_kver"
makedepends="easy-kernel$_kflavour-src-$_kver"
-source="https://git.zx2c4.com/WireGuard/snapshot/$_pkgreal-$pkgver.tar.xz"
+subpackages="wireguard-patch:_patch:noarch"
+source="https://git.zx2c4.com/$_pkgreal/snapshot/$_pkgreal-$pkgver.tar.xz"
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
@@ -29,4 +30,13 @@ package() {
make -C src DEPMOD=true KERNELDIR="/usr/src/linux-$_kver$_kflavour" INSTALL_MOD_PATH="$pkgdir" module-install
}
-sha512sums="b15424036f26298d8511ca0d0d6a485ff0992726d61fabff8bf6dd64d0a65423bf901e5eb14d3080372017390b05d25faff89a72128932c7408f93f59165c321 WireGuard-0.0.20191012.tar.xz"
+_patch() {
+ depends=""
+ pkgdesc="Kernel patch for the WireGuard VPN"
+
+ cd "$builddir"
+ mkdir -p "$subpkgdir/usr/share/wireguard"
+ kernel-tree-scripts/create-patch.sh > "$subpkgdir/usr/share/wireguard/wireguard-$pkgver.patch"
+}
+
+sha512sums="7eba183128555ca5fd8b171179fe8ec7b9a67c618ad000bc9c5475ff74097e0e2c220a1f1dd82393fbde6dbbba5c1114bfd725e733a5f4acfbb23248538f6afb wireguard-linux-compat-0.0.20191226.tar.xz"
diff --git a/user/wireguard-tools/APKBUILD b/user/wireguard-tools/APKBUILD
index 1ee00b549..21875f043 100644
--- a/user/wireguard-tools/APKBUILD
+++ b/user/wireguard-tools/APKBUILD
@@ -1,8 +1,7 @@
# Contributor: Luis Ressel <aranea@aixah.de>
# Maintainer: Luis Ressel <aranea@aixah.de>
pkgname=wireguard-tools
-_pkgreal=WireGuard
-pkgver=0.0.20191012
+pkgver=1.0.20191226
pkgrel=0
pkgdesc="Userland tools for the WireGuard VPN"
url="https://www.wireguard.com/"
@@ -11,18 +10,18 @@ options="!check" # no test suite
license="GPL-2.0-only"
depends="bash iproute2"
makedepends="libmnl-dev"
-subpackages="$pkgname-bash-completion:bashcomp:noarch $pkgname-doc wireguard-patch:_patch:noarch"
-source="https://git.zx2c4.com/WireGuard/snapshot/$_pkgreal-$pkgver.tar.xz"
-builddir="$srcdir/$_pkgreal-$pkgver"
+subpackages="$pkgname-bash-completion:bashcomp:noarch $pkgname-doc"
+source="https://git.zx2c4.com/$pkgname/snapshot/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
- make RUNSTATEDIR=/run -C src/tools
+ make RUNSTATEDIR=/run -C src
}
package() {
cd "$builddir"
- make WITH_BASHCOMPLETION=yes WITH_WGQUICK=yes DESTDIR="$pkgdir" -C src/tools install
+ make WITH_BASHCOMPLETION=yes WITH_WGQUICK=yes DESTDIR="$pkgdir" -C src install
}
bashcomp() {
@@ -33,14 +32,4 @@ bashcomp() {
mv "$pkgdir/usr/share/bash-completion" "$subpkgdir/usr/share/"
}
-_patch() {
- depends=""
- pkgdesc="Kernel patch for the WireGuard VPN"
-
- cd "$builddir"
- mkdir -p "$subpkgdir/usr/share/wireguard"
- contrib/kernel-tree/create-patch.sh > "$subpkgdir/usr/share/wireguard/wireguard-$pkgver.patch"
-
-}
-
-sha512sums="b15424036f26298d8511ca0d0d6a485ff0992726d61fabff8bf6dd64d0a65423bf901e5eb14d3080372017390b05d25faff89a72128932c7408f93f59165c321 WireGuard-0.0.20191012.tar.xz"
+sha512sums="e6b7fc34f9517efc830b751e054e811acdd7f210e8f68b5ad5a503ee0c081bcb1a65e64e82a0b66ddfea9ef3ea0ca3210d5620c278d1b17442e233be1734ef03 wireguard-tools-1.0.20191226.tar.xz"