summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2016-07-24 04:31:13 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2016-07-24 04:31:13 -0500
commit8e47d7c6398b9b6c5c2556691434b048921309fb (patch)
tree41a1d8357520f0bb28bf5512cf5b800bceb45e95
parentc434db725d470a2671927023d2363f0dcf2b3a67 (diff)
downloadpackages-8e47d7c6398b9b6c5c2556691434b048921309fb.tar.gz
packages-8e47d7c6398b9b6c5c2556691434b048921309fb.tar.bz2
packages-8e47d7c6398b9b6c5c2556691434b048921309fb.tar.xz
packages-8e47d7c6398b9b6c5c2556691434b048921309fb.zip
media-gfx/fontforge: Pinch working FontForge patch from Gentoo/musl
-rw-r--r--media-gfx/fontforge/Manifest1
-rw-r--r--media-gfx/fontforge/files/fontforge-20150430-intelligent-execinfo_h.patch33
-rw-r--r--media-gfx/fontforge/fontforge-20150612-r99.ebuild128
3 files changed, 162 insertions, 0 deletions
diff --git a/media-gfx/fontforge/Manifest b/media-gfx/fontforge/Manifest
new file mode 100644
index 000000000..bf0e90d5a
--- /dev/null
+++ b/media-gfx/fontforge/Manifest
@@ -0,0 +1 @@
+DIST fontforge-20150612.tar.gz 125037727 SHA256 0f4ec68a648f7f845d54d1e87cf5fb246a16d528b74e9e1a9b815418510022d7 SHA512 01a38bdbb55ba3b2638b55caa2f768ba691fdfa730afd843df0cf62417db5465731ed968c5ab7c026622264e20c20fdfd8ec0ceb50da71039588797fe18393b8 WHIRLPOOL 6662bc52669153ba46e562fbcb287f5bff59eeeec7fe9afcd65918f892282650ab4be4f279fe6fab95f02f36caa753900693532ece439bee114e774e0da3f855
diff --git a/media-gfx/fontforge/files/fontforge-20150430-intelligent-execinfo_h.patch b/media-gfx/fontforge/files/fontforge-20150430-intelligent-execinfo_h.patch
new file mode 100644
index 000000000..e0a44d227
--- /dev/null
+++ b/media-gfx/fontforge/files/fontforge-20150430-intelligent-execinfo_h.patch
@@ -0,0 +1,33 @@
+diff -Naur fontforge-20150430.orig/configure.ac fontforge-20150430/configure.ac
+--- fontforge-20150430.orig/configure.ac 2015-04-30 20:29:11.000000000 +0000
++++ fontforge-20150430/configure.ac 2015-08-06 07:36:50.535844085 +0000
+@@ -377,6 +377,7 @@
+ if test x"${i_do_want_iconv}" = xyes; then
+ AC_CHECK_HEADERS([iconv.h])
+ fi
++AC_CHECK_HEADERS([execinfo.h])
+ gl_INIT
+
+ #--------------------------------------------------------------------------
+diff -Naur fontforge-20150430.orig/fontforge/cvundoes.c fontforge-20150430/fontforge/cvundoes.c
+--- fontforge-20150430.orig/fontforge/cvundoes.c 2015-04-30 20:29:11.000000000 +0000
++++ fontforge-20150430/fontforge/cvundoes.c 2015-08-06 07:38:15.766082215 +0000
+@@ -24,6 +24,7 @@
+ * OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+ * ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ */
++#include "config.h"
+ #include "fontforgevw.h"
+ #include "views.h"
+ #include <math.h>
+@@ -33,8 +34,8 @@
+ #include "inc/gfile.h"
+ #include "psfont.h"
+
+-#if defined(__MINGW32__)||defined(__CYGWIN__)
+-// no backtrace on windows yet
++#ifndef HAVE_EXECINFO_H
++// no backtrace available
+ #else
+ #include <execinfo.h>
+ #endif
diff --git a/media-gfx/fontforge/fontforge-20150612-r99.ebuild b/media-gfx/fontforge/fontforge-20150612-r99.ebuild
new file mode 100644
index 000000000..276de805d
--- /dev/null
+++ b/media-gfx/fontforge/fontforge-20150612-r99.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit autotools eutils fdo-mime python-single-r1
+
+DESCRIPTION="postscript font editor and converter"
+HOMEPAGE="http://fontforge.github.io/"
+SRC_URI="https://github.com/fontforge/fontforge/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD GPL-3+"
+SLOT="0"
+KEYWORDS="arm ~mips ppc ppc64 x86 x86_64"
+IUSE="cairo truetype-debugger gif gtk jpeg png +python readline tiff svg unicode X"
+
+REQUIRED_USE="
+ cairo? ( png )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="
+ dev-libs/libltdl:0
+ dev-libs/libxml2:2=
+ >=media-libs/freetype-2.3.7:2=
+ cairo? (
+ >=x11-libs/cairo-1.6:0=
+ x11-libs/pango:0=
+ )
+ gif? ( media-libs/giflib:0= )
+ jpeg? ( virtual/jpeg:0 )
+ png? ( media-libs/libpng:0= )
+ tiff? ( media-libs/tiff:0= )
+ truetype-debugger? ( >=media-libs/freetype-2.3.8:2[fontforge,-bindist(-)] )
+ gtk? ( x11-libs/gtk+:2= )
+ python? ( ${PYTHON_DEPS} )
+ readline? ( sys-libs/readline:0= )
+ unicode? ( media-libs/libuninameslist:0= )
+ X? (
+ x11-libs/libX11:0=
+ x11-libs/libXi:0=
+ >=x11-libs/pango-1.10:0=[X]
+ )
+ !media-gfx/pfaedit
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ X? ( x11-proto/inputproto )
+"
+
+# Needs keywording on many arches.
+# zeromq? (
+# >=net-libs/czmq-2.2.0:0=
+# >=net-libs/zeromq-4.0.4:0=
+# )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+gnulib_import() {
+ (
+ func_add_hook() { :; }
+ source bootstrap.conf
+ set -- "${S}/gnulib/gnulib-tool" --libtool --import ${gnulib_modules}
+ echo "$@"
+ "$@"
+ )
+}
+
+src_prepare() {
+ # Tarball comes with broken absolute symlinks
+ # https://github.com/fontforge/fontforge/issues/2439
+ find . -lname "/*" -delete || die
+ gnulib_import || die
+ epatch "${FILESDIR}"/${PN}-20150430-intelligent-execinfo_h.patch
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ $(use_enable truetype-debugger freetype-debugger "${EPREFIX}/usr/include/freetype2/internal4fontforge")
+ $(use_enable gtk gtk2-use)
+ $(use_enable python python-extension)
+ $(use_enable python python-scripting)
+ --enable-tile-path
+ --enable-gb12345
+ $(use_with cairo)
+ $(use_with gif giflib)
+ $(use_with jpeg libjpeg)
+ $(use_with png libpng)
+ $(use_with readline libreadline)
+ --without-libspiro
+ $(use_with tiff libtiff)
+ $(use_with unicode libuninameslist)
+ #$(use_with zeromq libzmq)
+ --without-libzmq
+ $(use_with X x)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ # Build system deps are broken
+ emake -C plugins
+ emake
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}