summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2023-10-10 05:28:13 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2023-10-24 01:40:45 -0500
commitd2b9ae16a59f918dc15ae1e2da744974345d093b (patch)
tree5fca481582ea490e93e6f9b22a8ec9d1af69a853
parentceef8cc788413ca2af20688feae8715d0e35ddb0 (diff)
downloadpackages-d2b9ae16a59f918dc15ae1e2da744974345d093b.tar.gz
packages-d2b9ae16a59f918dc15ae1e2da744974345d093b.tar.bz2
packages-d2b9ae16a59f918dc15ae1e2da744974345d093b.tar.xz
packages-d2b9ae16a59f918dc15ae1e2da744974345d093b.zip
user/adelie-lxqt-theme: New package
Defines a base LXQt theme that is functional and appealing.
-rw-r--r--user/adelie-lxqt-theme/APKBUILD28
-rw-r--r--user/adelie-lxqt-theme/lxqt-desktop.conf20
-rw-r--r--user/adelie-lxqt-theme/lxqt-qt5ct.conf19
-rw-r--r--user/adelie-lxqt-theme/lxqt-session.conf2
4 files changed, 69 insertions, 0 deletions
diff --git a/user/adelie-lxqt-theme/APKBUILD b/user/adelie-lxqt-theme/APKBUILD
new file mode 100644
index 000000000..69cc43781
--- /dev/null
+++ b/user/adelie-lxqt-theme/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: A. Wilcox <awilfox@adelielinux.org>
+# Maintainer: A. Wilcox <awilfox@adelielinux.org>
+pkgname=adelie-lxqt-theme
+pkgver=1.0
+pkgrel=0
+pkgdesc="The Adélie Linux official LXQt theme"
+url="https://adelielinux.org/"
+arch="noarch"
+options="!check" # No test suite.
+license="NCSA"
+depends="adelie-fonts adelie-wallpapers papirus-icons"
+makedepends=""
+subpackages=""
+source="lxqt-session.conf
+ lxqt-desktop.conf
+ lxqt-qt5ct.conf
+ "
+builddir="$srcdir/"
+
+package() {
+ install -D -m644 lxqt-desktop.conf "$pkgdir"/etc/xdg/pcmanfm-qt/lxqt/settings.conf
+ install -D -m644 lxqt-qt5ct.conf "$pkgdir"/etc/xdg/qt5ct/qt5ct.conf
+ install -D -m644 lxqt-session.conf "$pkgdir"/etc/xdg/lxqt/session.conf
+}
+
+sha512sums="1e3bc3c06ae7d5251f24bad11f305947d43f2fcf7f4813f7d07ed98f44a0a12c6da8c9068044ea92fa4b704e0a7987a4369a4a80f327a1b67ed67376c35877e8 lxqt-session.conf
+9f6f3993e2d4699f6ce32387701bf4c458c92aba3b90c61fee4c17c5f8a8d70f42fa309c4342ee442671585d0a57027c944e61e166a3ac872e341dfd6ff1a952 lxqt-desktop.conf
+79db5e0e6fdeabc5e82e843f0199c5e9102b983097a9f8c007bfe2624b85980fc713da0603833af20c00d88c889972e5bfb78b064af32a09b459328065304aac lxqt-qt5ct.conf"
diff --git a/user/adelie-lxqt-theme/lxqt-desktop.conf b/user/adelie-lxqt-theme/lxqt-desktop.conf
new file mode 100644
index 000000000..0440f969f
--- /dev/null
+++ b/user/adelie-lxqt-theme/lxqt-desktop.conf
@@ -0,0 +1,20 @@
+[Behavior]
+ConfirmDelete=true
+ConfirmTrash=false
+CtrlRightClick=true
+SingleClick=false
+UseTrash=true
+
+[Desktop]
+AllSticky=false
+BgColor=#000000
+DesktopIconSize=48
+DesktopShortcuts=Home, Trash, Computer
+FgColor=#ffffff
+Font="Liberation Sans,10,-1,5,50,0,0,0,0,0"
+HideItems=false
+PerScreenWallpaper=false
+ShadowColor=#000000
+TransformWallpaper=false
+Wallpaper=/usr/share/wallpapers/Sunset/contents/images/1920x1200.jpg
+WallpaperMode=zoom
diff --git a/user/adelie-lxqt-theme/lxqt-qt5ct.conf b/user/adelie-lxqt-theme/lxqt-qt5ct.conf
new file mode 100644
index 000000000..023519e76
--- /dev/null
+++ b/user/adelie-lxqt-theme/lxqt-qt5ct.conf
@@ -0,0 +1,19 @@
+[Appearance]
+icon_theme=Papirus
+style=Fusion
+
+[Fonts]
+fixed=@Variant(\0\0\0@\0\0\0\x1e\0L\0i\0\x62\0\x65\0r\0\x61\0t\0i\0o\0n\0 \0M\0o\0n\0o@$\0\0\0\0\0\0\xff\xff\xff\xff\x5\x1\0\x32\x10)
+general=@Variant(\0\0\0@\0\0\0\x1e\0L\0i\0\x62\0\x65\0r\0\x61\0t\0i\0o\0n\0 \0S\0\x61\0n\0s@$\0\0\0\0\0\0\xff\xff\xff\xff\x5\x1\0\x32\x10)
+
+[Interface]
+activate_item_on_single_click=1
+buttonbox_layout=0
+cursor_flash_time=1000
+dialog_buttons_have_icons=1
+double_click_interval=400
+menus_have_icons=true
+show_shortcuts_in_context_menus=true
+toolbutton_style=4
+underline_shortcut=1
+wheel_scroll_lines=3
diff --git a/user/adelie-lxqt-theme/lxqt-session.conf b/user/adelie-lxqt-theme/lxqt-session.conf
new file mode 100644
index 000000000..09518fc2d
--- /dev/null
+++ b/user/adelie-lxqt-theme/lxqt-session.conf
@@ -0,0 +1,2 @@
+[General]
+window_manager=openbox