summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSíle Ekaterin Liszka <sheila@vulpine.house>2023-11-26 05:49:39 -0800
committerA. Wilcox <awilcox@wilcox-tech.com>2023-11-27 09:59:05 +0000
commit0f75de74e7cb642a4b8130ec7d833048f977167e (patch)
treefb355827a40dbf4c0a503278eddd7311e4511757
parent81d3b01f349be1349b49328c572eaa3121a85b70 (diff)
downloadpackages-0f75de74e7cb642a4b8130ec7d833048f977167e.tar.gz
packages-0f75de74e7cb642a4b8130ec7d833048f977167e.tar.bz2
packages-0f75de74e7cb642a4b8130ec7d833048f977167e.tar.xz
packages-0f75de74e7cb642a4b8130ec7d833048f977167e.zip
user/lxqt-runner: upgrade to 1.4.0
The patch accompanying this upgrade should be removed when kwindowsystem is bumped.
-rw-r--r--user/lxqt-runner/APKBUILD10
-rw-r--r--user/lxqt-runner/revert-kwindowsystem-bump.patch92
2 files changed, 98 insertions, 4 deletions
diff --git a/user/lxqt-runner/APKBUILD b/user/lxqt-runner/APKBUILD
index 65ea00bd1..8a98051f8 100644
--- a/user/lxqt-runner/APKBUILD
+++ b/user/lxqt-runner/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
pkgname=lxqt-runner
-pkgver=1.3.0
+pkgver=1.4.0
_lxqt=0.13.0
pkgrel=0
pkgdesc="Qt-based application launcher for LXQt"
@@ -11,11 +11,12 @@ options="!check" # No test suite.
license="LGPL-2.1+"
depends=""
makedepends="cmake extra-cmake-modules lxqt-build-tools>=$_lxqt
- liblxqt-dev>=${pkgver%.*}.0 lxqt-globalkeys-dev>=${pkgver%.*}.0
+ liblxqt-dev>=${pkgver%.*} lxqt-globalkeys-dev>=${pkgver%.*}
muparser-dev kwindowsystem-dev menu-cache-dev qt5-qttools-dev
qt5-qtsvg-dev"
subpackages="$pkgname-doc"
-source="https://github.com/lxqt/lxqt-runner/releases/download/$pkgver/lxqt-runner-$pkgver.tar.xz"
+source="https://github.com/lxqt/lxqt-runner/releases/download/$pkgver/lxqt-runner-$pkgver.tar.xz
+ revert-kwindowsystem-bump.patch"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
@@ -40,4 +41,5 @@ package() {
make DESTDIR="$pkgdir" -C build install
}
-sha512sums="79351e4cebb14ce6578197dc4d4ec3ee3b5be3d3832da778b075c5e2da38dcb518113c8076a4488570e68f51cedc5a3fe4855e296e813aa2b848a386ddcd6fbc lxqt-runner-1.3.0.tar.xz"
+sha512sums="53ead3b6cd45cbf57a01c06861a97f20ddab9f3a5f3a90b3b9c3e6c3b67344feec99e11e14a90a0d0a6beb7e0cf74e092b5664d5f8ec32f827893623e104ee12 lxqt-runner-1.4.0.tar.xz
+fe7d33dbdcb4500391c586bfbd43ab3e4dc660810a482fa38dcd6142b8f50df8f3ab0b53e7c71eeb09ecdc48056d490347cf68a62d01de809d5899f6152d1ca7 revert-kwindowsystem-bump.patch"
diff --git a/user/lxqt-runner/revert-kwindowsystem-bump.patch b/user/lxqt-runner/revert-kwindowsystem-bump.patch
new file mode 100644
index 000000000..a640b193a
--- /dev/null
+++ b/user/lxqt-runner/revert-kwindowsystem-bump.patch
@@ -0,0 +1,92 @@
+diff '--color=auto' -Nurd lxqt-runner-1.4.0/CMakeLists.txt lxqt-runner-1.4.0.new/CMakeLists.txt
+--- lxqt-runner-1.4.0/CMakeLists.txt 2023-11-05 04:08:33.000000000 -0800
++++ lxqt-runner-1.4.0.new/CMakeLists.txt 2023-11-26 05:46:06.721141501 -0800
+@@ -25,7 +25,7 @@
+ )
+
+ # Minimum Versions
+-set(KF5_MINIMUM_VERSION "5.101.0")
++set(KF5_MINIMUM_VERSION "5.36.0")
+ set(LIBMENUCACHE_MINIMUM_VERSION "1.1.0")
+ set(LXQT_MINIMUM_VERSION "1.4.0")
+ set(LXQT_GLOBALKEYS_MINIMUM_VERSION "1.4.0")
+diff '--color=auto' -Nurd lxqt-runner-1.4.0/dialog.cpp lxqt-runner-1.4.0.new/dialog.cpp
+--- lxqt-runner-1.4.0/dialog.cpp 2023-11-05 04:08:33.000000000 -0800
++++ lxqt-runner-1.4.0.new/dialog.cpp 2023-11-26 05:46:44.460840536 -0800
+@@ -55,7 +55,6 @@
+ #include <QScrollBar>
+
+ #include <KWindowSystem/KWindowSystem>
+-#include <KWindowSystem/KX11Extras>
+
+ #define DEFAULT_SHORTCUT "Alt+F2"
+
+@@ -201,8 +200,8 @@
+ ************************************************/
+ void Dialog::showEvent(QShowEvent *event)
+ {
+- connect(KX11Extras::self(), &KX11Extras::activeWindowChanged, this, &Dialog::onActiveWindowChanged);
+- connect(KX11Extras::self(), &KX11Extras::currentDesktopChanged, this, &Dialog::onCurrentDesktopChanged);
++ connect(KWindowSystem::self(), &KWindowSystem::activeWindowChanged, this, &Dialog::onActiveWindowChanged);
++ connect(KWindowSystem::self(), &KWindowSystem::currentDesktopChanged, this, &Dialog::onCurrentDesktopChanged);
+ return QDialog::showEvent(event);
+ }
+
+@@ -213,8 +212,8 @@
+ void Dialog::hideEvent(QHideEvent *event)
+ {
+ QDialog::hideEvent(event);
+- disconnect(KX11Extras::self(), &KX11Extras::currentDesktopChanged, this, &Dialog::onCurrentDesktopChanged);
+- disconnect(KX11Extras::self(), &KX11Extras::activeWindowChanged, this, &Dialog::onActiveWindowChanged);
++ disconnect(KWindowSystem::self(), &KWindowSystem::currentDesktopChanged, this, &Dialog::onCurrentDesktopChanged);
++ disconnect(KWindowSystem::self(), &KWindowSystem::activeWindowChanged, this, &Dialog::onActiveWindowChanged);
+ }
+
+
+@@ -349,7 +348,7 @@
+ {
+ // Using KWindowSystem to detect the active window since
+ // QWidget::isActiveWindow is not working reliably.
+- if (isVisible() && (KX11Extras::activeWindow() == winId()))
++ if (isVisible() && (KWindowSystem::activeWindow() == winId()))
+ {
+ hide();
+ }
+@@ -357,7 +356,7 @@
+ {
+ realign();
+ show();
+- KX11Extras::forceActiveWindow(winId());
++ KWindowSystem::forceActiveWindow(winId());
+ ui->commandEd->setFocus();
+ ui->commandEd->selectAll();
+ }
+@@ -378,7 +377,7 @@
+ screenNumber = screen ? screens.indexOf(screen) : 0;
+ }
+
+- desktop = screens.at(screenNumber)->availableGeometry().intersected(KX11Extras::workArea(screenNumber));
++ desktop = screens.at(screenNumber)->availableGeometry().intersected(KWindowSystem::workArea(screenNumber));
+
+ QRect rect = this->geometry();
+ rect.moveCenter(desktop.center());
+@@ -452,7 +451,7 @@
+ if (mDesktopChanged)
+ {
+ mDesktopChanged = false;
+- KX11Extras::forceActiveWindow(winId());
++ KWindowSystem::forceActiveWindow(winId());
+ } else
+ {
+ hide();
+@@ -468,8 +467,8 @@
+ {
+ if (isVisible())
+ {
+- KX11Extras::setOnDesktop(winId(), screen);
+- KX11Extras::forceActiveWindow(winId());
++ KWindowSystem::setOnDesktop(winId(), screen);
++ KWindowSystem::forceActiveWindow(winId());
+ //Note: workaround for changing desktop while runner is shown
+ // The KWindowSystem::forceActiveWindow may fail to correctly activate runner if there
+ // are any other windows on the new desktop (probably because of the sequence while WM