summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSíle Ekaterin Liszka <sheila@vulpine.house>2023-11-26 02:53:54 -0800
committerA. Wilcox <awilcox@wilcox-tech.com>2023-11-27 09:59:05 +0000
commit54b8af5ec8302123efb8c8dffdc76c621b6d650a (patch)
tree02d9a6ef13e20b25d838704ff48b84f3426e8edd
parent005dea5cbaf4e342439dd7fee001271377cbf552 (diff)
downloadpackages-54b8af5ec8302123efb8c8dffdc76c621b6d650a.tar.gz
packages-54b8af5ec8302123efb8c8dffdc76c621b6d650a.tar.bz2
packages-54b8af5ec8302123efb8c8dffdc76c621b6d650a.tar.xz
packages-54b8af5ec8302123efb8c8dffdc76c621b6d650a.zip
user/lxqt-config: upgrade to 1.4.0
The patch accompanying this upgrade should be removed when kscreen is bumped.
-rw-r--r--user/lxqt-config/APKBUILD12
-rw-r--r--user/lxqt-config/revert-kscren-bump.patch57
2 files changed, 64 insertions, 5 deletions
diff --git a/user/lxqt-config/APKBUILD b/user/lxqt-config/APKBUILD
index f85ea331f..3b690abea 100644
--- a/user/lxqt-config/APKBUILD
+++ b/user/lxqt-config/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
pkgname=lxqt-config
-pkgver=1.3.0
+pkgver=1.4.0
_lxqt=0.13.0
pkgrel=0
pkgdesc="Collection of tools for configuring LXQt and the underlying system"
@@ -9,13 +9,14 @@ url="https://lxqt.github.io/"
arch="all"
options="!check" # No test suite.
license="LGPL-2.1+"
-depends=""
+depends="lxqt-menu-data"
makedepends="cmake extra-cmake-modules qt5-qtsvg-dev qt5-qttools-dev
- liblxqt-dev>=${pkgver%.*}.0 lxqt-build-tools>=$_lxqt
+ liblxqt-dev>=${pkgver%.*} lxqt-build-tools>=$_lxqt
libxcursor-dev eudev-dev kwindowsystem-dev libkscreen-dev
xf86-input-libinput-dev libxi-dev"
subpackages="$pkgname-doc"
-source="https://github.com/lxqt/lxqt-config/releases/download/$pkgver/lxqt-config-$pkgver.tar.xz"
+source="https://github.com/lxqt/lxqt-config/releases/download/$pkgver/lxqt-config-$pkgver.tar.xz
+ revert-kscren-bump.patch"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
@@ -39,4 +40,5 @@ package() {
make DESTDIR="$pkgdir" -C build install
}
-sha512sums="30610d1c90d897eb54ce5ee75a39721a7818b0164bc97dece5b74aec2032c3b0027316995d83c077352e93fd2f7ab319d1801ed5ce356b857805e855db71cd75 lxqt-config-1.3.0.tar.xz"
+sha512sums="a3e6722c3f63b3c7382ec84723e3a4d838d99b2c42ce731565f940873b275ef025b7bc1a570f165b7fce521eb77bb7b83b02e922bee251507b773c8de4f785fc lxqt-config-1.4.0.tar.xz
+6580b8254c457a75221faf52410de3f0a678f0e9cde719dbe7d899cade521d4674a9f8b1807647fa7a9e9ed90e8787883a8b5e7d15236872299a0c7a51ad6f5e revert-kscren-bump.patch"
diff --git a/user/lxqt-config/revert-kscren-bump.patch b/user/lxqt-config/revert-kscren-bump.patch
new file mode 100644
index 000000000..bb9461b72
--- /dev/null
+++ b/user/lxqt-config/revert-kscren-bump.patch
@@ -0,0 +1,57 @@
+diff '--color=auto' -Nurd lxqt-config-1.4.0/CMakeLists.txt lxqt-config-1.4.0.new/CMakeLists.txt
+--- lxqt-config-1.4.0/CMakeLists.txt 2023-11-05 03:36:31.000000000 -0800
++++ lxqt-config-1.4.0.new/CMakeLists.txt 2023-11-26 02:44:43.889325759 -0800
+@@ -26,7 +26,7 @@
+ set(CMAKE_AUTORCC ON)
+
+ set(KF5_MINIMUM_VERSION "5.36.0")
+-set(KF5SCREEN_MINIMUM_VERSION "5.27.0")
++set(KF5SCREEN_MINIMUM_VERSION "5.2.0")
+ set(LXQT_MINIMUM_VERSION "1.4.0")
+ set(QT_MINIMUM_VERSION "5.15.0")
+
+diff '--color=auto' -Nurd lxqt-config-1.4.0/lxqt-config-monitor/kscreenutils.cpp lxqt-config-1.4.0.new/lxqt-config-monitor/kscreenutils.cpp
+--- lxqt-config-1.4.0/lxqt-config-monitor/kscreenutils.cpp 2023-11-05 03:36:31.000000000 -0800
++++ lxqt-config-1.4.0.new/lxqt-config-monitor/kscreenutils.cpp 2023-11-26 02:45:27.458971215 -0800
+@@ -63,7 +63,7 @@
+ output->setPos(pos);
+ output->setEnabled(true);
+ //first left one as primary
+- output->setPriority(width == 0 ? 1 : 0);
++ output->setPrimary(width == 0);
+ KScreen::ModePtr mode(output->currentMode());
+ //if (!mode)
+ {
+diff '--color=auto' -Nurd lxqt-config-1.4.0/lxqt-config-monitor/loadsettings.cpp lxqt-config-1.4.0.new/lxqt-config-monitor/loadsettings.cpp
+--- lxqt-config-1.4.0/lxqt-config-monitor/loadsettings.cpp 2023-11-05 03:36:31.000000000 -0800
++++ lxqt-config-1.4.0.new/lxqt-config-monitor/loadsettings.cpp 2023-11-26 02:46:05.328663054 -0800
+@@ -133,7 +133,7 @@
+ if( !output->isConnected() )
+ continue;
+ output->setEnabled( monitor.enabled );
+- output->setPriority( monitor.primary ? 1 : 0 );
++ output->setPrimary( monitor.primary );
+ output->setPos( QPoint(monitor.xPos, monitor.yPos) );
+ output->setRotation( (KScreen::Output::Rotation)(monitor.rotation) );
+ // output->setCurrentModeId could fail. KScreen sometimes changes mode Id.
+diff '--color=auto' -Nurd lxqt-config-1.4.0/lxqt-config-monitor/monitorwidget.cpp lxqt-config-1.4.0.new/lxqt-config-monitor/monitorwidget.cpp
+--- lxqt-config-1.4.0/lxqt-config-monitor/monitorwidget.cpp 2023-11-05 03:36:31.000000000 -0800
++++ lxqt-config-1.4.0.new/lxqt-config-monitor/monitorwidget.cpp 2023-11-26 02:47:02.698196214 -0800
+@@ -138,7 +138,7 @@
+ if (config->connectedOutputs().count() == 1) {
+ setOnlyMonitor(true);
+ // There isn't always a primary output. Gross.
+- output->setPriority(1);
++ output->setPrimary(true);
+ }
+
+ ui.xPosSpinBox->setValue(output->pos().x());
+@@ -208,7 +208,7 @@
+ ui.xPosSpinBox->setVisible(idx == ExtendDisplay);
+ ui.yPosSpinBox->setVisible(idx == ExtendDisplay);
+
+- output->setPriority(idx == PrimaryDisplay ? 1 : 0);
++ output->setPrimary(idx == PrimaryDisplay);
+ if(idx == PrimaryDisplay)
+ emit primaryOutputChanged(this);
+ }