summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSíle Ekaterin Liszka <sheila@vulpine.house>2023-11-30 06:55:30 -0800
committerA. Wilcox <awilcox@wilcox-tech.com>2023-12-02 02:15:12 +0000
commitb1d513607158392550dd0305ab37d05a1fdb7489 (patch)
treecd991337c112f3d88f50eadc8e5fe0863c7aa0c0
parent84ae51e84b6fa7e4ab82f601b648a04d8621a9c8 (diff)
downloadpackages-b1d513607158392550dd0305ab37d05a1fdb7489.tar.gz
packages-b1d513607158392550dd0305ab37d05a1fdb7489.tar.bz2
packages-b1d513607158392550dd0305ab37d05a1fdb7489.tar.xz
packages-b1d513607158392550dd0305ab37d05a1fdb7489.zip
user/luarocks: upgrade to 3.9.2
Fixes: #1129
-rw-r--r--user/luarocks/APKBUILD15
-rw-r--r--user/luarocks/config.lua17
2 files changed, 26 insertions, 6 deletions
diff --git a/user/luarocks/APKBUILD b/user/luarocks/APKBUILD
index 99b8874e5..fe0a75290 100644
--- a/user/luarocks/APKBUILD
+++ b/user/luarocks/APKBUILD
@@ -1,28 +1,31 @@
# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
pkgname=luarocks
-pkgver=3.7.0
+pkgver=3.9.2
pkgrel=0
pkgdesc="Package manager for Lua software"
url="https://luarocks.org/"
arch="noarch"
options="!check" # No test suite
license="MIT"
-depends="lua5.3"
-makedepends="lua5.3-dev"
-source="https://luarocks.github.io/luarocks/releases/luarocks-$pkgver.tar.gz"
+depends="lua5.3-dev"
+makedepends=""
+source="https://luarocks.github.io/luarocks/releases/luarocks-$pkgver.tar.gz
+ config.lua"
build() {
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--lua-version=5.3 \
- --rocks-tree=/usr/share/lua/5.3
+ --rocks-tree=/usr/local
make build
}
package() {
make DESTDIR="$pkgdir" install
+ install -D -m 644 "$srcdir"/config.lua "$pkgdir"/etc/$pkgname/config.lua
}
-sha512sums="cc3c555c488da9f95a118eedb74cb9e2a38b572e172958843dabebce125524e58a13ac65e89a349deb8fef13b6de751074fc3adbb430ab55d4e4109288119153 luarocks-3.7.0.tar.gz"
+sha512sums="7e93164bdcf35338e993822931a8e59957ab69c6e23236a7a075649c2f7cd173305c4ca6e9d115fc5e282cb76c21754d7adac92b21885006e5ee3bc06a9d0059 luarocks-3.9.2.tar.gz
+5845d5643c3eeb6d4af6d919a588c5253c91e6a0b278116b4cd855437fc48ac64970fd3ef758c135bc0536ddc1aaa16b01c50e33c864f59aeef1ccced0d01d82 config.lua"
diff --git a/user/luarocks/config.lua b/user/luarocks/config.lua
new file mode 100644
index 000000000..beb6ce586
--- /dev/null
+++ b/user/luarocks/config.lua
@@ -0,0 +1,17 @@
+rocks_trees = {
+ -- User-local Lua and Lua/C modules.
+ { name = 'user',
+ root = home..'/.luarocks' },
+ -- System-wide Lua and Lua/C modules for specific Lua version installed by apk.
+ { name = 'distro-modules',
+ root = '/usr' },
+ -- System-wide Lua modules compatible with Lua 5.1-5.4 installed by apk.
+ { name = 'distro-modules-common',
+ root = '/usr',
+ lua_dir = '/usr/share/lua/common',
+ rocks_dir = '/usr/lib/luarocks/rocks-common' },
+ -- System-wide Lua and Lua/C modules installed by user.
+ { name = 'system',
+ root = '/usr/local' },
+}
+deps_mode = 'all'