summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Rees <maxcrees@me.com>2020-02-17 21:34:59 -0600
committerZach van Rijn <me@zv.io>2023-04-12 03:25:27 +0000
commitc3d17c7e1f914e7d9b07d5eccc87020042eaeabf (patch)
tree6a4165e209254de783c2eeaace738ea32778e3c4
parent3fa4f7fe62265cf49a597d708042422e338a4bec (diff)
downloadpackages-c3d17c7e1f914e7d9b07d5eccc87020042eaeabf.tar.gz
packages-c3d17c7e1f914e7d9b07d5eccc87020042eaeabf.tar.bz2
packages-c3d17c7e1f914e7d9b07d5eccc87020042eaeabf.tar.xz
packages-c3d17c7e1f914e7d9b07d5eccc87020042eaeabf.zip
user/nextcloud: bump to 16.0.8
-rw-r--r--user/nextcloud/APKBUILD60
-rw-r--r--user/nextcloud/openssl.patch32
2 files changed, 35 insertions, 57 deletions
diff --git a/user/nextcloud/APKBUILD b/user/nextcloud/APKBUILD
index 46a03ba71..f9f3aae74 100644
--- a/user/nextcloud/APKBUILD
+++ b/user/nextcloud/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Max Rees <maxcrees@me.com>
pkgname=nextcloud
-pkgver=15.0.14
+pkgver=16.0.8
pkgrel=0
pkgdesc="Self-hosted file sync and groupware server"
url="https://nextcloud.com"
@@ -37,14 +37,6 @@ depends="
!$pkgname-user_external
"
makedepends="libxml2-utils"
-provides="
- $pkgname-accessibility=$pkgver-r$pkgrel
- $pkgname-dav=$pkgver-r$pkgrel
- $pkgname-federatedfilesharing=$pkgver-r$pkgrel
- $pkgname-files=$pkgver-r$pkgrel
- $pkgname-provisioning_api=$pkgver-r$pkgrel
- $pkgname-support=$pkgver-r$pkgrel
-"
install="$pkgname.pre-install $pkgname.pre-upgrade
$pkgname-initscript.post-install"
pkgusers="nextcloud"
@@ -56,7 +48,6 @@ source="https://download.nextcloud.com/server/releases/$pkgname-$pkgver.zip
dont-update-htaccess.patch
disable-integrity-check-as-default.patch
iconv-ascii-translit-not-supported.patch
- openssl.patch
use-external-docs-if-local-not-avail.patch
$pkgname-config.php
@@ -68,9 +59,28 @@ source="https://download.nextcloud.com/server/releases/$pkgname-$pkgver.zip
"
builddir="$srcdir/$pkgname"
-# List of bundled apps to separate into subpackages. Keep it in sync!
-# Note: Don't add "files", "dav", and "provisioning_api" here, these should
-# be always installed.
+# $_bundled_apps are included in the main `nextcloud' package - it can't
+# work without them. This can be checked against core/shipped.json's
+# "alwaysEnabled" entries.
+#
+# $_apps are separated into subpackages.
+#
+# `accessibility' & `support' are still bundled for backwards compatibility.
+_bundled_apps="accessibility
+ cloud_federation_api
+ dav
+ federatedfilesharing
+ files
+ lookup_server_connector
+ oauth2
+ provisioning_api
+ support
+ twofactor_backupcodes
+ workflowengine
+"
+for _i in $_bundled_apps; do
+ provides="$provides $pkgname-$_i=$pkgver-r$pkgrel"
+done
_apps="activity
admin_audit
comments
@@ -78,6 +88,7 @@ _apps="activity
federation
files_external
files_pdfviewer
+ files_rightclick
files_sharing
files_texteditor
files_trashbin
@@ -86,19 +97,18 @@ _apps="activity
firstrunwizard
gallery
logreader
- lookup_server_connector
nextcloud_announcements
notifications
- oauth2
password_policy
+ privacy
+ recommendations
serverinfo
sharebymail
survey_client
systemtags
theming
- twofactor_backupcodes
user_ldap
- workflowengine
+ viewer
"
for _i in $_apps; do
subpackages="$subpackages $pkgname-$_i:_package_app"
@@ -208,6 +218,10 @@ _default_apps() {
if grep -q '<default_enable\s*/>' "$path/appinfo/info.xml"; then
depends="$depends $pkgname-${path##*/}"
fi
+ if ! list_has "${path##*/}" $_apps \
+ && ! list_has "${path##*/}" $_bundled_apps; then
+ warning "Maybe new app: nextcloud-${path##*/}"
+ fi
done
mkdir -p "$subpkgdir"
@@ -219,20 +233,17 @@ _package_app() {
local name="$(xmllint --xpath '//info/name/text()' "$appinfo" 2>/dev/null)"
pkgdesc="Nextcloud ${name:-$appname} app"
+ local php_deps="$(xmllint --xpath 'info/dependencies/lib/text()' \
+ "$appinfo" 2>/dev/null | sed 's/^/php7-/')"
case "$appname" in
- encryption) php_deps="php7-openssl";;
- files_external) php_deps="php7-ftp";;
+ files_external) php_deps="$php_deps php7-ftp";;
# TODO: add php7-imap, php7-smbclient
- user_ldap) php_deps="php7-ldap";;
esac
case "$appname" in
- files_sharing) app_deps="$pkgname-federatedfilesharing";;
# Announcements are delivered via the notifications pane
nextcloud_announcements) app_deps="$pkgname-notifications";;
- # workflowengine provides admin panel to manage systemtags
- systemtags) app_deps="$pkgname-workflowengine";;
esac
depends="$pkgname=$pkgver-r$pkgrel $php_deps $app_deps"
@@ -241,12 +252,11 @@ _package_app() {
mv "$pkgdir/$_appsdir/$appname" "$subpkgdir/$_appsdir/"
}
-sha512sums="d847342bdeb298efafc691b1d3f3095e24643e429639be05bda51cd84c4c9c60cd82d467328a685b02f8cd48e97ed59e4ed68f8f984a71d36a009072a10754a5 nextcloud-15.0.14.zip
+sha512sums="b53777db70e97a20a6a8bba0e2b630bff3e24dbd215a9f5679abc3ff49e210eca726020ab9f146b731fc31e0b16d2dc58c1f6db3f8b75fc0afcfd4744eb1328c nextcloud-16.0.8.zip
3336c2f534de1e380d64bb87f07dcaeb617db5b7bb9446ed845e78be917c1c87eb6f7da71a6b4382198d977e21e550b3165d0b276b07b68a0a569a383766c75d dont-chmod.patch
aef3c92497d738d6968e0f0b0d415b4953500db24ae14af41ef972665cf7eff00cb6c53dc953845fdbb389c3c965a75b8b14b9247513c05cf4130fe1cfc61731 dont-update-htaccess.patch
d2100a837fef1eeae5f706650ab4c985d9e00f61efa5526ef76c7c1f5811c3906eb6c3c13c151eff9677a0c303faab64411a5a84d6792728bc520d2c618d7d5b disable-integrity-check-as-default.patch
de1b433c2fb2582b599cb25e718e454fc4b93543a5a60eee39a03bcccf35d281594611395bdebe02319bedd9a894507eef97010ebdfca381e0f1a09df283d375 iconv-ascii-translit-not-supported.patch
-17da9bcf569524ed0006a86d510f9a7a2475372559c36730bd98fe336b13e39fcc6757b759e6dd6732b2653ba3d0631e0dc2b228238115ff1ab4af3946cfc30d openssl.patch
478f5cd7c5d30380ea619d3e8ec623217a06a09b27534266f00297545c7d276b068c5d984673eebc5676e8bac7f45112549498944ce3fa678ac8a69541d7c430 use-external-docs-if-local-not-avail.patch
4d01c89d5fd86190fb3bd6a5ca97bc623ec55d92cbf030c18c5811d711cea557485d334a6588e458eea4e0b3ad82f4defd7cb5a9d4f393ce4d5b32abf45db596 nextcloud-config.php
7388458a9e8b7afd3d3269718306410ffa59c3c23da4bef367a4d7f6d2570136fae9dd421b19c1441e7ffb15a5405e18bb5da67b1a15f9f45e8b98d3fda532ba nextcloud.logrotate
diff --git a/user/nextcloud/openssl.patch b/user/nextcloud/openssl.patch
deleted file mode 100644
index f705da0ec..000000000
--- a/user/nextcloud/openssl.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- nextcloud/lib/private/Authentication/Token/PublicKeyTokenProvider.php 2019-12-19 08:23:31.000000000 +0000
-+++ nextcloud/lib/private/Authentication/Token/PublicKeyTokenProvider.php 2020-02-18 00:55:54.210000000 +0000
-@@ -295,7 +295,15 @@ class PublicKeyTokenProvider implements
-
- // Generate new key
- $res = openssl_pkey_new($config);
-- openssl_pkey_export($res, $privateKey);
-+ if ($res === false) {
-+ $this->logOpensslError();
-+ throw new \RuntimeException('OpenSSL reported a problem');
-+ }
-+
-+ if (openssl_pkey_export($res, $privateKey, null, $config) === false) {
-+ $this->logOpensslError();
-+ throw new \RuntimeException('OpenSSL reported a problem');
-+ }
-
- // Extract the public key from $res to $pubKey
- $publicKey = openssl_pkey_get_details($res);
-@@ -343,5 +351,11 @@ class PublicKeyTokenProvider implements
- }
- }
-
--
-+ private function logOpensslError() {
-+ $errors = [];
-+ while ($error = openssl_error_string()) {
-+ $errors[] = $error;
-+ }
-+ $this->logger->critical('Something is wrong with your openssl setup: ' . implode(', ', $errors));
-+ }
- }