summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2023-04-05 22:45:28 +0000
committerZach van Rijn <me@zv.io>2023-04-05 22:45:48 +0000
commit8437b3bbced0ace205d9745f838d7d4353641b63 (patch)
tree9048b21435b6382676fd71e4a52043c07623d761
parent18f48d5d44b880a58726fb11a388a719bf668666 (diff)
downloadpackages-8437b3bbced0ace205d9745f838d7d4353641b63.tar.gz
packages-8437b3bbced0ace205d9745f838d7d4353641b63.tar.bz2
packages-8437b3bbced0ace205d9745f838d7d4353641b63.tar.xz
packages-8437b3bbced0ace205d9745f838d7d4353641b63.zip
system/libtool: add patch for unspecified grep usage. fixes #976.
Commit 5d9ffc28fc6a0d99338cac0b020e3eac486bccfc bumped grep from 3.7 to 3.10, and in 3.8 they started warning on stray backslashes, so we didn't catch this until now.
-rw-r--r--system/libtool/APKBUILD7
-rw-r--r--system/libtool/fix-test-grep-expression.patch17
2 files changed, 22 insertions, 2 deletions
diff --git a/system/libtool/APKBUILD b/system/libtool/APKBUILD
index 26f0a3fc1..90b3a0170 100644
--- a/system/libtool/APKBUILD
+++ b/system/libtool/APKBUILD
@@ -12,7 +12,9 @@ checkdepends="autoconf automake gzip"
subpackages="libltdl $pkgname-doc"
options="libtool"
source="https://ftp.gnu.org/gnu/$pkgname/${pkgname}-${pkgver}.tar.gz
- libtool-fix-cross-compile.patch"
+ libtool-fix-cross-compile.patch
+ fix-test-grep-expression.patch
+ "
build() {
./configure \
@@ -43,4 +45,5 @@ libltdl() {
}
sha512sums="27acef46d9eb67203d708b57d80b853f76fa4b9c2720ff36ec161e6cdf702249e7982214ddf60bae75511aa79bc7d92aa27e3eab7ef9c0f5c040e8e42e76a385 libtool-2.4.7.tar.gz
-aa14cadd70a633520249fa3a6a4c45b309a980380e62dd5982b3ae842c478a77401ad809297fceebd167c167b0a19f380e6a6c295bc75d1029d56d3bf262b209 libtool-fix-cross-compile.patch"
+aa14cadd70a633520249fa3a6a4c45b309a980380e62dd5982b3ae842c478a77401ad809297fceebd167c167b0a19f380e6a6c295bc75d1029d56d3bf262b209 libtool-fix-cross-compile.patch
+57d47955bd3d51c5df2d62ba4773687e9111bfc155312eaa10d84e273845e255c2e62a1ceb01e8ce35617cb702f116fc223121dbb69955f5141c0185fbf4b6b4 fix-test-grep-expression.patch"
diff --git a/system/libtool/fix-test-grep-expression.patch b/system/libtool/fix-test-grep-expression.patch
new file mode 100644
index 000000000..6a78c0b7a
--- /dev/null
+++ b/system/libtool/fix-test-grep-expression.patch
@@ -0,0 +1,17 @@
+--- a/tests/link-order.at
++++ b/tests/link-order.at
+@@ -99,12 +99,12 @@
+ case $hardcode_direct$hardcode_direct_absolute in
+ yesno)
+ AT_CHECK([if $EGREP relinking stderr; then
+- $EGREP " .*\/new\/lib/libb$shared_ext .*\/old\/lib/libcee$shared_ext" stdout
++ $EGREP " .*/new/lib/libb$shared_ext .*/old/lib/libcee$shared_ext" stdout
+ else :; fi], [0], [ignore], [], [echo "wrong link order"])
+ ;;
+ *)
+ AT_CHECK([if $EGREP relinking stderr; then
+- $EGREP " -L.*\/new\/lib -lb -L.*\/old\/lib -lcee" stdout
++ $EGREP " -L.*/new/lib -lb -L.*/old/lib -lcee" stdout
+ else :; fi], [0], [ignore], [], [echo "wrong link order"])
+ ;;
+ esac