summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSíle Ekaterin Liszka <sheila@vulpine.house>2023-11-23 04:40:53 -0800
committerSíle Ekaterin Liszka <sheila@vulpine.house>2023-11-23 04:40:53 -0800
commit0477336ffb167d7d2148774be7db09a3f9654237 (patch)
tree412df7086e4a47c9b44165b6e2c2002d8f68df2e
parentb22b93574fc69af83bdcf4a78987cde64ee300d7 (diff)
downloadpackages-0477336ffb167d7d2148774be7db09a3f9654237.tar.gz
packages-0477336ffb167d7d2148774be7db09a3f9654237.tar.bz2
packages-0477336ffb167d7d2148774be7db09a3f9654237.tar.xz
packages-0477336ffb167d7d2148774be7db09a3f9654237.zip
user/fwupd-efi: new package
-rw-r--r--user/fwupd-efi/APKBUILD39
-rw-r--r--user/fwupd-efi/licenses.txt15
2 files changed, 54 insertions, 0 deletions
diff --git a/user/fwupd-efi/APKBUILD b/user/fwupd-efi/APKBUILD
new file mode 100644
index 000000000..2bf0bcde4
--- /dev/null
+++ b/user/fwupd-efi/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
+# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
+pkgname=fwupd-efi
+pkgver=1.4
+pkgrel=0
+pkgdesc="EFI application for fwupd"
+url="https://fwupd.org"
+arch="all !ppc !ppc64"
+options="!check"
+license="LGPL-2.1+ AND (Custom OR GPL-2.0+)"
+depends=""
+makedepends="meson ninja gnu-efi py3-pefile"
+subpackages="$pkgname-dev"
+source="https://github.com/fwupd/fwupd-efi/releases/download/$pkgver/fwupd-efi-$pkgver.tar.xz
+ licenses.txt"
+
+build() {
+ meson setup \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ --wrap-mode=nofallback \
+ . output
+ meson compile -C output
+}
+
+check() {
+ meson test -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C output
+ install -Dm644 "$srcdir"/licenses.txt "$pkgdir"/usr/share/licenses/$pkgname-$pkgver.txt
+}
+
+sha512sums="c330409861a8c1e332a0d4fd49c54ef2c5bf7cdaca99d14de39b50fb35f0c490e9f7f7a4c9dd48181bd509cd358c43eb23659536aea93408c1fefb47629e4991 fwupd-efi-1.4.tar.xz
+135eed7311ba40216e1a201f9bc0bd2cb6040788ffc7b8bb0209950c1a2e3d65b179972b8c43ab5d3f1b28fd44b4e24985d5a3f886e090ed3cb61c2231c17970 licenses.txt"
diff --git a/user/fwupd-efi/licenses.txt b/user/fwupd-efi/licenses.txt
new file mode 100644
index 000000000..f7b61cdc1
--- /dev/null
+++ b/user/fwupd-efi/licenses.txt
@@ -0,0 +1,15 @@
+src/fwupd-efi-1.4/efi/crt0/crt0-efi-aarch64.S
+src/fwupd-efi-1.4/efi/crt0/crt0-efi-arm.S
+ * Copyright (C) 2014 Linaro Ltd. <ard.biesheuvel@linaro.org>
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice and this list of conditions, without modification.
+ * 2. The name of the author may not be used to endorse or promote products
+ * derived from this software without specific prior written permission.
+ *
+ * Alternatively, this software may be distributed under the terms of the
+ * GNU General Public License as published by the Free Software Foundation;
+ * either version 2 of the License, or (at your option) any later version.