summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSíle Ekaterin Liszka <sheila@vulpine.house>2023-11-08 08:52:24 -0800
committerSíle Ekaterin Liszka <sheila@vulpine.house>2023-11-08 16:33:30 -0800
commit08c9036c8a3299d8a1ed70160bf7691c99a03ffc (patch)
tree64868c53bd7279a3c7e554e822a5f04dcd708e37
parent5d6ea4fceee215b2b2f97069acb839a2c90dfdb3 (diff)
downloadpackages-08c9036c8a3299d8a1ed70160bf7691c99a03ffc.tar.gz
packages-08c9036c8a3299d8a1ed70160bf7691c99a03ffc.tar.bz2
packages-08c9036c8a3299d8a1ed70160bf7691c99a03ffc.tar.xz
packages-08c9036c8a3299d8a1ed70160bf7691c99a03ffc.zip
user/pantheon-files: new package
-rw-r--r--user/pantheon-files/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/user/pantheon-files/APKBUILD b/user/pantheon-files/APKBUILD
new file mode 100644
index 000000000..7e9ac5235
--- /dev/null
+++ b/user/pantheon-files/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
+# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
+pkgname=pantheon-files
+pkgver=6.5.2
+pkgrel=0
+pkgdesc="File manager for the Pantheon desktop environment"
+url="https://elementary.io/"
+arch="all"
+license="GPL-2.0+ AND LGPL-3.0-only AND GPL-3.0+ AND GPL-3.0-only AND GPL-2.0-only AND LGPL-2.0+ AND LGPL-2.1-only AND LGPL-3.0+"
+depends=""
+makedepends="meson ninja desktop-file-utils glib-dev gobject-introspection-dev granite-dev gtk+3.0-dev libcanberra-dev libcloudproviders-dev libgee-dev libgit2-glib-dev libhandy-dev plank-dev sqlite-dev vala-dev"
+subpackages="$pkgname-dev $pkgname-lang"
+source="pantheon-files-$pkgver.tar.gz::https://github.com/elementary/files/archive/refs/tags/$pkgver.tar.gz"
+builddir="$srcdir/files-$pkgver"
+
+build() {
+ meson setup \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ --wrap-mode=nofallback \
+ -Dsystemduserunitdir=no \
+ . output
+ meson compile -C output
+}
+
+check() {
+ meson test -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C output
+}
+
+sha512sums="bdafe8edd67a85fc03234f553c9858178300eed2fc3f11510b79fa74c563eeb1e24c044cdc5633a788de7ae0bbb0fd7d0388bd0a33bb69f309738d3706d1c203 pantheon-files-6.5.2.tar.gz"