summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSíle Ekaterin Liszka <sheila@vulpine.house>2023-11-05 13:36:55 -0800
committerSíle Ekaterin Liszka <sheila@vulpine.house>2023-11-08 16:33:29 -0800
commitc1c136f0ac3f15feaf35416c7cdbdd080774dd9c (patch)
tree899174f94d33d2e72a61959e3aabd73830c8cb4c
parentd398fbf9e8d5f57b0003453685a48905a515dcc0 (diff)
downloadpackages-c1c136f0ac3f15feaf35416c7cdbdd080774dd9c.tar.gz
packages-c1c136f0ac3f15feaf35416c7cdbdd080774dd9c.tar.bz2
packages-c1c136f0ac3f15feaf35416c7cdbdd080774dd9c.tar.xz
packages-c1c136f0ac3f15feaf35416c7cdbdd080774dd9c.zip
user/libgweather: new package
-rw-r--r--user/libgweather/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/user/libgweather/APKBUILD b/user/libgweather/APKBUILD
new file mode 100644
index 000000000..316b94090
--- /dev/null
+++ b/user/libgweather/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Síle Ekaterin Liszka <sheila@vulpine.house>
+# Maintainer: Síle Ekaterin Liszka <sheila@vulpine.house>
+pkgname=libgweather
+pkgver=4.4.0
+pkgrel=0
+pkgdesc="Gnome weather library"
+url="https://gnome.pages.gitlab.gnome.org/libgweather/"
+arch="all"
+options="!check" # broken tests
+license="GPL-2.0-only AND LGPL-2.1-only AND LGPL-2.0-only AND BSD-3-Clause"
+depends=""
+makedepends="meson ninja geocode-glib-dev gi-docgen glib-dev
+ gobject-introspection-dev json-glib-dev libsoup3-dev libxml2-dev
+ py3-pygobject vala-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
+
+build() {
+ meson setup \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ --wrap-mode=nofallback \
+ . output
+ meson compile -C output
+}
+
+check() {
+ meson test --no-rebuild -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+}
+
+sha512sums="dd232d36b168132a7c7cf06ffff16e88eb6e3e9e003e39b975df3d294ada401ab7d34de386dcc53452de6b0f8c68ff7f0cf6a94492e353828e00d4a1204b5d00 libgweather-4.4.0.tar.xz"