summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-02-03 21:22:26 +0000
committerZach van Rijn <me@zv.io>2022-06-12 23:51:58 +0000
commit5635628480f681960b76eddcbd04a2e62668f822 (patch)
tree4f2d3af0280b7acc3f2d709f995a8e01823217f8
parentba19b09fa90640a39a711af2c85b36a818ab9837 (diff)
downloadpackages-5635628480f681960b76eddcbd04a2e62668f822.tar.gz
packages-5635628480f681960b76eddcbd04a2e62668f822.tar.bz2
packages-5635628480f681960b76eddcbd04a2e62668f822.tar.xz
packages-5635628480f681960b76eddcbd04a2e62668f822.zip
user/qt5-qtscxml: new package.
-rw-r--r--user/qt5-qtscxml/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/user/qt5-qtscxml/APKBUILD b/user/qt5-qtscxml/APKBUILD
new file mode 100644
index 000000000..79288cfd5
--- /dev/null
+++ b/user/qt5-qtscxml/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Zach van Rijn <me@zv.io>
+pkgname=qt5-qtscxml
+_pkgname=${pkgname#*-}-everywhere-src
+pkgver=5.15.3_git20201027
+pkgrel=0
+_commit=7a15000f42c7a3171719727cd056f82a78244ed7
+pkgdesc="Qt5 SCXML module provides classes for embedding state machines created from State Chart XML (SCXML) files in Qt applications"
+url="https://www.qt.io/"
+arch="all"
+license="LGPL-3.0-only WITH Qt-LGPL-exception-1.1 OR GPL-3.0-only WITH Qt-GPL-exception-1.0"
+depends=""
+makedepends="qt5-qtbase-dev"
+subpackages="$pkgname-dev"
+source="https://invent.kde.org/qt/qt/${pkgname#*-}/-/archive/$_commit/${pkgname#*-}-$_commit.tar.gz"
+builddir="$srcdir"/${pkgname#*-}-$_commit
+
+prepare() {
+ default_prepare
+
+ # Make configure think we are running in a git directory
+ # This makes it symlink the include files to the right directory
+ mkdir .git
+}
+
+build() {
+ qmake
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make install INSTALL_ROOT="$pkgdir"
+}
+
+sha512sums="2d99952208044db1405b456570d0a5e4d0ec7e9fd9aaf64935d81822218802f8ab6132276e52e4fa0ec4407f25e815a429c0b17c367665cb71a212c14b875654 qtscxml-7a15000f42c7a3171719727cd056f82a78244ed7.tar.gz"