summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-02-03 19:25:31 +0000
committerZach van Rijn <me@zv.io>2022-06-12 23:51:58 +0000
commitbf44c6cf326281ae4d4df760b97280b6c39c7502 (patch)
tree5f02adf581b49d1d9932e98c48eda56b4e721a7c
parentba6fc027852ebc935ab8327665295f236df518fc (diff)
downloadpackages-bf44c6cf326281ae4d4df760b97280b6c39c7502.tar.gz
packages-bf44c6cf326281ae4d4df760b97280b6c39c7502.tar.bz2
packages-bf44c6cf326281ae4d4df760b97280b6c39c7502.tar.xz
packages-bf44c6cf326281ae4d4df760b97280b6c39c7502.zip
user/qt5-qtgamepad: new package.
-rw-r--r--user/qt5-qtgamepad/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/user/qt5-qtgamepad/APKBUILD b/user/qt5-qtgamepad/APKBUILD
new file mode 100644
index 000000000..1d317820e
--- /dev/null
+++ b/user/qt5-qtgamepad/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Zach van Rijn <me@zv.io>
+pkgname=qt5-qtgamepad
+_pkgname=${pkgname#*-}-everywhere-src
+pkgver=5.15.3_git20201027
+pkgrel=0
+_commit=64afa18a0a1e9588060e2e6d917bb01ccdd48a81
+pkgdesc="Qt5 plugin enables applications to support the use of gamepad hardware and in some cases remote control equipment"
+url="https://www.qt.io/"
+arch="all"
+license="LGPL-3.0-only WITH Qt-LGPL-exception-1.1 OR GPL-3.0-only WITH Qt-GPL-exception-1.0"
+depends=""
+makedepends="qt5-qtbase-dev eudev-dev"
+subpackages="$pkgname-dev"
+source="https://invent.kde.org/qt/qt/${pkgname#*-}/-/archive/$_commit/${pkgname#*-}-$_commit.tar.gz"
+builddir="$srcdir"/${pkgname#*-}-$_commit
+
+prepare() {
+ default_prepare
+
+ # Make configure think we are running in a git directory
+ # This makes it symlink the include files to the right directory
+ mkdir .git
+}
+
+build() {
+ qmake
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make install INSTALL_ROOT="$pkgdir"
+}
+
+sha512sums="2e6cec5d93ae39c39638b00d22491e91b043f4c819b66a0d95d0b05cee66f82dd8e440efc2afc193dc1a7d2c3979d1d9711d3ff0c7a384ac5c1cb27ca7995b78 qtgamepad-64afa18a0a1e9588060e2e6d917bb01ccdd48a81.tar.gz"