summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZach van Rijn <me@zv.io>2022-02-03 19:30:44 +0000
committerZach van Rijn <me@zv.io>2022-06-12 23:51:58 +0000
commitd3983ecd67d52c53bdb63e1dcaee88d74b0b517f (patch)
tree919a09bb7e1b535f3589356db49e2904179273a2
parentaec07048439bd2696e5a817b3732af9b6655be94 (diff)
downloadpackages-d3983ecd67d52c53bdb63e1dcaee88d74b0b517f.tar.gz
packages-d3983ecd67d52c53bdb63e1dcaee88d74b0b517f.tar.bz2
packages-d3983ecd67d52c53bdb63e1dcaee88d74b0b517f.tar.xz
packages-d3983ecd67d52c53bdb63e1dcaee88d74b0b517f.zip
user/qt5-qtlottie: new package.
-rw-r--r--user/qt5-qtlottie/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/user/qt5-qtlottie/APKBUILD b/user/qt5-qtlottie/APKBUILD
new file mode 100644
index 000000000..3fffd2b6c
--- /dev/null
+++ b/user/qt5-qtlottie/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Zach van Rijn <me@zv.io>
+pkgname=qt5-qtlottie
+_pkgname=${pkgname#*-}-everywhere-src
+pkgver=5.15.3_git20201027
+pkgrel=0
+_commit=fa8c8bfc6742ab98b61d1351e054e0e73e9a42f4
+pkgdesc="Qt5 Lottie Animation provides a QML API for rendering graphics and animations that are exported in JSON format"
+url="https://www.qt.io/"
+arch="all"
+license="LGPL-3.0-only WITH Qt-LGPL-exception-1.1 OR GPL-3.0-only WITH Qt-GPL-exception-1.0"
+depends=""
+makedepends="qt5-qtbase-dev qt5-qtdeclarative-dev"
+subpackages="$pkgname-dev"
+source="https://invent.kde.org/qt/qt/${pkgname#*-}/-/archive/$_commit/${pkgname#*-}-$_commit.tar.gz"
+builddir="$srcdir"/${pkgname#*-}-$_commit
+
+prepare() {
+ default_prepare
+
+ # Make configure think we are running in a git directory
+ # This makes it symlink the include files to the right directory
+ mkdir .git
+}
+
+build() {
+ qmake
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make install INSTALL_ROOT="$pkgdir"
+}
+
+sha512sums="38c8ad9ece8aba1ed6fba69f59ae084446836ae881760a4cde311bd9700ce0c86f00769607b299f449ebfd85ce7c07a504fd8c78fbe7e01b57356032cc9813bf qtlottie-fa8c8bfc6742ab98b61d1351e054e0e73e9a42f4.tar.gz"