summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-11-08 11:44:14 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-11-08 11:44:43 -0600
commit17e9fdacccb89e1a515ec1defc0fafc7a79adf45 (patch)
treeed74b5cdab2a535652ae7a49a8afd4a4982a53d7
parent69dbc7009355b91fd65139fd63c2e379d6ad4775 (diff)
downloadpackages-wayland/improvements.tar.gz
packages-wayland/improvements.tar.bz2
packages-wayland/improvements.tar.xz
packages-wayland/improvements.zip
user/wayland-protocols: Update to 1.38wayland/improvements
Also updates the test patch to be applicable to all tests. This patch has been submitted upstream and the upstream URL is included.
-rw-r--r--user/wayland-protocols/APKBUILD8
-rw-r--r--user/wayland-protocols/test.patch66
-rw-r--r--user/wayland-protocols/tests.patch53
3 files changed, 57 insertions, 70 deletions
diff --git a/user/wayland-protocols/APKBUILD b/user/wayland-protocols/APKBUILD
index 43b7fb585..3c5e8da43 100644
--- a/user/wayland-protocols/APKBUILD
+++ b/user/wayland-protocols/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Sile Ekaterin Liszka <sheila@vulpine.house>
pkgname=wayland-protocols
-pkgver=1.36
+pkgver=1.38
pkgrel=0
pkgdesc="Protocols and protocol extensions complementing the Wayland core protocol"
url="https://wayland.freedesktop.org"
@@ -12,7 +12,7 @@ makedepends="wayland-dev meson"
subpackages=""
provides="$pkgname-dev"
source="https://gitlab.freedesktop.org/wayland/$pkgname/-/releases/$pkgver/downloads/$pkgname-$pkgver.tar.xz
- test.patch
+ tests.patch
"
build() {
@@ -35,5 +35,5 @@ package() {
DESTDIR="$pkgdir" ninja -C build install
}
-sha512sums="5448b9aedc953ce6be0f378da900c195c8743cb6001f615823b5fc9cab3e3ee54271132055743278e10decef7f8e9dcdeef31593a2a12062575fb90eb0084be0 wayland-protocols-1.36.tar.xz
-659220b5e3fab4a2e6bb017d6fde33fd2cb1424e9e8778829c089e2f422abcdbaae44661ab9c62160046ccf8c3b397da055478194690de057758563d18c62610 test.patch"
+sha512sums="43fc36d35bedb245deed0e2de246f42d2bbfa6ecafa094f2a7fb103d6df8ae28f3cc200bc5aa24745b9131a28381883c24779da0a6d9ac954753bd5ebb1405db wayland-protocols-1.38.tar.xz
+adf31ede543514317d57dbd4966034ffbd03e0745701d69c9a852d4b8388542fbb350ce3b32020192dfdbe90fe3a9a1e0ce1d472d9a8be695006652b704ab3f6 tests.patch"
diff --git a/user/wayland-protocols/test.patch b/user/wayland-protocols/test.patch
deleted file mode 100644
index b7a5e26ea..000000000
--- a/user/wayland-protocols/test.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-xdg-decoration-unstable-v1 needs xdg-toplevel but does not define it.
-This leads to a linker failure on at least ppc64.
-
---- wayland-protocols-1.25/tests/meson.build.old 2022-01-28 10:00:40.731421000 -0600
-+++ wayland-protocols-1.25/tests/meson.build 2022-07-02 20:09:54.653454716 -0500
-@@ -88,32 +88,34 @@
- ]
-
- # Check that header can be included by a pedantic C99 compiler
-- test_name = 'test-build-pedantic-@0@'.format(protocol_file.underscorify())
-- test_name_source = '@0@.c'.format(test_name)
-- test_source = custom_target(
-- test_name_source,
-- input: 'build-pedantic.c.in',
-- output: test_name_source,
-- command: replace_command,
-- )
-- pedantic_test_executable = executable(
-- test_name,
-- [
-- test_source,
-- client_header,
-- server_header,
-- code
-- ],
-- link_args: extra_linker_flags,
-- dependencies: libwayland,
-- c_args: [
-- '-std=c99',
-- '-pedantic',
-- '-Wall',
-- '-Werror' ],
-- install: false,
-- )
-- test(test_name, pedantic_test_executable)
-+ if not protocol_file.contains('xdg-decoration-unstable-v1')
-+ test_name = 'test-build-pedantic-@0@'.format(protocol_file.underscorify())
-+ test_name_source = '@0@.c'.format(test_name)
-+ test_source = custom_target(
-+ test_name_source,
-+ input: 'build-pedantic.c.in',
-+ output: test_name_source,
-+ command: replace_command,
-+ )
-+ pedantic_test_executable = executable(
-+ test_name,
-+ [
-+ test_source,
-+ client_header,
-+ server_header,
-+ code
-+ ],
-+ link_args: extra_linker_flags,
-+ dependencies: libwayland,
-+ c_args: [
-+ '-std=c99',
-+ '-pedantic',
-+ '-Wall',
-+ '-Werror' ],
-+ install: false,
-+ )
-+ test(test_name, pedantic_test_executable)
-+ endif
-
- # Check that the header
- if not protocol_file.contains('xdg-foreign-unstable-v1')
diff --git a/user/wayland-protocols/tests.patch b/user/wayland-protocols/tests.patch
new file mode 100644
index 000000000..d8d5dc3ca
--- /dev/null
+++ b/user/wayland-protocols/tests.patch
@@ -0,0 +1,53 @@
+Upstream-URL: https://gitlab.freedesktop.org/wayland/wayland-protocols/-/merge_requests/363
+
+From 8b4c76275fa1b6e0a99a53494151d9a2c907144d Mon Sep 17 00:00:00 2001
+From: "A. Wilcox" <AWilcox@Wilcox-Tech.com>
+Date: Fri, 8 Nov 2024 11:27:25 -0600
+Subject: [PATCH] tests: Make build-only tests actually build-only
+
+The goal behind the pedantic compiler tests are to ensure that the code
+that wayland-scanner is generating can be compiled in pedantic mode by
+the system C compiler.
+
+Trying to execute the built tests may fail because of undefined symbols.
+This affects certain platforms more than others; Linux/musl and Darwin
+are examples of platforms that cannot execute binaries with undefined
+symbols. This meant tests needlessly failed on these platforms.
+
+Signed-off-by: A. Wilcox <AWilcox@Wilcox-Tech.com>
+Closes: #48, #228
+---
+ tests/meson.build | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/tests/meson.build b/tests/meson.build
+index aa216ec..5a93bb3 100644
+--- a/tests/meson.build
++++ b/tests/meson.build
+@@ -1,4 +1,5 @@
+ prog_scan_sh = find_program('scan.sh')
++prog_true = find_program('true')
+
+ libwayland = [
+ dependency('wayland-client'),
+@@ -100,7 +101,7 @@ foreach protocol_file : protocol_files
+ test_source,
+ client_header,
+ server_header,
+- code
++ code,
+ ],
+ link_args: extra_linker_flags,
+ dependencies: libwayland,
+@@ -111,7 +112,7 @@ foreach protocol_file : protocol_files
+ '-Werror' ],
+ install: false,
+ )
+- test(test_name, pedantic_test_executable)
++ test(test_name, prog_true, depends : [pedantic_test_executable])
+
+ # Check that the header
+ if not protocol_file.contains('xdg-foreign-unstable-v1')
+--
+2.40.0
+