summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-23 22:39:19 -0600
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2019-12-23 22:39:19 -0600
commit222fb21c28d6250196100eb89ff6a076c703fd5c (patch)
tree7d6d42648c34bd6e21bae829c3fc8fed3cc2c1db
parent934414d79caa3489077e4f442bf023bca0e06614 (diff)
downloadpackages-222fb21c28d6250196100eb89ff6a076c703fd5c.tar.gz
packages-222fb21c28d6250196100eb89ff6a076c703fd5c.tar.bz2
packages-222fb21c28d6250196100eb89ff6a076c703fd5c.tar.xz
packages-222fb21c28d6250196100eb89ff6a076c703fd5c.zip
user/libexecinfo: move to system/ repository
This is required by CMake 3.15+; the dependency wasn't noticed because a full distro rebuild hasn't been done since before the CMake bump.
-rw-r--r--system/libexecinfo/10-execinfo.patch (renamed from user/libexecinfo/10-execinfo.patch)0
-rw-r--r--system/libexecinfo/20-define-gnu-source.patch (renamed from user/libexecinfo/20-define-gnu-source.patch)0
-rw-r--r--system/libexecinfo/30-linux-makefile.patch (renamed from user/libexecinfo/30-linux-makefile.patch)0
-rw-r--r--system/libexecinfo/APKBUILD (renamed from user/libexecinfo/APKBUILD)6
4 files changed, 1 insertions, 5 deletions
diff --git a/user/libexecinfo/10-execinfo.patch b/system/libexecinfo/10-execinfo.patch
index 97bd8cd5d..97bd8cd5d 100644
--- a/user/libexecinfo/10-execinfo.patch
+++ b/system/libexecinfo/10-execinfo.patch
diff --git a/user/libexecinfo/20-define-gnu-source.patch b/system/libexecinfo/20-define-gnu-source.patch
index ac18f6eeb..ac18f6eeb 100644
--- a/user/libexecinfo/20-define-gnu-source.patch
+++ b/system/libexecinfo/20-define-gnu-source.patch
diff --git a/user/libexecinfo/30-linux-makefile.patch b/system/libexecinfo/30-linux-makefile.patch
index f832adce7..f832adce7 100644
--- a/user/libexecinfo/30-linux-makefile.patch
+++ b/system/libexecinfo/30-linux-makefile.patch
diff --git a/user/libexecinfo/APKBUILD b/system/libexecinfo/APKBUILD
index 6951797d8..0d240b86c 100644
--- a/user/libexecinfo/APKBUILD
+++ b/system/libexecinfo/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libexecinfo
pkgver=1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Library for inspecting backtraces"
url="https://www.freshports.org/devel/libexecinfo"
arch="all"
@@ -17,19 +17,15 @@ source="https://pkg.freebsd.org/local-distfiles/itetcu/$pkgname-$pkgver.tar.bz2
"
build() {
- cd "$builddir"
make
}
check() {
- cd "$builddir"
${CC:-cc} -I. -L. -ggdb -fno-omit-frame-pointer $CFLAGS -o test test.c -lexecinfo
./test
}
package() {
- cd "$builddir"
-
install -D -m755 "$builddir"/execinfo.h \
"$pkgdir"/usr/include/execinfo.h
install -D -m755 "$builddir"/stacktraverse.h \