summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErmine <mustela@erminea.space>2024-08-31 11:49:20 +0000
committerErmine <mustela@erminea.space>2024-09-01 12:54:04 +0000
commit8036f7b83b4d6c03b0e006883ad84ecfd2441cf6 (patch)
treec62c087e2594eedaea4ecfda5d4857c765f58b79
parentc4ebb7f8bcab3303cf23ce788c3eb7f598999bfe (diff)
downloadpackages-8036f7b83b4d6c03b0e006883ad84ecfd2441cf6.tar.gz
packages-8036f7b83b4d6c03b0e006883ad84ecfd2441cf6.tar.bz2
packages-8036f7b83b4d6c03b0e006883ad84ecfd2441cf6.tar.xz
packages-8036f7b83b4d6c03b0e006883ad84ecfd2441cf6.zip
user/libxkbcommon: upgrade to 1.7.0, enable wayland support
-rw-r--r--user/libxkbcommon/APKBUILD59
1 files changed, 48 insertions, 11 deletions
diff --git a/user/libxkbcommon/APKBUILD b/user/libxkbcommon/APKBUILD
index a4be5d572..78be9fe38 100644
--- a/user/libxkbcommon/APKBUILD
+++ b/user/libxkbcommon/APKBUILD
@@ -1,33 +1,70 @@
# Contributor: Ariadne Conill <ariadne@dereferenced.org>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=libxkbcommon
-pkgver=0.10.0
+pkgver=1.7.0
pkgrel=0
pkgdesc="Keyboard handling library"
url="https://www.xkbcommon.org/"
arch="all"
license="MIT AND X11"
depends="xkeyboard-config"
-checkdepends="bash"
-makedepends="bison doxygen flex libxcb-dev meson ninja util-macros
- xorgproto-dev"
-subpackages="$pkgname-dev $pkgname-doc"
+checkdepends="bash xvfb"
+makedepends="bison doxygen libxcb-dev meson libxml2-dev wayland-dev
+ graphviz wayland-protocols"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-tools
+ $pkgname-tools-doc:xkbcli_doc $pkgname-tools-bash-completion:bashcomp"
source="https://www.xkbcommon.org/download/libxkbcommon-$pkgver.tar.xz"
build() {
- meson \
+ meson setup \
-Dprefix=/usr \
- -Denable-wayland=false \
+ -Denable-docs=true \
build
- ninja -C build
+ meson compile -C build
}
check() {
- ninja -C build test
+ meson test -C build
}
package() {
- DESTDIR="$pkgdir" ninja -C build install
+ DESTDIR="$pkgdir" meson install -C build
}
-sha512sums="58c523b42a8ea0cae7322d453fbc5d4624374221246cb067074e2ff9820eef3ceea8686283136432cdf0842acfc0858c7b2d3954de234b6501092ae1d27c9e79 libxkbcommon-0.10.0.tar.xz"
+doc() {
+ pkgdesc="Keyboard handling library (documentation)"
+ install_if="docs $pkgname=$pkgver-r$pkgrel"
+ # Library docs are in HTML in /usr/share/doc, while xkbcli
+ # docs are man pages. So we move doc directory to the subpackage...
+ mkdir -p "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/share/doc "$subpkgdir"/usr/share
+}
+
+tools() {
+ pkgdesc="xkb command-line tool with interactive debugger"
+
+ mkdir -p "$subpkgdir"/usr/bin
+ mkdir -p "$subpkgdir"/usr/libexec/xkbcommon
+
+ mv "$pkgdir"/usr/bin/xkbcli "$subpkgdir"/usr/bin/
+ mv "$pkgdir"/usr/libexec/xkbcommon "$subpkgdir"/usr/libexec/
+}
+
+xkbcli_doc() {
+ # ...and run default_doc here to let abuild process man pages properly
+ default_doc
+ pkgdesc="xkb command-line tool with interactive debugger (doc)"
+ install_if="docs $pkgname-tools=$pkgver-r$pkgrel"
+}
+
+bashcomp() {
+ pkgdesc="xkb command-line tool with interactive debugger (bash completions)"
+ depends=""
+ install_if="$pkgname-tools=$pkgver-r$pkgrel bash-completion"
+
+ mkdir -p "$subpkgdir"/usr/share/bash-completion/completions
+ mv "$pkgdir"/usr/share/bash-completion/completions/xkbcli \
+ "$subpkgdir"/usr/share/bash-completion/completions/
+}
+
+sha512sums="4b74a9f3f63e2ebc1cbdcaa963c70362e55fa527e1d89b6a1fd30d7a84a8b60c1b3dc99bcfbde85aa31890e0b2f62f0bad3c8ff8340fe6a930ee662b33448ba5 libxkbcommon-1.7.0.tar.xz"