summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErmine <mustela@erminea.space>2024-08-31 11:50:25 +0000
committerErmine <mustela@erminea.space>2024-09-01 12:54:04 +0000
commitc26324a95e2236ebcb3e9e4173219a04604c5183 (patch)
treececbd7b4144e3480b8a229ae87ac71e4a88e1b6c
parent8036f7b83b4d6c03b0e006883ad84ecfd2441cf6 (diff)
downloadpackages-c26324a95e2236ebcb3e9e4173219a04604c5183.tar.gz
packages-c26324a95e2236ebcb3e9e4173219a04604c5183.tar.bz2
packages-c26324a95e2236ebcb3e9e4173219a04604c5183.tar.xz
packages-c26324a95e2236ebcb3e9e4173219a04604c5183.zip
user/xwayland: new package
-rw-r--r--user/xwayland/APKBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/user/xwayland/APKBUILD b/user/xwayland/APKBUILD
new file mode 100644
index 000000000..012770875
--- /dev/null
+++ b/user/xwayland/APKBUILD
@@ -0,0 +1,57 @@
+# Contributor: Łukasz Jendrysik <scadu@yandex.com>
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Contributor: Simon Zeni <simon@bl4ckb0ne.ca>
+# Maintainer: Ermine <mustela@erminea.space>
+pkgname=xwayland
+pkgver=24.1.1
+pkgrel=0
+pkgdesc="X11 server for Wayland"
+url="https://www.X.Org/"
+arch="all"
+options="!check" # requires piglit, which has no stable releases
+license="MIT AND X11"
+subpackages="$pkgname-dbg $pkgname-dev $pkgname-doc"
+depends="xorg-server-protocol xkbcomp"
+depends_dev="dbus-dev font-util-dev libdrm-dev libepoxy-dev openssl-dev
+ libxcvt-dev libxfont2-dev libxkbfile-dev mesa-dev pixman-dev wayland-dev
+ wayland-protocols xorgproto xtrans"
+makedepends="$depends_dev meson"
+source="https://xorg.freedesktop.org/archive/individual/xserver/xwayland-$pkgver.tar.xz"
+
+replaces="xorg-server-xwayland"
+
+build() {
+ meson setup \
+ -Dprefix=/usr \
+ -Dipv6=true \
+ -Dxvfb=false \
+ -Dxdmcp=false \
+ -Dxcsecurity=true \
+ -Ddri3=true \
+ -Dglamor=true \
+ -Dsecure-rpc=false \
+ -Dxkb_dir=/usr/share/X11/xkb \
+ -Dxkb_output_dir=/var/lib/xkb \
+ . output
+ meson compile -C output
+}
+
+check() {
+ meson test --no-rebuild --print-errorlogs -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
+
+ # Part of xorg-server-doc
+ rm -f "$pkgdir"/usr/share/man/man1/Xserver.1
+
+ # Part of xorg-server-protocol
+ rm -f "$pkgdir"/usr/lib/xorg/protocol.txt
+}
+
+sha512sums="
+e44f47adab3830846360fd05fdc06d9016832133c662f2e4b0763b98de0c9b48dbfce7d757ffea5538b5fabb68170e5d1057acc1b9a086e396b147deaa750998 xwayland-24.1.1.tar.xz
+42db6616a6566acedaa0c5dc125435183be0c0da5df4f542bf3857a1905ae4646d5eb311e4e00ec892c845a2dc2069f6e68f5f45ec6c499ea32b8e55d873a0f5 use-libtirpc-nokrb.patch
+"
+sha512sums="e44f47adab3830846360fd05fdc06d9016832133c662f2e4b0763b98de0c9b48dbfce7d757ffea5538b5fabb68170e5d1057acc1b9a086e396b147deaa750998 xwayland-24.1.1.tar.xz"