summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-05-30 19:38:13 -0500
committerZach van Rijn <me@zv.io>2024-06-03 01:22:29 +0000
commit208002100f45bad5d5969f07f356196026bb73ba (patch)
treea6db42c727dd7cc9648af0e0165f2d9e0e9773b1
parent9868b1371e67494be8488ee807740a710e2dfed4 (diff)
downloadpackages-208002100f45bad5d5969f07f356196026bb73ba.tar.gz
packages-208002100f45bad5d5969f07f356196026bb73ba.tar.bz2
packages-208002100f45bad5d5969f07f356196026bb73ba.tar.xz
packages-208002100f45bad5d5969f07f356196026bb73ba.zip
user/qt-creator: Patch missing header
-rw-r--r--user/qt-creator/APKBUILD6
-rw-r--r--user/qt-creator/cstdint.patch27
2 files changed, 31 insertions, 2 deletions
diff --git a/user/qt-creator/APKBUILD b/user/qt-creator/APKBUILD
index 7ef7f7671..6039cf923 100644
--- a/user/qt-creator/APKBUILD
+++ b/user/qt-creator/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=qt-creator
pkgver=4.15.2
-pkgrel=0
+pkgrel=1
pkgdesc="Cross-platform multi-language programming IDE"
url="https://doc.qt.io/qtcreator/index.html"
arch="all"
@@ -16,6 +16,7 @@ subpackages="$pkgname-dev"
source="https://download.qt.io/official_releases/qtcreator/${pkgver%.*}/$pkgver/$pkgname-opensource-src-$pkgver.tar.xz
llvm13.patch
malloc_trim.patch
+ cstdint.patch
"
ldpath="/usr/lib/qtcreator"
builddir="$srcdir/$pkgname-opensource-src-$pkgver"
@@ -32,4 +33,5 @@ package() {
sha512sums="b29d5d97a1faa8d5756069d90c18d6d367e09057b97bd75c774bc2d1e373f9f4dcc24211188259f8d397bb932a65daaacda433bced796fd165654f5c3c621258 qt-creator-opensource-src-4.15.2.tar.xz
c38cf1aea69bc52864d5aa4b6fbc01b5e91b1514a616056b270fcccc2744bb418eb93a470462823c05e00e44f44c45d8e26effd8aa72a6817402ddd9a6dd0cc4 llvm13.patch
-7fcb9b293daecc4c0f294d372507db9a6282479c4cf45999446193d9f35552db2532d47dedc9c5666a10855e20d0fe655f0ee0408abca8cc8ffbf121a230960f malloc_trim.patch"
+7fcb9b293daecc4c0f294d372507db9a6282479c4cf45999446193d9f35552db2532d47dedc9c5666a10855e20d0fe655f0ee0408abca8cc8ffbf121a230960f malloc_trim.patch
+7d7a739cf98c1bc4232d9d14334e3c3a319746db931aaad4d441c903351c56869015ce427e2098fbe930d56a2dd433b1869fbbf5a78f91c10a94f5a47a778ea0 cstdint.patch"
diff --git a/user/qt-creator/cstdint.patch b/user/qt-creator/cstdint.patch
new file mode 100644
index 000000000..39558e90f
--- /dev/null
+++ b/user/qt-creator/cstdint.patch
@@ -0,0 +1,27 @@
+--- qt-creator-opensource-src-4.15.2/src/libs/qlitehtml/src/3rdparty/litehtml/include/litehtml/html.h.old 2021-07-12 21:12:54.000000000 -0500
++++ qt-creator-opensource-src-4.15.2/src/libs/qlitehtml/src/3rdparty/litehtml/include/litehtml/html.h 2024-05-30 18:51:05.965117572 -0500
+@@ -9,6 +9,7 @@
+ #include <cstring>
+ #include <algorithm>
+ #include <sstream>
++#include <cstdint>
+ #include "os_types.h"
+ #include "types.h"
+ #include "background.h"
+--- qt-creator-opensource-src-4.15.2/src/libs/qlitehtml/src/3rdparty/litehtml/include/litehtml/num_cvt.h.old 2021-07-12 21:12:54.000000000 -0500
++++ qt-creator-opensource-src-4.15.2/src/libs/qlitehtml/src/3rdparty/litehtml/include/litehtml/num_cvt.h 2024-05-30 18:54:29.873560575 -0500
+@@ -2,6 +2,7 @@
+ #define NUM_CVT_H
+
+ #include <string>
++#include <cstdint>
+ #include "os_types.h"
+
+ namespace litehtml
+@@ -16,4 +17,4 @@
+ }
+ }
+
+-#endif // NUM_CVT_H
+\ No newline at end of file
++#endif // NUM_CVT_H