summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-05-25 12:44:52 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-06-11 14:03:56 -0500
commit2f1c361f2858e55715044a8376311d74b832529e (patch)
tree88ebfbdee9523c931983470954c23c12fa31e8e8
parentbd1c8515b4a0ec44d53e117a0f47fa03ee46fe48 (diff)
downloadpackages-2f1c361f2858e55715044a8376311d74b832529e.tar.gz
packages-2f1c361f2858e55715044a8376311d74b832529e.tar.bz2
packages-2f1c361f2858e55715044a8376311d74b832529e.tar.xz
packages-2f1c361f2858e55715044a8376311d74b832529e.zip
system/sharutils: Update for GCC -fno-common default
-rw-r--r--system/sharutils/APKBUILD9
-rw-r--r--system/sharutils/modern-gcc.patch47
2 files changed, 53 insertions, 3 deletions
diff --git a/system/sharutils/APKBUILD b/system/sharutils/APKBUILD
index 67b264b53..7d74c1743 100644
--- a/system/sharutils/APKBUILD
+++ b/system/sharutils/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=sharutils
pkgver=4.15.2
-pkgrel=2
+pkgrel=3
pkgdesc="Utilities for manipulating shell archives"
url="https://www.gnu.org/software/sharutils/"
arch="all"
@@ -11,7 +11,9 @@ depends="bzip2"
makedepends_build="texinfo"
subpackages="$pkgname-lang $pkgname-doc"
source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz
- CVE-2018-1000097.patch"
+ CVE-2018-1000097.patch
+ modern-gcc.patch
+ "
# secfixes:
# 4.15.2-r2:
@@ -40,4 +42,5 @@ package() {
}
sha512sums="80d0b804a0617e11e5c23dc0d59b218bbf93e40aaf5e9a5401a18ef9cb700390aab711e2b2e2f26c8fd5b8ef99a91d3405e01d02cadabcba7639979314e59f8d sharutils-4.15.2.tar.xz
-6415da74c4f6f203bc4ad617bd05fa6ac86e1079538236148763e0b5e81ca8ea4004ea58e9e4755ba371246a7c469ef1e421576260494043d3ce3fc80e73cf69 CVE-2018-1000097.patch"
+6415da74c4f6f203bc4ad617bd05fa6ac86e1079538236148763e0b5e81ca8ea4004ea58e9e4755ba371246a7c469ef1e421576260494043d3ce3fc80e73cf69 CVE-2018-1000097.patch
+3938bd255cbc62953a8c2888525e0b8932df0df2628efbda285ba85ae2037fd1e32b6015f89663452c1d566fb7e27e648c0be4141a4c327e9744c07c86b523fd modern-gcc.patch"
diff --git a/system/sharutils/modern-gcc.patch b/system/sharutils/modern-gcc.patch
new file mode 100644
index 000000000..b42e0a7fb
--- /dev/null
+++ b/system/sharutils/modern-gcc.patch
@@ -0,0 +1,47 @@
+Upstream-URL: https://savannah.gnu.org/bugs/index.php?65790
+Upstream-Status: Pending
+
+--- sharutils-4.15.2/src/shar-opts.h.old 2015-05-30 10:34:12.000000000 -0500
++++ sharutils-4.15.2/src/shar-opts.h 2024-05-25 12:36:29.126495658 -0500
+@@ -352,7 +352,7 @@
+ * global exported definitions
+ */
+ #include "local.h"
+-char const * const program_name;
++extern char const * const program_name;
+
+ extern bool initialization_done;
+ extern int optidx;
+--- sharutils-4.15.2/src/unshar-opts.h.old 2015-05-30 10:34:18.000000000 -0500
++++ sharutils-4.15.2/src/unshar-opts.h 2024-05-25 12:36:07.748789737 -0500
+@@ -192,7 +192,7 @@
+ extern size_t separator_str_len;
+
+ #include "local.h"
+-char const * const program_name;
++extern char const * const program_name;
+
+
+ /* * * * * *
+--- sharutils-4.15.2/src/uudecode-opts.h.old 2015-05-30 10:34:21.000000000 -0500
++++ sharutils-4.15.2/src/uudecode-opts.h 2024-05-25 12:33:58.052707656 -0500
+@@ -170,7 +170,7 @@
+ * global exported definitions
+ */
+ #include "local.h"
+-char const * const program_name;
++extern char const * const program_name;
+
+
+ /* * * * * *
+--- sharutils-4.15.2/src/uuencode-opts.h.old 2015-05-30 10:34:25.000000000 -0500
++++ sharutils-4.15.2/src/uuencode-opts.h 2024-05-25 12:36:54.973721944 -0500
+@@ -166,7 +166,7 @@
+ * global exported definitions
+ */
+ #include "local.h"
+-char const * const program_name;
++extern char const * const program_name;
+
+
+ /* * * * * *