summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2024-05-29 20:47:20 -0500
committerA. Wilcox <AWilcox@Wilcox-Tech.com>2024-06-11 14:04:05 -0500
commit532b9bc729d7e7905bd711896fba319b354a13a1 (patch)
tree192e49193b57619e600375fd59a51284ed55901c
parent90577dcf0224b8e971b3c992bafc5ff33c35610c (diff)
downloadpackages-532b9bc729d7e7905bd711896fba319b354a13a1.tar.gz
packages-532b9bc729d7e7905bd711896fba319b354a13a1.tar.bz2
packages-532b9bc729d7e7905bd711896fba319b354a13a1.tar.xz
packages-532b9bc729d7e7905bd711896fba319b354a13a1.zip
user/htop: Update to 3.3.0
* New upstream URL and source. * Remove patches that were integrated upstream.
-rw-r--r--user/htop/APKBUILD19
-rw-r--r--user/htop/correctness.patch78
-rw-r--r--user/htop/fix-python-path.patch8
3 files changed, 6 insertions, 99 deletions
diff --git a/user/htop/APKBUILD b/user/htop/APKBUILD
index 69994dfab..602b2b9f1 100644
--- a/user/htop/APKBUILD
+++ b/user/htop/APKBUILD
@@ -1,20 +1,17 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=htop
-pkgver=2.2.0
-pkgrel=1
+pkgver=3.3.0
+pkgrel=0
pkgdesc="Interactive process viewer"
-url="http://hisham.hm/htop"
+url="https://htop.dev/"
arch="all"
options="!check" # No test suite.
license="GPL-2.0+"
depends=""
makedepends="libexecinfo-dev ncurses-dev python3"
subpackages="$pkgname-doc"
-source="http://hisham.hm/htop/releases/$pkgver/$pkgname-$pkgver.tar.gz
- correctness.patch
- fix-python-path.patch
- "
+source="https://github.com/htop-dev/htop/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"
build() {
LIBS="-lexecinfo" ./configure \
@@ -23,9 +20,7 @@ build() {
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var \
- --enable-cgroup \
- --enable-taskstats
+ --localstatedir=/var
make
}
@@ -33,6 +28,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="ec1335bf0e3e0387e5e50acbc508d0effad19c4bc1ac312419dc97b82901f4819600d6f87a91668f39d429536d17304d4b14634426a06bec2ecd09df24adc62e htop-2.2.0.tar.gz
-010ca1d42caeea133ba3d0383373a8eca849c73c95bb98fe3222c458c44320d1e2a3aee9431213721f1ccfcbd5af54eb1e54fafd6e0e5ca3b87499ee6d04b49a correctness.patch
-16358bcd6d83181cc04dd8a7971f7cc0804dc49995208bad2042bcca7962f562bbd008c2185f24aa6186c58896e94e4ec02e2053dc46ed14789889d64836b679 fix-python-path.patch"
+sha512sums="f98d4a4370954969d0ae16993d80ca5ce48670a711f17445de979513ac9caf2b197291732d937ae07d48709ded660ea09601b3a41ad7c48b3abb87e7a67deb65 htop-3.3.0.tar.xz"
diff --git a/user/htop/correctness.patch b/user/htop/correctness.patch
deleted file mode 100644
index 51a9848d2..000000000
--- a/user/htop/correctness.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-From: Jonathan Currier <dullfire@yahoo.com>
-
-diff --git a/MainPanel.h b/MainPanel.h
-index 8849659..471870b 100644
---- a/MainPanel.h
-+++ b/MainPanel.h
-@@ -12,6 +12,7 @@ in the source distribution for its full text.
- #include "Panel.h"
- #include "Action.h"
- #include "Settings.h"
-+#include "union-arg.h"
-
- typedef struct MainPanel_ {
- Panel super;
-@@ -21,11 +22,6 @@ typedef struct MainPanel_ {
- pid_t pidSearch;
- } MainPanel;
-
--typedef union {
-- int i;
-- void* v;
--} Arg;
--
- typedef bool(*MainPanel_ForeachProcessFn)(Process*, Arg);
-
- #define MainPanel_getFunctionBar(this_) (((Panel*)(this_))->defaultBar)
-diff --git a/Process.c b/Process.c
-index 471f529..ae617a6 100644
---- a/Process.c
-+++ b/Process.c
-@@ -548,7 +548,9 @@ bool Process_changePriorityBy(Process* this, int delta) {
- return Process_setPriority(this, this->nice + delta);
- }
-
--void Process_sendSignal(Process* this, int sgn) {
-+
-+void Process_sendSignal(Process* this, Arg arg) {
-+ int sgn = arg.i;
- CRT_dropPrivileges();
- kill(this->pid, (int) sgn);
- CRT_restorePrivileges();
-diff --git a/Process.h b/Process.h
-index f702ca0..3011845 100644
---- a/Process.h
-+++ b/Process.h
-@@ -29,6 +29,7 @@ in the source distribution for its full text.
- #include "Object.h"
-
- #include <sys/types.h>
-+#include "union-arg.h"
-
- #define PROCESS_FLAG_IO 0x0001
-
-@@ -199,7 +200,7 @@ bool Process_setPriority(Process* this, int priority);
-
- bool Process_changePriorityBy(Process* this, int delta);
-
--void Process_sendSignal(Process* this, int sgn);
-+void Process_sendSignal(Process* this, Arg arg);
-
- long Process_pidCompare(const void* v1, const void* v2);
-
-diff --git a/union-arg.h b/union-arg.h
-new file mode 100644
-index 0000000..5c8a094
---- /dev/null
-+++ b/union-arg.h
-@@ -0,0 +1,9 @@
-+#ifndef UNION_ARG_HEADER
-+#define UNION_ARG_HEADER
-+
-+typedef union {
-+ int i;
-+ void* v;
-+} Arg;
-+
-+#endif
-
diff --git a/user/htop/fix-python-path.patch b/user/htop/fix-python-path.patch
deleted file mode 100644
index 4d11bfb4a..000000000
--- a/user/htop/fix-python-path.patch
+++ /dev/null
@@ -1,8 +0,0 @@
---- a/scripts/MakeHeader.py
-+++ b/scripts/MakeHeader.py
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- import os, sys, string, io
- try:
- from StringIO import StringIO